1 5 6 7 8 9 Previous Next 130 Replies Latest reply: Mar 30, 2014 8:10 AM by Magwich Go to original post
  • 90. Re: cannot verify certificate "static.ak.facebook.com"
    chikojak Level 1 Level 1 (0 points)

    Yes, identical problem. What is maddening is that Safari asks "Do you want to connect anyway"? The obvious answer is NO. But you're not given that option. You're given three options (Cancel, etc.). I've clicked on all those and the certificate problem pops up the next time I open Safari.

  • 91. Re: cannot verify certificate "static.ak.facebook.com"
    canucksgirl01 Level 1 Level 1 (55 points)

    chikojak,

     

    You can follow the directions I posted in this thread. I've included more information there about this issue.

     

    Its really not that serious. The company "Akamai Network" is the hosting service for Apple, Microsoft, Facebook and Twitter. All the websites out there that use Facebook (such as a "Like" button), have their certificate posted and checked when the page loads. Akamai Network (who signed the certificates for Facebook), created a "mismatched" situation, which Safari has alerted us to.

     

    The problem has been corrected by Akamami, but it takes time before all the servers/websites that use Facebook get repopulated with the new certificate. The directions I posted can take care of the problem a lot faster, if you don't want to wait. The process just instructs Safari to run a verification check on ALL certificates. It can't be done with the options you have when the certificate error pops up.

  • 92. Re: cannot verify certificate "static.ak.facebook.com"
    S. G. Level 1 Level 1 (45 points)

    Thanks canucksgirl01,

     

    Your explanations are helpful, but the problem seems to be getting worse. It has been three days, and I still get the "can't connect to s-static.ak.facebook.com" on almost every webpage or link that I visit, including these Apple Discussions, NYTimes, Macrumors, etc... You said it would take a while to repopulate, though I would think that a site like the NYTimes or Apple would already have updated. I guess I will be patient, but I hate Facebook even more now, and starting to hate Safari too... Let me know if there is anything else I should do (I have verified the keychain certificates and already had Sophos antivirus installed). Thanks.

  • 93. Re: cannot verify certificate "static.ak.facebook.com"
    crampy Level 4 Level 4 (1,135 points)

    Hello S.G.-- that sounds awful. It corrected itself for me within two hours (way less, just did not time it) of my posting the first question.

    Have you checked for software updates? Have you emptied your caches (what OS are you? Caches now under the develop in menu)? Have you reset safari? Have you gone to safari>preferences>security and looked at your settings?

  • 94. Re: cannot verify certificate "static.ak.facebook.com"
    crampy Level 4 Level 4 (1,135 points)

    Hey there chikojak...I had hit on the Cancel tab, and nothing changed. I never hit continue, worrying it would take me to a strange page. Hitting cancel, I just stayed at the page I wanted to be on. After a while that night, days ago, all became normal again. Are you STILL having it happen? Where on earth are you?--not a rhetorical question- I mean it- continent will do...

  • 95. Re: cannot verify certificate "static.ak.facebook.com"
    canucksgirl01 Level 1 Level 1 (55 points)

    Hey S. G.

     

    Do you have Lion or Mountain Lion?

     

    There's a bit of a quirk with the certificates in that OS... So if that's what you have, follow the directions outlined in this link as it will fix the problem for you.

     

    http://b.rthr.me/wp/?p=356

     

    If that doesn't help, let me know.

  • 96. Re: cannot verify certificate "static.ak.facebook.com"
    borbye Level 1 Level 1 (5 points)

    Hi canucksgirl01.

     

    It is still happening to me despite blocking sites with LS, following your first instructions and later the instructions in your latest link.

     

    They are popping and popping...

  • 97. Re: cannot verify certificate "static.ak.facebook.com"
    chilira Level 1 Level 1 (0 points)

    just hit continue like i did.  digi certs expire.   unless you manually want to block it. 

  • 98. Re: cannot verify certificate "static.ak.facebook.com"
    canucksgirl01 Level 1 Level 1 (55 points)

    Hey borbye,

     

    Not sure what to suggest with that... I don't use Little Snitch.

     

    For a lot of people the problem just went away on its own (because Akamai Network update the cert), some had to use the first fix I posted (and some with Lion or ML had to use the other link I posted).

     

    See if clearing your cache and history makes a difference and then restart it. There is a small possiblity that loading from cache is continuing this problem for you. Or you may have to completely reset Safari if you can't get it to work otherwise, or just try disabling LS and revisit one of the problematic websites to see if it makes a difference (as part of the problem for you could be LS, but I can't say for sure).

  • 99. Re: cannot verify certificate "static.ak.facebook.com"
    S. G. Level 1 Level 1 (45 points)

    Hi Crampy and Canucksgirl01.

     

    I reset Safari, emptied the cache, the facebook alert is still popping up with every click. I have to switch to Firefox for surfing.

     

    I am using Safari 5.1.7 on OS 10.6.8 and everything is up to date.

     

    I am now even more upset because I lost all my settings and passwords with the reset, though I am grateful for your help.

     

    If I try to say Continue instead of Cancel, I am transferred to this facebook link (when I try to read the NYTimes for example):

    https://s-static.ak.facebook.com/connect/xd_arbiter.php?version=11#channel=fbae4 6a4&origin=http%3A%2F%2Fwww.nytimes.com&channel_path=%2Fpackages%2Fhtml%2Ffacebo ok%2Ffbchannel.html%3Ffb_xd_fragment%23xd_sig%3Df23f099c74%26

     

    This is a really bad security issue for Safari, as it redirects my pages. Are you sure it is not malware?

  • 100. Re: cannot verify certificate "static.ak.facebook.com"
    wright Level 1 Level 1 (0 points)

    Have you downlaoded any updates to your software, e.g., Silverlight, Java, etc?

     

    I

  • 101. Re: cannot verify certificate "static.ak.facebook.com"
    chilira Level 1 Level 1 (0 points)

    I updated Silverlight

  • 102. Re: cannot verify certificate "static.ak.facebook.com"
    crampy Level 4 Level 4 (1,135 points)

    I do not understand- reset safari changed settings? I reset safari every time I log out and sometimes during a session just to keep clean. I lose no bookmarks or preferences or anything.

    As to the last question you ask- all I am sure of is the thing stopped for me about an hour or so +/- some, from when i first posted the inquiry. I looked up the company and learned it provides services that a lot of sites use.

    Maybe you should contact them.  Are you also SURE that the error you get when going to a page matches EXACTLY the one I posted at the top of this thread?

    And I do not recall if I asked or if you answered, but did you go to Safari>preferences>security and tell us what settings you have there?

  • 103. Re: cannot verify certificate "static.ak.facebook.com"
    canucksgirl01 Level 1 Level 1 (55 points)

    Ya, I'm not sure what to say. You and I have the exact same OS version and browser version... and I had very little trouble correcting the certificate issue. However, the one you are having trouble with is technically different. We've all been complaining about static.ak.facebook.com, and your link is for s-static.ak.facebook.com. -- Not that that should make a difference, the verification process should validate (or reject) all your certs.

     

    S-static.ak.facebook.com is legit, but I can't tell if the s-static.ak.facebook.com certificate YOU have is malware without a screenshot of the details section expanded open (as its possible its a fake certificate).

     

    I didn't try your re-direct link, but I did go to the NY Times website to see if I got the same issue, but I did not.

     

    Also, as crampy said, I don't know why resetting Safari would have deleted your bookmarks etc... Now I feel bad for having suggested that (sorry).

  • 104. Re: cannot verify certificate "static.ak.facebook.com"
    wright Level 1 Level 1 (0 points)

    The problem appeared for me after I updated software but it was also at the same time that it appeared for everyone else. 

     

    • I did a total reset for my Safari - didn't work. 
    • I then upped my security,
    • Delated the Silverlight and Java updates,
    • Removed items from my Bookmark Bar that my son had added (ESPN that was linked to Facebook),
    • Did another total reset for Safari
    • then shutdown my computer instead of a Restarting- removed the back plug for the iMac, waited (15-20) seconds and then plugged it back in and went to Safari.  I visited a couple of sites and no longer had the certificate message popping up.  Added Java back in, surfed the web and still no certificate pop-ups.  Added Silverlight back in but this time I did not go to the Microsoft page - did it directly from my Netflix account. 
    • Successful - have updates and no more certificate issues. 

     

    I do not know which one of these steps cleared the problem or if it had been clered by an outside source. 

1 5 6 7 8 9 Previous Next