Previous 1 2 3 4 5 Next 119 Replies Latest reply: Oct 16, 2014 11:11 PM by Preston Holt Go to original post
  • Spare Tire Level 1 (0 points)

    Same problem here, newly imported CD/songs can't found in iTunes 11 library, but can be found in hard disk folder, also the new album/songs can be found on iTunes Match in which can download and play in iPhone / iPad.


    In iTunes search, newly imported CD/songs can be found, but can't be played. 

    In Spotlight search, newly imported CD/songs can be found and can be played in iTunes 11.

  • sim0nh0we Level 1 (0 points)

    CD's are importing but I am randomly finding specific tracks will not play with iTunes11... will play fine in Spoftify or Windows Media Player   grrrrrrr

  • Spare Tire Level 1 (0 points)

    It goes back to normal the day after....strange.

  • contour body lover Level 1 (0 points)

    Yes, al of a sudden it's working smooth on the nex day. Imported tracks are there, like if they had always been. Right now, importing some cds and it's all fine. Wich sorta makes it even stranger...

  • ohma81 Level 1 (0 points)

    What did work for me was de-selecting in the 'Sharing' section of the Preferences the following items:


    1) Show iTunes in the Cloud purchases

    2) Automatically download album artwork

    3) Share details of your library with Apple


    But am not sure, which one of the three fixed it in the end.

  • Jonny127 Level 1 (0 points)

    hey all!


    Well like the rest of you i've installed itunes 11 and was initially very excited by the new lay out blah blah blah.. however decided to go onto the store and bought two songs. neither of them come up in ANYTHING ELSE other than the purchased folder....which tbh i dont want to listen to because my gf has downloaded loads of stuff and her music is rubbish(wasnt allowed a swearword)!


    any thoughts/updates/help?




    P.S just read some of the comments above mine saying that all goes back to normal a day later.....thats still a day of listening to rubbish music!

  • iTraveller Level 1 (0 points)

    I don't use iTunes match and I was having the same problems with a new CD i tried to import.

    Signing out of the store and back in worked for me:



    - I turned on the sidebar and noticed that the little clouds next to "music" and "movies" were animated and moving

    - I signed out of the itunes store, then back in.

    - got a beach ball

    - the cloud animation stopped

    - all my stuff appeared properly

  • Ryantm2 Level 1 (0 points)

    Last night my songs imorted no problem now it won't let even play new mp3s if they came from a cd or a flashdrive  they only play if i purchased them from itunes

  • JenniferAL10 Level 1 (0 points)

    I just upgraded my iTunes today to the newest version, 11 and i plugged in my iPod classic as i always do every day to the computer to listen to music through iTunes.  iTunes is only showing the music that was purchased through iTunes ex. 200 songs, and not acknowledging my whole iPod as it always does in the past.  When I click on the top right tab for "my iPod" it does acknowledge that I do have more songs on my iPod example 500.  Where are the rest of my songs? and is there a way I can go back to the older version of iTunes so I can listen to my whole iPod instead? Thanks!

  • thejohnisjohn Level 1 (0 points)

    I have been having this issue for the past few days. What finally got my newly imported music to show up everywhere was simply going to the itunes store, signing out, and signing back in. When I did this, all of my recently added music was visible everywhere in iTunes. I think there is some sort of hitch in iTunes Match's giddyup (which I don't use).

  • markclea Level 1 (0 points)

    I posted this in another thread (there seems to be a couple of threads on this):


    My fix was to log out of the iTunes store (even though I had never logged into it). Repeat log in's and log out's, and still haven't had the problem of adding files to iTunes repeat itself.


    Here's a longer version:

    I had/have the problem of adding new songs to my library. I do not have iTunes Match. The library is on an external drive. Over 15,000 songs. On adding, the files got copied over, I can search for them in the iTunes search bar, but they don't appear in the iTunes library list, so I couldn't select them in iTunes to play. I'm not sure if this is linked, but my cloud icons in the sidebar appeared striped, as if it's sending or receiving information constantly. I had never logged into the iTunes store using iTunes 11, but my Apple ID appeared in the store header, when clicking on the store icon.


    To get the cloud icons to go away, I logged out of the iTunes store completely, by clicking sign-out (even though I had never logged in with iTunes 11). The cloud icons went away, and the added files then appeared in iTunes, without me having to re-add them.


    Just as a test, while logged out of the store, I deleted the files, re-added them, and they get added properly. I then repeated while logged into the store, and they appear as well. Then I quit iTunes while logged in to the store and added new files to it, and those appeared in the library as well. On successive launches of iTunes, the cloud icons go from striped to solid fairly quickly. Not sure if that's linked.

  • justliketoby Level 1 (0 points)

    Either way this is poor release. The user shouldn't have to turn off/on, uninstall/re-install everything.

    I'm afraid to say none of these work-arounds have worked for me.

    Anyone have any other ideas?

  • GregorShelby Level 1 (0 points)

    It was simple for me, though kind of annoying.


    You will find the music you are trying to open or import in iTunes under Playlists > Recently Added.


    From there you can add these songs to a playlist. When you mouse over the song title a little arrow appears next to it. Click that arrow, and it gives you a few different options, including "Add To". I was already importing songs to make a CD for my dad so in my case I already had a playlist made. Simply click "Add to..." and select which playlist you want to add it to. After doing that, I found that the songs were also in my main music library.


    There is also an option under this arrow called "Go To (artist name)". This may work as well to take you to your imported song.


    Hope this helps!!


    - Shelby

  • cjk77 Level 1 (0 points)

    GOT IT.

    Under sharing in iTunes preferences, deselect "Sync playback information across devices" and all my music I added appeared in my library


    And I was going to attach a photo with the screen showing it, but it wouldn't load. Funny since I'm using a MacBook Pro and screenshot it using an Apple program.

  • tauceti1 Level 1 (0 points)

    Wow, it seems like the secret to solving this problem is to change each and every preference until something randomly fixes it. Yikes!


    I'm still having this problem, despite following each suggestion in this thread. Hopefully there will be an update soon that fixes this. Adding music is pretty basic functionality!

Previous 1 2 3 4 5 Next