Previous 1 2 3 4 5 Next 111 Replies Latest reply: Jun 13, 2014 10:44 PM by GeorgeLe Go to original post
  • Kybber Level 1 (0 points)

    Problem Event Name: APPCRASH

    Application Name: iTunes.exe

    Application Version:

    Application Timestamp: 50b71fed

    Fault Module Name: StackHash_acff

    Fault Module Version:

    Fault Module Timestamp: 00000000

    Exception Code: c0000005

    Exception Offset: 00000000

    OS Version: 6.0.6002.

    Locale ID: 1033

    Additional Information 1: acff

    Additional Information 2: 14f3e5a9c38d3367a672d8ed0769d4b9

    Additional Information 3: 316f

    Additional Information 4: d410539e393c1bad5407687bfdcd55c1

  • Lou-ICE Level 1 (0 points)

    I've now tried the following and have no further progress on the store BEX error: 

    - reset the store cache,

    - changed the server certificate revocation setting for internet explorer,

    - followed the HOSTS reset instructions,

    - created a new user account,

    - uninstalled and reinstalled EMET (and toggled DEP settings for itunes application)


    Not sure what else to do . . . .   any further suggestions to defeat this issue? 

  • polydorus Level 6 (11,955 points)



    Resetting the store cache had no effect, nor were there any problem Winsock providers.


    I hope the Apple engineers pick this one up as they are the ones who know exactly what itunes is trying to do when the problem occurs.


    I tried running  Process monitor during the crash but couldn't get anything useful there.

  • kevin e. Level 1 (0 points)

    Okay, same thing happens here. I have removed and reinstalled all apple software, I have cleared all apple software links from the Registry, and have disabled my firewall. I have unchecked the check for server revokations in internet options, and flushed DNS.


    If i go to the store via app updates, then I can get in, and I can get to some areas, ie: productivity apps, but the screen is blank. if I try other areas, itunes crashes. If I select a main category, say Music, or applications, it crashes. It seems I can get further if I do not sign into my account.


    Autoruns shows only Bonjour and Bonjour64


    Windows Error Report:

    Fault bucket 3388102246, type 5

    Event Name: BEX

    Response: Not available

    Cab Id: 0



    Problem signature:

    P1: iTunes.exe


    P3: 50b71fed

    P4: StackHash_0a9e


    P6: 00000000

    P7: 00000000

    P8: c0000005

    P9: 00000008




    Attached files:




    These files may be available here:

    C:\Users\Kevin\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_iTunes .exe_48ba7f89d279f74f83524e7b70547712bc7c_0bf8956c



    Analysis symbol:

    Rechecking for solution: 0

    Report Id: e4c03091-3d4d-11e2-a60e-00016c704f04

    Report Status: 0



    Diagnostic from iTunes:


    Microsoft Windows 7 x64 Home Premium Edition Service Pack 1 (Build 7601)

    Packard Bell ixtreme M5740


    QuickTime 7.7.3

    FairPlay 2.2.32

    Apple Application Support 2.3.2

    iPod Updater Library 10.0d2

    CD Driver

    CD Driver DLL

    Apple Mobile Device

    Apple Mobile Device Driver

    Bonjour (333.10)

    Gracenote SDK

    Gracenote MusicID

    Gracenote Submit

    Gracenote DSP



    iTunes Serial Number 003AB7000A2A2058



    Current user is not an administrator.

    The current local date and time is 2012-12-03 14:34:52.

    iTunes is not running in safe mode.

    WebKit accelerated compositing is enabled.

    HDCP is supported.

    Core Media is supported.



    Video Display Information



    NVIDIA, NVIDIA GeForce 9500 GT





    **** External Plug-ins Information ****



    No external plug-ins installed.



    iPodService (x64) is currently running.

    iTunesHelper is currently running.

    Apple Mobile Device service is currently running.



    **** Network Connectivity Tests ****



    Network Adapter Information



    Adapter Name:          {3E2823A1-B779-4306-99A2-608BF0D9F41A}

    Description:          Intel(R) 82578DC Gigabit Network Connection

    IP Address:

    Subnet Mask:

    Default Gateway:

    DHCP Enabled:          Yes

    DHCP Server:

    Lease Obtained:          Mon Dec 03 13:18:07 2012



    Lease Expires:          Tue Dec 04 13:18:07 2012



    DNS Servers:



    Adapter Name:          {4C642265-B6C2-4AB9-A769-D3E744D262EE}

    Description:          VirtualBox Host-Only Ethernet Adapter

    IP Address:

    Subnet Mask:

    Default Gateway:

    DHCP Enabled:          No

    DHCP Server:

    Lease Obtained:          Thu Jan 01 01:00:00 1970



    Lease Expires:          Thu Jan 01 01:00:00 1970



    DNS Servers:



    Active Connection:          LAN Connection

    Connected:          Yes

    Online:                    Yes

    Using Modem:          No

    Using LAN:          Yes

    Using Proxy:          No



    Firewall Information





    Connection attempt to Apple web site was successful.

    Connection attempt to browsing iTunes Store was successful.

    Connection attempt to purchasing from iTunes Store was successful.

    Connection attempt to iPhone activation server was successful.

    Connection attempt to firmware update server was successful.

    Connection attempt to Gracenote server was successful.

    Last successful iTunes Store access was 2012-12-03 14:34:21.

  • RossFromAZ Level 1 (0 points)

    I believe this is linked to a similar issue on Safari when using custom fonts (web fonts). On certain systems/configurations, Safari will crash anytime a web font is loaded. Since the iTunes Store also appears to use webfonts (from what I can tell on another system) and, most likely, uses the same rendering engine that the now discontinued Safari for Windows uses, it stands to reason that this is related.

  • b noir Level 9 (72,050 points)

    I hope the Apple engineers pick this one up as they are the ones who know exactly what itunes is trying to do when the problem occurs.


    Yeah ... I think we'd need to try getting a ProcDump from you at the time when the application crashes. (I did that for Jason once, with a clicking-on-artwork crash in an older version that I was able to replicate.) Filthy-huge files they are.


    Maybe we could pursue that in the Lounge? (It's possible that the Hosts don't realise you can replicate/generate this error, and don't realise we've got an available affected machine for the engineers to do the test on.)

  • gn_id Level 1 (10 points)

    Anyone having any luck on this?  I am having the exact same issue after installing iTunes 11 - removing and reinstalling has no effect whatsoever.  Odd thing is on other Win7 64bit machines, the upgrade works fine.

  • Lou-ICE Level 1 (0 points)

    No luck . . .   yet.    I'm new to this forum, don't know if its just for peers beefing or a sandbox, so when Polydorus said:


    "I hope the Apple engineers pick this one up as they are the ones who know exactly what itunes is trying to do when the problem occurs."   


    . . . .   well, I never thought in hoping they actually would.  I had an Apple engineer send out an email to me today to diagnose things.  I may not be able to connect with this person for several days, but will definitely share outcomes.  


    Fingers crossed, hoping for best.

  • gn_id Level 1 (10 points)

    ok, I finally stopped being lazy and fixed this (in my case at least).  First, I ran a watch tool (Microsoft sysinternals - procmon - amazing tool) and saw that the crash happened just after iTunes tried to access this file: C:\Windows\SysWOW64\t2embed.dll.


    Now, the issue is that this file is involved in the famous Duqu flaw in Windows ( and MS issued a temporary fix to lock access to this file to prevent the exploit back in 2011.  An update has since been released through Windows Update and once it is applied, this fix is safe to undo according to the Microsoft info at these links:



    Enable/disable here (linked from the above page):



    Scroll down and use the FixIt links to enable/disable.


    I always run Windows update and keep my system current, so I ran disable and iTunes now works fine.


    Hope this helps someone.  WARNING WARNING WARNING: If you do not keep your system up to date by running Windows update for all patches, do that FIRST before applying this fix or your system WILL BE VULNERABLE TO EXPLOIT.


    Good luck and please update this thread if it works!

  • polydorus Level 6 (11,955 points)



    I also got:

    C:\Windows\SysWOW64\t2embed.dll - Acces denied in Procmon, but I was dumb and did't work out what to do with the information.


    Disabling the fixit you linked to seems to have worked for me.


    Great work!

  • Conger Level 1 (95 points)

    "Disabling the fixit you linked to seems to have worked for me."


    This has solved the problem for me too.  Thanks.

  • FabFr Level 1 (0 points)

    Thank you !


    it solved my problem :-)

  • kevin e. Level 1 (0 points)



    This fix also worked for me. I disabled the hotfix, as my system is fully up to date, and iTunes no longer crashes when I open the store.


    On a side note, apple is looking at this problem. I received a call from apple support in California to gather more information on this bug to pass onto the engineering team. I was rather shocked to get the phone call and had a extremely good experience with the support rep that I was dealing with. So, if you are having this problem, and nothing is working, be patient, they are definitely working on it.


    As a suggestion, if you do try the fix as outlined by gn_id and it does not work, I would suggest re-enabling the patch, just in case


    Thanks for your research gn_id. And Kudos to the Apple Support team for keeping on top of things.

  • khisanth Level 1 (0 points)

    Worked for me also !

  • Smarty1001 Level 1 (0 points)

    Works for me, too. Great work - thank you very much!

Previous 1 2 3 4 5 Next