Previous 1 2 3 Next 43 Replies Latest reply: Apr 14, 2013 8:05 AM by Samir Sogay
DhruvC Level 1 Level 1



I am trying to install Samsung ML-1640 through my wireless router's print server feature but its not working. Whereas I am able to print through my Windows PC's on the network with no issues.


On giving print command the print job is getting paused around 40-50% in the print que and not printing. Neither the printer is getting pinged through Network Utility.


The printer is work fine with my MBP 13' when attached directly through its USB port.


1) Have tried deleting & re-adding the printer through its IP with all the three different protocols LPD, IPP & HP JetDirect.


2) Have updated to the latest drivers from here:


3) Also, have gone through the troubleshooting steps given in this article:

MacBook Pro (13-inch Late 2011), OS X Mountain Lion
  • PAHU Level 6 Level 6

    Since Windows is working you should check what protocol and queue name it is using. You can see this information under the Ports tab after selecting Properties. Then you can press the Configure Ports button to see this information. Once you see the protocol and queue used, you can then use this information for the Mac.


    Also note that some vendors drivers for OS X have limitations compared to the Windows driver for the same printer. One of these limitations is when the printer is connected to the USB port of a wireless router. If this is your setup then you may have all the correct network information set and it is the driver that is causing your problem.

  • DhruvC Level 1 Level 1

    Thanks PAHU for replying.


    Here's a screenshot of Network Printer Properties in my Windows PC. Adjacently the Configure Ports window is also open. As asked by you, I am unable to see the Protocol & Queue Used.


    Network Printer - Configure Port.JPG


    1) Could queue name be the issue. As I have been leaving it blank & the printer is getting paused in the printer queue. Should I share any Error Logs with you in order to undestand further?


    2) Here's a reference from one of the threads of a setting up concern with the similar printer:


    Steve Ashcroft (Thread Starter) was able to successfully add the network printer through HP JetDirect Protocol.


    Kindly review & assist.

  • PAHU Level 6 Level 6

    The second image shows that Windows is using IPP for the protocol. So you could create the queue on the Mac using the same protocol, but you must enter the correct information as shown in Windows.


    Enter the IP address of the router (

    Select IP > IPP for the protocol.

    Enter the queue name as printers/SamsungML1640

    Then select the ML1640 driver in the Use menu


    As for the HP Jetdirect protocol, you could use this but you would need to enter queue information for the USB port. This could be something like Port1 or even a port number, like 9101. You would need to check the documentation for the router/print server.

  • DhruvC Level 1 Level 1

    Tried with your suggested steps but no luck. First I just added IP address of the router ( with IPP as protocol, it did not print. Here's the error log from Print Queue for your reference;


    E [14/Feb/2013:13:03:10 +0530] [Job 1] Unable to queue job for destination "ipp://abc-macbook-pro.home/printers/Samsung_ML_1640".

    W [14/Feb/2013:13:05:12 +0530] Samsung_ML_1640: Printer does not provide REQUIRED printer-is-accepting-jobs attribute.

    W [14/Feb/2013:13:05:12 +0530] Samsung_ML_1640: Printer does not provide REQUIRED printer-state-reasons attribute.

    W [14/Feb/2013:13:05:12 +0530] Samsung_ML_1640: Printer does not support REQUIRED Cancel-Job operation.

    W [14/Feb/2013:13:05:12 +0530] Samsung_ML_1640: Printer does not support REQUIRED Validate-Job operation.

    W [14/Feb/2013:13:05:12 +0530] Samsung_ML_1640: Printer does not provide REQUIRED job-id attribute.


    Then, added the printer with as IP address and again no luck. Here's the error log;


    W [14/Feb/2013:13:10:57 +0530] Samsung: Printer does not provide REQUIRED printer-is-accepting-jobs attribute.

    W [14/Feb/2013:13:10:57 +0530] Samsung: Printer does not provide REQUIRED printer-state-reasons attribute.

    W [14/Feb/2013:13:10:57 +0530] Samsung: Printer does not support REQUIRED Cancel-Job operation.

    W [14/Feb/2013:13:10:57 +0530] Samsung: Printer does not support REQUIRED Validate-Job operation.

    W [14/Feb/2013:13:10:57 +0530] Samsung: Printer does not provide REQUIRED job-id attribute.

  • PAHU Level 6 Level 6

    The log shows that the destination is "". This would suggest that the DNS name used by is your MacBook Pro rather than the print server. So you may want to check all the IP addresses that are being provided by the router.

  • DhruvC Level 1 Level 1

    Thanks for your quick response.


    Here's a screenshot of DNS from System Preferences>Network. The IP is being shown as twice under DNS servers.


    Screen Shot 2013-02-14 at 2.50.02 PM.png


    Pls assist how should I resolve this?

  • PAHU Level 6 Level 6

    This looks correct. The router is your local DNS server so the entries shown above are okay. Don't be concerned about having two entries.


    Can you confirm what the name of your Mac is. This can be found in the Sharing > File Sharing preference pane.


    What you need to look at is the addresses allocated by the router. If you open a web browser on the Mac and type



    and press Return, this should take you to the internal web page of the router. You will probably need a password to get past the home screen. Once you are in you should see an entry about what IP addresses have been given out and what computer names are using them.


    What you can also try with the web browser is typing in



    and press Return. This should show the shared printer (the Samsung). Do you see this?

  • DhruvC Level 1 Level 1

    My MBP's name is DC's MacBook Pro. (I changed DC's to abc in the error log.)


    I have added my printer in Windows PC's with this IP:


    When I ping this IP in Network Utility, I get this;


    Ping has started…


    ping: cannot resolve Unknown host


    And nothing opens when I type it in Safari, in Chrome I get message 'No data received' with Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.


    My MBP IP Address is


    Screen Shot 2013-02-14 at 2.46.16 PM.png

  • PAHU Level 6 Level 6

    Did you just enter in Network Utility or did you enter ?


    If you entered just the IP address in Network Utility then it would suggest that you have this complete address registered in your Hosts file. This file is located in the hidden folder etc. The easiest way to access the file is to open Finder and select Go > Go to Folder. Then type /etc and press Go. This will take you to the hidden etc folder and here you should see a file called hosts. You can double-click on the file - it should open up in TextEdit. Do you see an entry with the address?

  • DhruvC Level 1 Level 1

    In Network Utility I pinged:

    On pinging, I get normal pings;


    Ping has started…


    PING ( 56 data bytes

    64 bytes from icmp_seq=0 ttl=64 time=3.544 ms

    64 bytes from icmp_seq=1 ttl=64 time=4.678 ms

    64 bytes from icmp_seq=2 ttl=64 time=1.447 ms

    64 bytes from icmp_seq=3 ttl=64 time=3.855 ms

    64 bytes from icmp_seq=4 ttl=64 time=3.892 ms


    Here's the hosts file:



    # Host Database


    # localhost is used to configure the loopback interface

    # when the system is booting.  Do not change this entry.

    ##          localhost          broadcasthost

    ::1             localhost

    fe80::1%lo0          localhost

  • PAHU Level 6 Level 6

    Okay, you cannot ping the http address. The correct action is just to ping the IP address, which when you did it showed you are getting a response.


    What I was concerned about was that you pinged and got the response of Ping cannot resolve the http address. Anyway, this was not the case. You were just doing the wrong thing so all is good.


    The thing that still concerns me is that when you try to print you get this message in the cups error log


    E [14/Feb/2013:13:03:10 +0530] [Job 1] Unable to queue job for destination "ipp://abc-macbook-pro.home/printers/Samsung_ML_1640".


    This suggests that your Mac is trying to connect to itself rather than the router, which is why it errors. So why does the Mac try to send the print job to itself. Hopefully it is due to you creating the queue incorrectly. To check, can you open System Information and select Printers in the left column. Then select this Samsung printer in the right pane. Can you copy this information and paste back here for me to check.


    Also, what brand of router do you have that the Samsung is connected to? I would like to find a manual for it and check what is says about adding a USB connected printer on OS X.

  • DhruvC Level 1 Level 1

    I had deleted the printer yesterday. Hence, today I re-added the Network Printer through IP with following inputs;

    IP Address:

    Protocol: IPP

    Queue: printers/SamsungML1640


    Here's the screenshot from the System Information, Samsung ML-1640 Series is the printer installed through USB;

    Screen Shot 2013-02-15 at 2.39.04 PM.png


    Router is D-Link DSL-2750U.

  • PAHU Level 6 Level 6

    I downloaded the DSL-2750U manual today. Unfortunately there was not one shred of information about configuring a USB connected printer. In fact the manual does not even state that it supports such as connection. The only reference it makes to the USB port is for connecting another computer.


    Do you have a guide that came with the router explaining how to add a USB connected printer? Maybe there is an explanation of what protocols it supports and how to add a printer on OS X?


    If not, then the latest information you have provided above looks correct - at least when comparing it to what Windows is using. So if this queue is not printing from the Mac then maybe it is due to the Samsung driver.

  • DhruvC Level 1 Level 1

    PAHU, first of all I would really like to appreciate all the pain being taken at your end in order assist me on this issue.


    Now, the user manual is silent about Print Server settings. Whereas, on searching the net I was able to find following User Manuals for setup & also under FAQ's mentioned on the product page.


    1) User Manuals:

    a) DSL-2750U%20On%20Winows%207.pdf

    b) %20Server%20Setup.pdf


    2) FAQ from D-Link's Website - Q No. 20 'Can we connect the USB printer in DSL-2750U and how to configure it?'


    If it was anything to do with Mac Samsung Drivers how was Steve Ashcroft (Thread Starter) here able to configure the same printer with OSX on the network?

Previous 1 2 3 Next