Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iPhone to Android iMessage bug fix

I was having the problem when i switched from my iPhone to my Galaxy s4 where people using iPhones would try to text me and it wouldn't get to me because it would be sent in iMessage. Well i asked one of my friends who knows a lot about Apple products and he seems to have found a fix. What worked for me is to open iTunes, then go to account. Once there find the the section "iTunes in the cloud" and the option in there "Manage my devices". You have to go in there and remove your iPhone from the iCloud and that should work, or at least it did for me.

Posted on

Reply
Question marked as Helpful

Jun 8, 2013 11:51 AM in response to andrenat39 In response to andrenat39

All you have to do is reset your apple id password. Go to iforgot.apple.com and reset your password. Imessage requires a verified apple id and password, therefore the act of change your password unauthenticates it and fixes it. As said before not a glitch simply an extra step if you want to go from one phone that has a feature to one that doesn't.

Jun 8, 2013 11:51 AM

Reply Helpful (6)

Jun 8, 2013 3:57 PM in response to andrenat39 In response to andrenat39

I guess a prissy attitude from the outset and posting foolish commentaries and an inability to read and pay attention does not win anyone the jerk-of-the-year award.


BTW, I am glad you solved your problem. Have a nice day.

Jun 8, 2013 3:57 PM

Reply Helpful (1)

Jun 22, 2013 8:37 PM in response to Pat518 In response to Pat518

I recently lost my iphone and switched to an galaxy so i can't turn off imessage on the phone. I unregistered my iphone in the profile that you guys are talking about but i still am not receiving texts from some of my friends. for some reason it's only in group texts. regular texts are still a little messed up to because they're coming out of order. I don't want to ask my friends to turn off their imessage just to text me. is there a way to turn it off for just a single contact? any suggestions??

Jun 22, 2013 8:37 PM

Reply Helpful

Jul 5, 2013 5:35 AM in response to Pat518 In response to Pat518

I had the same problem switching from iphone 5 to galaxy s4. When I originally made the switch I put my old phone number on my new galaxy and switched the iphone to a new phone # so I didn't have the problem. The problem occurred when I switched back to my iphone and then switched again to the galaxy. Confusing, I know! Anyhoo, I think the problem is when the phone number is attached to the sim card! After I reswitched back to my galaxy, my phone # was still embedded on my iphone 5 and I could not uncheck it. I have several lines so I changed my iphone to an unused # and it solved the problem. And I dont want to be charged the data fee so I just switched the line back to a basic phone. But switching my iphone to a different number, even for a min, seems to solve the problem. That leaves me to believe it is because the phone number i am using is attached to the sim card. I only thought of this today and did not try removing the sim card? That may work too. Hope this helps some of you. I know its a little confusing. Bottom line, I like switching between the 2 phones on my main phone number, but I need to unattach my main phone number from my sim card to free it up from sending imessages to my phone number on my iphone....

Jul 5, 2013 5:35 AM

Reply Helpful

Jul 8, 2013 9:10 PM in response to Pat518 In response to Pat518

Pat and all,


I too have been experiencing this issue and was about to turn my new Galaxy s4 back into Best Buy. I visited the Apple store the night before who got me halfway to fixing the problem but it still persisted. My friends who had previously communicated with me over imessage had to turn off their own iPhone's iMessage in order for me to be able to receive texts from them. Today, I went to a BestBuy location that has a Samsung "store in store" concept in east Plano, TX and the Samsung guy got online to chat with other Samsung technicians about this issue. Here is the link to a 9 page document that goes through a number of steps how to deactivate iMessage and get texts on your Android (while still maintaining iMessage on any other Apple devices that you might still have): http://www.samsung.com/us/support/SupportOwnersFAQPopup.dofaq_id=FAQ00053450&fm_ seq=62995


if the link doesn't work for some reason, shorten the url to get to the Samsung support page and type in various search boxes in the support section "deactivate iMessage on iPhone" until it gets you to the support document.


the long and short of it is 1) go to your iphone settings under "Messages" and assuming iMessage is set to "on" scroll down to where it says "send & receive" and click on that. It should show your phone number along with other email and Apple related addresses. Deselect your phone number and any email messsages that you don't need to send/receive imessages from. Close that up.


Then 2) go to the itunes/apple page and change your password. When you change the password on the account it supposedly deauthorizes the phone number and other deselected addresses from iMessage.


There are some other steps in between that you may need to take and are listed on the support page but hopefully that will work for you as it finally did for me.


Good luck!

Andrea


Message was edited by: gottabook

Jul 8, 2013 9:10 PM

Reply Helpful
Question marked as Helpful

Jul 13, 2013 5:48 AM in response to andrenat39 In response to andrenat39

After trying many things here's what worked for me. Log into your apple acount using this link: https://supportprofile.apple.com/MySupportProfile.do


Go to edit products and delete your Iphone from the list.


Next log into Icloud from a computer with this link: https://www.icloud.com/#find


Erase your Iphone from the finf my Iphone and delete it. Next go to your contacts and remove anyone that has an Iphone.

Jul 13, 2013 5:48 AM

Reply Helpful (9)

Jul 15, 2013 8:32 PM in response to Pat518 In response to Pat518

I switched to android s4 and have only had one of my friends not be able to send text messages to me due to this bug. All my other iPhone using friends are good to go. But this one guy can get all my texts but I get none of his. I removed my iPhone from my device list on apple account. It didn't fix the issue. My buddy has to switch to sms in order to send any messages. Any more ideas?

Jul 15, 2013 8:32 PM

Reply Helpful

Jul 19, 2013 4:56 PM in response to Pat518 In response to Pat518

The most important thing you need to do among going to https://supportprofile.apple.com/MySupportProfile.do and unregisterring your device and unlinking your phone number from your "messages" app on your computer and your iPad if you have them is to:


unlink your phone number from your(or any) iPhone WHILE YOUR ACTIVE SIM CARD IS IN THAT IPHONE.


If you unlink your phone number under settings: messages on your iPhone while your SIM card is in your new Galaxy S4, it won't work.


I'll repeat,

1. turn off both your s4 and your iPhone


2. Take the sim out of s4 and put it back in iPhone (any iPhone of the same carrier should do if you sold or lost your iPhone)


3. Turn on iPhone. Go to settings: messages: send and recieve. And uncheck your phone number. I can't hurt to turn off iMessage and Turin back on either.


4. Restart all devices that you had to unlink your phone number to.


5. Put SIM card back in s4.


6. Hopefully by this point your friends with iPhones will see you not as iMessage anymore even when they allow iMessage under their settings.

Jul 19, 2013 4:56 PM

Reply Helpful

Sep 21, 2013 3:19 PM in response to FelipeV In response to FelipeV

Felipe, you obviously do not understand what ANY of the people in this thread are trying to tell you... Yes, we have all done the obvious. The obvious did not work. We all had to go through extra junk, which took way too much time and frustration (including reading your arrogance on this thread), JUST so we could recieved text messages. It IS a glich on apple's part. Get your head out of the cloud and get over it. Oh, and out of the three iphone's I've had, none can even compare to the Galaxy I traded in for.

Sep 21, 2013 3:19 PM

Reply Helpful (1)

Sep 26, 2013 8:41 AM in response to FelipeV In response to FelipeV

Actually this IS a glitch. I am now experiencing the same problem, except when I had gone in and switched my phone I traded it so they took it from me. They did not turn off iMessage before wiping the phone and sent it in to headquarters...therefore now I have no way to get ahold of my device and turn iMessage off. Customer service directed me to the apple site where I could unregister my device, and lo and behold...it's not there. There is literally nothing I can do at this point except to tell all my iphone friends that if they want to text me they have to turn off THEIR iMessage and nobody seems to want to do that. This only occurs with people who have the iOS7 update, because everyone that does not have the update send me a message that starts off as an iMessage then it converts to a regular SMS. Yet everyone with iOS7 cannot do this.

Sep 26, 2013 8:41 AM

Reply Helpful
User profile for user: Pat518

Question: iPhone to Android iMessage bug fix