Previous 1 2 3 4 Next 83 Replies Latest reply: Jan 29, 2016 6:34 AM by shenx Go to original post
  • Stonerabroad Level 1 Level 1

    Nice work khsaechao!


    After three failed attempts at installing through an external DVD drive, I also found this post.


    As stated above, when you find your keyboard, trackpad, or even a USB keyboard won't work during your Windows install (I was installing Win7Pro)


    1. Through bootcamp, remove the failed windows install

    2. Create your boot stick, install disk

    3. Restart boot camp and only select "Download latest drivers"

    4. Restart boot camp and only select the last Install Windows option


    After that, sit back and relax.


    Thanks a bundle!

  • Geof Corb Level 1 Level 1

    I didn't need to follow khsaechao's instructions but, rather, followed the above KB article and I'm in business.  Win7 on Boot Camp partition was working flawlessly (knock on wood).  Got Parallels up and running against the same partition and it's working fine, too, except for some odditiies with IE9 graphics.

  • ITCrazy Level 1 Level 1



    I have same problem as above. After use the Boot Camp partition install the window, I can't through bootcamp, remove the failed windows install. When I restart boot camp , It block the option  in grey color. So How to do it continue....


    Anybody can give me advice and solve the problem.

  • ugbug Level 1 Level 1

    It is almost certainly a USB3 driver problem, as there is no native USB3 support in windows 7. Using another windows machine I was able to download the USB3 drivers for Intel 4th Gen chipset from:


    Then extract the drivers and include them into the boot.wim file on the USB key following instructions here: (about halfway down post by mjgr33n)


    this got me past the language selection etc as I could then use Keyboard and trackpad. However after it reboots during the setup I am once again stuck with no input on the "type a user name" set up screen.


    so I am only halfway to an actual solution. any help much appreciated. It seems any laptop without USB2 ports will have this issue. if there was a USB2 port you just plug in an external keyboard/mouse and away you go. then install usb3 drivers once you are in.

  • yaddam205 Level 1 Level 1

    Thank you so much!


    I've been wrestling with this all day and your odd method worked like a charm!

  • raamar Level 1 Level 1

    My installation gets stuck at "expanding Windows files" (at 65% to be exact).


    Is there anyone having a similar issue? I am totally lost

  • Stefan Jerry Level 1 Level 1

    My MBA have the same issues... keyboard and trackpad not working.


    If I shut down the macbook Air and I turn it on again, the macbook Air always get back to windows mode...


    how do I get back to mac??


    its very frustating..


    please someone help...

  • Stefan Jerry Level 1 Level 1

    My MBA have the same issues... keyboard and trackpad not working.


    Since you already have the answer , I like to try it but If I shut down the macbook Air and I turn it on again, the macbook Air always get back to windows mode...


    how do I get back to mac since keyboard not working???


    its very frustating..


    please help...

  • Codeus Level 1 Level 1

    To get back to Mac OS, hold down 'Alt' while powering on the option and select the Mac boot partition.

  • jasonj566 Level 1 Level 1

    new macbook air partition error windows 8....I've spent hours trying to research this. I'm able to download support drivers and then try to install windows 8 pro via a usb dvd drive. I get to the point of picking the partition from windows and format it like always done in the past with other computers with no problems, after i format the bootcamp partition it doesn't allow me to go past that by hitting the next button. it comes up with an error "windows cannot be installed to this disk. the selected disk is of the GPT partition style"....frustrating, any help out there?

  • Stefan Jerry Level 1 Level 1

    none of the answer by khsaechao nor Geof Korb  nor Codeus worked for me.


    I bought this NEW macbookair last week (the one which have double the battery life). and I want to install windows 7 home premium.


    I already created the USB instalation... still stuck in giving the Windows computer a name and neither the mouse nor the keyboard are responsive.


    Same thing happen when I installed with dvd.. stuck in giving the Windows computer a name and neither the mouse nor the keyboard are responsive.


    any more suggestion???


    I almost give up....


  • Codeus Level 1 Level 1

    It looks like it is important that the 'Windows Support software' that you download via Bootcamp is available to the Windows installer during the install process.


    The best way to achieve this is to let Boot Camp Assistant put both the installer DVD image and the Windows Support software on to a single USB Flash drive as follows: -


    • Copy a Windows 7 or 8 ISO image on to your Mac
    • Insert an 8GB or larger USB flash drive in to a USB socket (warning: it will be wiped).
    • Open BootCamp and select 'Remove Windows 7 or later version' to get rid of the failed Windows install
    • Select 'Create Windows 7 or later version install disk' and follow the instructions to copy the ISO to the USB drive.
    • Select 'Download the latest Windows support software from Apple' and follow the instruction to download to the same USB drive.
    • Select 'Install Windows 7 or later' and go through the installation process, make sure the USB drive is still plugged in.


  • AaronOssom Level 1 Level 1

    Hi Guys,


    I've had this same problem this afternoon after my 2013 MBA arrived.


    Solution was quite simple in the end, I've listed my steps below for clarity but the main bit is the shut down I think.


    1. Fire up bootcamp, already had win 8 key but selected "download latest drivers" after removing the WindowsSupport folder off my existing key.

    2. Chose same win8 install key as target for drivers (created a new WindowsSupport directory)

    3. Had last option for "install windows" checked too - partitioned drive and rebooted.


    -- Reading through some of the posts it may be pertinent to mention my usb key was in the left port and is a Lacie iamakey --


    4. Rebooted and hit windows installation, proceeded as normal

    5. went through a few reboots with full keyboard and mouse support

    6. arrived at personalise screen (windows setup) and had no keyboard or mouse support

    7. hard powered off using the power key

    8. booted in to mac os

    9. did a complete shut down

    10. booted back up in to windows partition

    11. hey presto! mouse and keyboard support back.


    I'm an IT professional so I should be able to hazard a guess at what the problem was there but sadly I can't quite figure it out. Certainly having the latest drivers on the USB key helped I believe (bootcamp installer popped up automagically when I eventually got in to desktop) and that last shut down/boot seemed to do the trick as warm restarting was getting me nowhere. Maybe the trip in to MacOS helped too - who knows!


    Hope this helps.

  • Geof Corb Level 1 Level 1

    About 5 days and counting and all is working flawlessly (knock on wood). I would encourage anyone with this problem to follow the KB article that I referenced above. I may have gotten lucky but once I did, I was in the clear. The Win7 partition works fine in boot camp and in a Parallels VM that accesses the boot camp partition.

  • Stefan Jerry Level 1 Level 1

    wohoo.. it workss.....  Thank you very much ...

Previous 1 2 3 4 Next