Previous 1 2 3 4 Next 50 Replies Latest reply: Aug 20, 2015 3:13 AM by KatieC16 Go to original post
  • jmoney687 Level 1 Level 1 (0 points)

    Ken, again you are a god send. My girlfriend accidentally spilled a glass of water on my MacBook Pro, I know. She thought quickly and shut it down, flipped it over a towel to let the water drain out, then used a blow drier on cold and aired it out for about 20 minutes (redeeming herself...). I then opened the lap top and stood it tee-pee style for 2 days to let it air out. Thankfully when I tried to turn the laptop on 2 days later, it fired right up (**** yes!!!), but wouldn't hold a charge though plugged in, I thought for sure somehow the battery was corrupted somehow. I tried to do the battery reset while the laptop was still plugged in but nothing happened. I unplugged the laptop and tried the reset again, and by the grace of god it started to charge.

     

    Thank you Ken, and thank you Apple for justifying my purchases over and over by producing a superior product. I own an iPhone, iPad Mini and MacBook Pro and could not be more satisfied with these products.

  • schbg Level 1 Level 1 (0 points)

    I tried this and it didn't work...and only have 1% left on my battery so unplugging during the process isn't going to work either. Does anyone else have tips?

  • Notary Sojak Level 1 Level 1 (135 points)

    I should have read the rest of the posts. I was quite surprised when the Left-Shift,Control,Option,Power combo immediately shut my MBP down. Chrome and Photoshop appear to have recovered my work.

    On the plus side, I have not seen the "Battery Not Charging" alert in the menu since. (knock wood)

  • tdinges Level 1 Level 1 (0 points)

    Hi Sheila,

    I did this and it it didnt work.

     

    I followed Ken's advice and it worked. Why the discrepancy? Did I also reset the SMC, or was that something different?

  • Lukas Willcocks Level 1 Level 1 (5 points)

    Just had same issue, battery completely flat and not charging anymore. Macbook 3,1 OSX 10.5.8

     

     

    Battery Information:

     

      Model Information:

      Serial Number:          SMP-ASMB016-379a-a95

      Manufacturer:          SMP

      Device name:          ASMB016

      Pack Lot Code:          0000

      PCB Lot Code:          0000

      Firmware Version:          0110

      Hardware Revision:          0200

      Cell Revision:          0102

      Charge Information:

      Charge remaining (mAh):          0

      Fully charged:          No

      Charging:          No

      Full charge capacity (mAh):          0

      Health Information:

      Cycle count:          1467

      Condition:          Check Battery

      Battery Installed:          Yes

      Amperage (mA):          0

      Voltage (mV):          9947

     

    System Power Settings:

     

      AC Power:

      System Sleep Timer (Minutes):          10

      Disk Sleep Timer (Minutes):          10

      Display Sleep Timer (Minutes):          10

      Automatic Restart On Power Loss:          No

      Wake On AC Change:          No

      Wake On Clamshell Open:          Yes

      Wake On LAN:          Yes

      Display Sleep Uses Dim:          Yes

      Battery Power:

      System Sleep Timer (Minutes):          5

      Disk Sleep Timer (Minutes):          10

      Display Sleep Timer (Minutes):          1

      Wake On AC Change:          No

      Wake On Clamshell Open:          Yes

      Display Sleep Uses Dim:          Yes

      Reduce Brightness:          Yes

  • Lukas Willcocks Level 1 Level 1 (5 points)

      Model Name:          MacBook

      Model Identifier:          MacBook3,1

      Processor Name:          Intel Core 2 Duo

      Processor Speed:          2.2 GHz

      Number Of Processors:          1

      Total Number Of Cores:          2

      L2 Cache:          4 MB

      Memory:          4 GB

      Bus Speed:          800 MHz

      Boot ROM Version:          MB31.008E.B02

      SMC Version (system):          1.24f3

      Serial Number (system):          W88012X5Z64

      Hardware UUID:          2DDD4F1E-0218-54E8-90AB-31E9A39371F1

      Sudden Motion Sensor:

      State:          Enabled

  • alexusmjordan Level 1 Level 1 (0 points)

    Ken Walker... I hope you find $20 on the sidewalk. THANK YOU SO MUCH!!!

  • canius1 Level 1 Level 1 (0 points)

    Thanks Ken. The reset worked like a charm . 

  • jay epsom Level 1 Level 1 (0 points)

    hi ken...

     

    I tried what u suggested and i even unplugged the adapter and cable after doing so like the other guys suggested but it still wont work. still says not charging. I'm completely out of juice and the machine will only switch on or run so long as the cable is plugged in and is green. My warranty has run out and i don't know what else to do. Am i doing something wrong here?

  • Nakilon Level 1 Level 1 (0 points)

    Sure, now I don't see the message, that battery isn't charging, but it is just because now Mac OS doesn't tell me, when it isn't!

    So yesterday my Mavericks was saying my battery is 97% through the whole evening, and suddenly my Macbook went black! I had to keep it powered off charging, until it got more, than one green LED to be able to turn on.

  • erikvoneric Level 1 Level 1 (0 points)

    YESSSS. Thanks a heap!

  • paul8agrape Level 1 Level 1 (0 points)

    I've tried all options here including Ken's.  I also tried shutting the computer down, doing Ken's trick with it off and then powering back on.  This also works according to a YouTube video.

     

    I have a 13", Mid 2010 MacPro.  This didn't happen until I installed the Yosemite beta.  As soon as I did, I started noticing the battery wasn't charging.  Could be coincidence.  Battery has been slowly going down ever since and is at 3% now.  I rolled back to Mavericks and the problem is still happening.  Pulling my hair out!

  • Prapius Level 1 Level 1 (0 points)

    I've tried the Ken Walker method until I'm blue in the face. Powered on/powered off, standing on my head with a tinfoil hat on but to no avail. Is there any other ideas out there besides resetting the SCM?

     

    My battery is at 80%. The computer works on battery or the power adapter. But, the battery is not charging. The only symbols on the battery icon is battery or plug icon. The normal lighting bolt symbol when charging is no where to be found

  • Robin Peter Level 1 Level 1 (0 points)

    In a similar position to the last few posters - tried Ken's trick and all variations on it but still don't get any charge. I have a green light on the adaptor and the lightning symbol for a while after turning laptop on but battery remains at 0%. After a bit it switches to the X symbol in the battery icon. Can't run the laptop at all without being plugged in.

     

    Machine is a 13-inch Macbook, one of the early unibodies from late 2008/early 2009, running latest Yosemite 10.10.1.

     

    Have tried a brand new battery and experimented with different power cords to no avail.

     

    Ken are you still there? How do we take it to the next level?

     

    Thanks!

  • Robin Peter Level 1 Level 1 (0 points)

    PS it seems that Coconutbattery can't see the battery at all, so maybe this is a hardware issue?