Previous 1 2 3 Next 42 Replies Latest reply: Oct 20, 2014 8:09 AM by LaraCroft_NYC
Wooky Level 1 (0 points)

This started a few days back when I updated my Mac OS X. Not sure it's related but that's when this issues started. I can see it's due to my external HD (seagate go flex 1.5T, TB connected) from the log file but not sure why this is happening all of a sudden.


Any way I can fix this issue? I properly ejected and re-connected the drive but the problem still persiste. I set up my iMac to go to sleep after one hour of inactiveness by the way.


Appreciate any tips for this.



iMac (27-inch, Late 2012), OS X Mountain Lion (10.8.2)
  • Z_B-B Level 2 (200 points)


    Did you connect the external hard disk to USB HUB ?

  • Wooky Level 1 (0 points)

    nope, that's directivly connected to my mac via TB. It required some power for the external HD.

  • Eric Root Level 9 (50,304 points)

    Try running the combo updater. It fixed a lot of problems for people when 10.8.4 was released.


    10.8.5 Combo Update


    Based on other discussions, this seems to be a 10.8.5 bug. Send Apple feedback. They won't answer, but at least will know there is a problem. If enough people send feedback, it may get the problem solved sooner.


    Or you can use your Apple ID to register with this site and go the Apple BugReporter. Supposedly you will get an answer if you submit feedback.

    Feedback via Apple Developer

  • Wooky Level 1 (0 points)

    Thanks a lot, Eric. I will definitely try the combo update tonight. What do you think about updating the firmware from the manufacturer... would this be helpful? I have my doubt but... Will post some results after I try the combo update.



  • Eric Root Level 9 (50,304 points)

    Usually, but not always, having the latest updares are best.

  • Eric Root Level 9 (50,304 points)

    updates. Great proof reading.

  • Wooky Level 1 (0 points)

    Tough luck. I installed the combo update and update the firmware... the problem still persists... guess it doesn't work for me. I reported the bug but I have a feeling APPLE is caught up with the new release of Mavericks. Hopefully they address this issue there.


    I even tried an app called Jettison which unplug external hard drive before sleep... this didn't work either (wasted 2 bucks).


    Thanks for the advice though. Much appreciated, Eric.

  • Wooky Level 1 (0 points)

    Oh one more. I strongly urge anyone who's got the same problem reporting this bug to apple... that seems all we can do for now.

  • LexSchellings Level 6 (8,747 points)

    Seagate and WesternDigital have "help" softwares on the disk for you to install when you buy them.

    Do not install these softwares: just format the disk and use it.

    If you have installed the software uninstall it.

    It does not do anything for you and makes everything slow or crippled.

  • Wooky Level 1 (0 points)

    will do.

  • Russ tolman Level 2 (155 points)

    I have the exact same problem with a few additions.  I am unable to clone  a drive, copy large amounts of data to any of my external HD.  When doing so I ge the above error as well as the following, Unable to eject drives using all the methods I know.  Finder crashes hard to the point that I must power down to recover the machine.


    Reinstalled OSX from recovery partation.  No joy.   Have reported bug to apple.


    It happens on both a 2010 i7, 16 gig imac,  2013 MBP 2.8 i7, 16 gig. 


    Now installing OSX 10.8 from USB hoping it installs 10.8.0, then I will install 10.8.4 combo update.


    Will report back.


    sure hope this works.

  • LexSchellings Level 6 (8,747 points)

    Are you sure the external has enough power? if it has a power cord, use it. If it does not have its own power cord then use a powered USB hub.

  • Machwa Level 1 (10 points)



    I'm having the EXACT same problem as you. Ever since I upgraded to 10.8.5 I've been getting the "disk not ejected properly" message. I have a 3TB LaCie Thunderbolt external disk. I have since disconnected it and am hoping that Mavericks fixes the issue.


    If you find any solution, please post it, and I will do the same. (Very frustrating.)


    Best of luck.

  • Wooky Level 1 (0 points)

    Thanks, sure thing, I will definitely post a solution if I find one.


    In the meatime, I am using this app called "Jettison"... which allows you eject external HD and put the machine to sleep... as opposed to waiting to be put into sleep... when u wake it up, ur HD should be connected again. But still getting an error from time to time anyway. So I woudn't strongly recommend unless this bothers you heck out of it... I was even thinking about not put the machine into sleep (in your power mgmt)... not sure if this is a good idea though... Anyhow, I will keep you posted if I find anything further.



Previous 1 2 3 Next