Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: IOS 7 won't play YouTube videos?

Since updating my iPad with retina display to iOS7 the only issue that I have had is that I seem unable to play YouTube videos on my device. Other videos work, but anything from YouTube just sits and tries to load and never plays. Any ideas?

iPad (4th gen) Wi-Fi, iOS 7

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Yesterday I was able to update my iPad again to the latest version (7.0.2) and that seems to have resolved my problem. I can now play YouTube videos through the Facebook and tumblr apps, and I don't seem to have any loading issues anymore. For those still having issues, I would recommend going into settings and checking for this update. Thanks so much for everyone's help!!

Posted on

Question marked as Helpful

Sep 29, 2013 10:33 AM in response to stripeytom In response to stripeytom

My router is an Apple AirPort Extreme. This issue only started after updating to iOS 7.


This only related to iOS 7 and embedded YouTube videos. The YouTube app works fine, although a bit slow to load.

YouTube links in Safari open in the YouTube app. Only embedded videos do not appear in Safari.

There’s more to the conversation

Read all replies

Page content loaded

Sep 23, 2013 10:59 AM in response to RavenHeart518 In response to RavenHeart518

Okay, so apparently the YouTube only works through the YouTube app, but I never had that problem before, I could watch YouTube videos when I was in my tumblr or Facebook apps without an issue...

Sep 23, 2013 10:59 AM

Reply Helpful

Sep 23, 2013 11:08 AM in response to RavenHeart518 In response to RavenHeart518

Nope. Not there either. Just fired up the Digg client, browsed down to a Mental Floss article about "10 Famous Psychological Experiments..." and clicked on the inlined video of the "Little Albert Experiment". No problem watching it.


However, by default it will not play until it finishes downloading, which can take awhile on congested links. You can force it to start playing without the wait, but have to tap on the play arrow explicitly. Maybe this behavior is what you're seeing.

Sep 23, 2013 11:08 AM

Reply Helpful

Sep 27, 2013 12:15 AM in response to RavenHeart518 In response to RavenHeart518

Did you resolve this? I have exactly the same issue. I wonder if there is an incompatibility between iOS 7 and my zyxel router, since YouTube will play using a cellular connection. It is just over wifi things don't play. Vine works, so it is clearly not all video content that fails.

Sep 27, 2013 12:15 AM

Reply Helpful

Sep 27, 2013 5:47 PM in response to RavenHeart518 In response to RavenHeart518

I have the same problem and regret I updated my IPad 2 .Since updating my iPad with retina iOS7 My IPad 2 it seem unable to play YouTube videos on my device. Any ideas what I can do that is not too complicated, I am not a technician , just and ordinary user .

iPad 2 ,Wi-Fi, iOS 7

Sep 27, 2013 5:47 PM

Reply Helpful

Sep 28, 2013 8:42 AM in response to RavenHeart518 In response to RavenHeart518

Like I mentioned earlier, on a GSM Retina (4) iPad with 7.0.2 and all apps updated, I have had no issue with watching YouTube videos. Either explicitly on their app or embedded in any of the browsers.


However, I have noticed that some embedded videos don't start up automatically on their own. Download progress bar reaches the far end with no issues, but the pinwheel keeps on spinning. Only if I tap the play arrow (sometimes more than once) does the entertainment begin.

Sep 28, 2013 8:42 AM

Reply Helpful
Question marked as Helpful

Sep 29, 2013 10:33 AM in response to stripeytom In response to stripeytom

My router is an Apple AirPort Extreme. This issue only started after updating to iOS 7.


This only related to iOS 7 and embedded YouTube videos. The YouTube app works fine, although a bit slow to load.

YouTube links in Safari open in the YouTube app. Only embedded videos do not appear in Safari.

Sep 29, 2013 10:33 AM

Reply Helpful (1)

Oct 1, 2013 12:54 AM in response to RavenHeart518 In response to RavenHeart518

I have an iPad mini. Sorry, I don't know what version. I got it last Xmas. Ever since I downloaded IO7 I too am having the hardest time watching videos on YouTube. They won't load. Doesn't matter if I access YouTube through the app, through a link on Safari, or a link in Facebook (which might be considered accessing it through safari). Dang videos just won't load. I have to back out of them, then try again. Then again. If I just sit and wait often they won't load at all. It isn't that they won't load, it is just that they are slow to the point of being maddening.


No trouble before this awful upgrade. I also have lost some apps that won't work now. Zynga app won't load at all. Why oh why did I download this thing?


And it isn't my internet speed. I'm getting 20 mps. Can't remember what router I use, but it worked fine with the old system.

Oct 1, 2013 12:54 AM

Reply Helpful
Question marked as Solved

Oct 1, 2013 3:26 AM in response to RavenHeart518 In response to RavenHeart518

Yesterday I was able to update my iPad again to the latest version (7.0.2) and that seems to have resolved my problem. I can now play YouTube videos through the Facebook and tumblr apps, and I don't seem to have any loading issues anymore. For those still having issues, I would recommend going into settings and checking for this update. Thanks so much for everyone's help!!

Oct 1, 2013 3:26 AM

Reply Helpful

Oct 2, 2013 7:01 AM in response to RavenHeart518 In response to RavenHeart518

AFAIK, YouTube offered two means of delivery: via Flash or via HTML 5. For the iGadget Universe, the only means accepted is HTML 5, given that Flash is and will be forever verboten in here. I would like to think that a properly working YouTube access on iOS should somehow auto-select the HTML 5 option, given that as per my experience, there never was any need or opportunity to choose one over the other.


You might try diving deep into the more arcane settings available to see if this can be fiddled with.

Oct 2, 2013 7:01 AM

Reply Helpful
User profile for user: RavenHeart518

Question: IOS 7 won't play YouTube videos?