Previous 1 2 3 Next 139 Replies Latest reply: Jan 7, 2015 3:34 AM by iStefke
Rondom1 Level 1 Level 1 (0 points)

I just noticed that the Mail app in iOS 7 changes the sent from email address from my default to another account I have after entering in the send to address. When I first create the new email the correct default email address is showing (iCloud) but after I add any send to address it changes to another account (Hotmail) as the sent from account.

 

I checked my settings and iCloud is still set as the default account, I can click and change it before sending the email but I think this may be a bug unless there is something I missed.

 

Anyone else have this problem?


iPhone 4, iOS 7
  • jgmj Level 1 Level 1 (0 points)

    I'm having this issue also with a Comcast email account that is set to defualt. When I begin email it has right defult account but when I enter a "to" email and tab to "subject" line it changes accounts.

     

    Help!!!!

  • Kilgore-Trout Level 7 Level 7 (27,750 points)

    If you have multiple accounts, the default will be used when you send from the All Mail Mailbox. However, if you are sending from any of the individual accounts, that account will be used. also, if you are replying to an email, it should use the account that the mail was recieved on.

  • jgmj Level 1 Level 1 (0 points)

    Yes I know but when using "All Mail Mailbox" is when it changes the default account. Now getting "CANNOT SEND MAIL" The user name or password for "SMTP" is incorrect. Have deleted account and added a number of times and sure they are correct.

  • Kilgore-Trout Level 7 Level 7 (27,750 points)

    If you are certain the account settings are correct, try a reset: Simultaneously hold down the Home and On buttons until the device shuts down. Ignore the off slider if it appears. Once shut down is complete, if it doesn't restart on it own, turn the device back on using the On button. In some cases it also helps to double click the Home button and close all apps BEFORE doing the reset.

  • Rondom1 Level 1 Level 1 (0 points)

    Yes, I have reset both ipad and iphone and am aware of how the default email is supposed to work. It actually happened to me when I was emailing a contact to my work email and when I received the email it showed as being sent from my Hotmail and so I went back and tested numerous situations and yes this seems to be a bug and it is not supposed to change the sent account after already creating the email with the correct default account and then change it after entering some To: addresses.

     

    Sounds like a bug.

  • jgmj Level 1 Level 1 (0 points)

    Reset complete and having same problem. Can get mail to default account but can not send.

  • Rondom1 Level 1 Level 1 (0 points)

    I'll see if it is still doing it after updating to iOS 7.0.2...

  • Rondom1 Level 1 Level 1 (0 points)

    I have found after it changes the sent from account you can still click on it and it will allow you to change it back to your preferred defaul account to send out the email.

  • jgmj Level 1 Level 1 (0 points)

    Have figured it out. Had to change "Outgoing Mail Server - Port Number" from 465 (SMTP) to 587 (SMTP)and then it worked!

     

    Thanks for your help.

  • rfh723 Level 1 Level 1 (10 points)

    I don't believe the solution is the port 465 to 587 idea although that may work for some cases, in my case the send server port was already 587 and the from address was still changing after entering a to address.  I believe the proper fix is as follows:

     

    1. Enter the mail application and navigate to the Mailboxes screen, at the top right of that screen is the word "Edit" in blue text.  Select "Edit"

    2. The screen will change appearance but your list of mail accounts will appear among other things and on the right side of the screen is a gray menu "icon" (a few horizontal lines), select the icon at the right for the account you want to be the default, this will cause the entire entry to "highlight" (becomes "raised"), then drag it to the first mail account entry. 

    3. Select "Done" at the top right of the screen and you should be good to go.

  • elpedro1978 Level 1 Level 1 (5 points)

    This didnt work for me.  Whenever I create a new message (issue not present when I forward emails) the from address still changes to my icloud account after I enter in the to address, even though icloud id not my default mail account within the settings menu.  Problem still occurs even after following your tip :-(

  • rfh723 Level 1 Level 1 (10 points)

    I'm sorry that this didn't work for you.  But just to check to be certain.  In Settings->Mail, Contacts, Calendars down near the bottom of the "Mail" section.  The value there for "Default Account" I don't believe has any meaning in the context of the discussion.  If you look at the text just below the setting it states that this is the default mail account to use when an application outside of mail attempts to send mail.  The setting I'm speaking of is Mail->Mailboxes then select "Edit".  If that is what you have done and it didn't work for you sorry.  However this is how (or similar to this) the default mail account has been set for as long as I've been using mail (iOS 4 if I remember correctly)

  • elpedro1978 Level 1 Level 1 (5 points)

    Thanks but I disagree. If I change the default mail account under Settings > Mail it does change the initial From email address within the Mail app when sending a new mail (until the bug kicks in anyway). This is certainly how it used to work under ios5 and ios6 anyway. I have 4 email addresses and was always particular about the default one (not my icloud one). This never happened before ios7 - the account I specified under settings would always be the one that email was sent from.

  • elpedro1978 Level 1 Level 1 (5 points)

    Oh, and just to add, whilst under Settings > Mail it does indeed state 'default mail account to use when an application outside of mail attempts to send mail'.  However also when you are in the Mail app and on the main screen where you can see all your mailboxes, the Mail App also needs a 'default' account, and in my experience/opinion this is pulled from the Default account within Settings > Mail rather than which ever mailbox is top of the list within the Mail app (didnt work for me!)

     

    But regardless, I have sent an email from an app outside of Mail and the issue is encountered:-  I have my virgin.net as my default email (via Settings > Mail).  I go into the Photo app, and select a photo to email.  My virgin.net email is showing in the From box - so far so good.  I select an email address for the To box.  My From email address switches to my iCloud.com address.  So this is the bug.  It should not be doing this.  This is the same issue it seems encountered by the original member of this thread.  Anyone know how you alert Apple to bugs in their software?

Previous 1 2 3 Next