Previous 1 2 3 4 Next 46 Replies Latest reply: Sep 20, 2014 8:45 AM by Ellen Higgins Go to original post
  • Jack Frantz Level 2 Level 2 (320 points)

    Mmm. Trouble is, it still is in the list (the official one) when I choose the driver. It always was.

  • Ham Level 2 Level 2 (175 points)

    Canon has dropped support for these older models (4000, 4200).  Do not wait for anything from Apple, becuase nothing is coming.  Once a vendor dropps support for their 6 or 7 year old designs, there is nothing Apple is going to do to undo this.

     

    There are recommendations for GutenPrint or other 3rd party solutions if you need to continue using this printer.

     

    If you do buy a new printer, I recommend that you get one with AirPrint.  That way you are not dependent on a vendor provided driver (http://support.apple.com/kb/HT4356)

  • Jack Frantz Level 2 Level 2 (320 points)

    It turns out to be a networking issue: the ip4200 works (it even installs automatically) when connected directly to the Mac. What is different in Mavericks?

  • PAHU Level 6 Level 6 (15,180 points)

    I believe that the iP4200 does not have built-in network so you would have the printer connected via USB cable to a print server / wireless router. Is this correct?

     

    As for what is different in Mavericks, from what I have seen I don't think that there is any difference to 10.8 or 10.7 with regards to the network connections for printing.

  • Jack Frantz Level 2 Level 2 (320 points)

    Yes that is correct. It is connected to à Windows XP machine and it had worked this way from day one - ie before 10.9...

  • PAHU Level 6 Level 6 (15,180 points)

    Interesting. For a long time the Canon drivers have not been able to function correctly when the printer is connected to Windows and shared. For this type of network connection the Gutenprint driver has been required. So I would expect that you were using Gutenprint driver rather than the Canon supplied driver.

  • Jack Frantz Level 2 Level 2 (320 points)

    Nope! I was printing from the Apple bundled driver, which won't go by the way, and still printing that way from my Mini (10.7) and black MacBook.

  • sailormac Level 1 Level 1 (0 points)

    Canon iP4200: First effort at printing in Mavericks (from PhotoShop) my Printer Proxy advised that I needed to Repair Permissions and gave me an option OK or Cancel. After OK printing was fine. Maybe you could go into Disk Utility/Macintosh HD/Repair Permissions.

    Good luck.

  • dJacobsen Level 4 Level 4 (1,015 points)

    Canon has no support for my Canon Pixma ip8500, either, and I was getting a bit frustrated.  I tried Gutenprint v5.2.9 based on your advice, and it worked perfectly.  Thanks for the suggestion and link!

  • David6696 Level 1 Level 1 (0 points)

    I also had problems printing with an iP4000 and after reading the comments here I wrote to Canon support - this is their answer back:

     

    Thank you for your request and for contacting Canon.

    We are sorry to read that you have updated your computer to Mac SO 10.9 and now your printer is no longer recognised. We regret to inform you that no drivers are available for your iP4000 and that non (sic) will be made available.

    To explain this lack of availability we would like to provide you with some additional information regarding Canon's policy towards the provision of drivers for new operating systems.

    At the time of launch of a new product, Canon generally provides drivers so that the product in question will operate on all existing and known future planned operating systems.

    When the launch of a new operating system is announced, Canon reviews the existing product range to see which of these products can be considered for the provision of compatible drivers.

    There are many different factors that may influence this decision. These can include (but are not limited to) such factors as the technical compatibility between the new operating system and the Canon product, the cost of driver development, the cost of supporting utility software product updates, the issue of certification of the developed driver by the operating system in question, the expected lifetime of the Canon product and costs associated with quality assurance.

    Canon respects the right of its customers to decide to upgrade their operating systems and we attempt to make it clear at the time of purchase which products will function on which operating system.

    Furthermore, Canon always advises its customers to check the compatibility of their associated Canon products prior to the upgrade of an operating system. To this purpose, our consumer helpdesk staff are always available to assist customers with such enquiries.

    We hope that the information above offers enough explanations with regards to the unavailability of the updated driver that you need.

    Once again, thank you for contacting Canon Technical Support. We trust that the information above is of use to you. Please do not hesitate to contact us again if you have any further questions or enquiries.


  • David6696 Level 1 Level 1 (0 points)

    Update: On the back - or lack - of Canon's support, I was just about to flog the printer and spare inks on Gumtree when I decided to check it one more time.

     

    I followed the instructions here - http://support.apple.com/kb/PH10663 - I updated the software, unplugged and then replugged the printer...and it's now working perfectly.

     

    (Admittedly, I had the same message yesterday as sailormac above - repair permissions - but it didn't appear to respond to clicking OK. Perhaps a reboot was all it needed.)

     

    Hope this is helpful to others in the same situation.


  • flowgrow Level 1 Level 1 (0 points)

    I also had a problem with my iP4200 on Mavericks. I couldn't print duplex anymore and also a lot of the print settings where stroke through (like Duplexprinting and Borders)


    So what i did was delete the ip4200 from my printers, download the driver for the iP4300 from canon and then re-add the ip4200. but this time with the ip4300 driver.

     

    works for me.

    tell me how this works out for you.

  • rndym Level 1 Level 1 (0 points)

    I upgraded a late 2012 iMac to 10.9 and could no longer print to my Canon iP4300 PIXMA. After hours of off and on trouble shooting and wasted time, I moved the printer off this iMac and onto the late 2006 iMac running 10.6.8. Printing works fine again, and I can print from my 2012 Macbook Air with 10.9  and the iMac with 10.9. So the upgrade to 10.9 has definitely broken the ability to print and networked printing services on what looks like many printers.

  • Jo! Level 1 Level 1 (15 points)

    hi, I don't know if it helps and how to make this constructive But…

     

    I installed 10.9 on a partition, having become 'wise' over the many years. This gives me the opportunity to testrun the Os and to see if there are workarounds.

    In this case I found one and it is relatively simple:

    Because I have a partition on the same drive, I still have the full install of ML. Now, in the library (main and personal in divers folders) the drivers are stored. What I did is copy/paste the whole folder and replaced it in the 10.9 location. Result: it works like before.

     

    Point is here: the software (drivers) just works, it is just the installer I guess hat does not work.

     

    Hope it helps?

  • Shawn Grinter 2 Level 3 Level 3 (950 points)

    Hi,

     

    Odd, my ip4200 works fine - but then it is connected via an AirPort Extreme.

     

    Driver version is 10.67.1.0

     

    Regards,

    Shawn