Previous 1 6 7 8 9 10 Next 249 Replies Latest reply: Aug 21, 2015 3:56 PM by ma77hew.su11ivan Go to original post
  • vk5880 Level 1 Level 1 (0 points)

    Could you give some advice how to set up Windows on GPT style disk with OsX 10.9 installed. Have you managed it?

  • levelel Level 1 Level 1 (0 points)

    Worked for my 2011 early MBP!!!

    Thanks sooooooo much!

  • CharlieEEE Level 1 Level 1 (0 points)

    For all those who are having trouble, here is what I did and I got it to work on a late 2010 Macbook Air (which officially cannot boot from a USB drive and does not support Windows 8).

     

    First, edit the plist of Boot Camp Assistant.

    1. Go to Applications/Utilities
    2. Right click Boot Camp Assistant and view package contents
    3. Find Info.plist in the Contents folder and edit it in Text Edit (it will make you duplicate the file first)

     

    Before you do anything, make a backup of Info.plist or the whole Boot Camp Assitant app so that you can go back if necessary. Rename it something like "Info old.plist" or "Original Boot Camp Assistant."

     

    You want to edit FOUR things:

    • Add your model to DARequiredROMVersions
    • Delete the word "Pre" from UEFIModels and add your model
    • Delete the word "Pre" from USBBootSupportedModels and add your model
    • Remove your model from Win7OnlyModels (if its there)

     

    To add your model to these lines, just copy and paste an exsiting row and replace the data between the two <string> tags with your model code. You can find the right codes to use for the plist by going to Apple Menu > About This Mac > More Info > System Report. Use the "Boot ROM Version" and "Model Identifier" as appropriate in the plist.

     

    Once you make these changes, save the file and replace the old Info.plist with your new one. It will ask you to type your password.

     

    The last step is to do a code sign. Boot Camp Assitant will not run if it's been edited. You need to resign it. Open Terminal (use spotlight to find it) and type this:

    sudo codesign -fs - /Applications/Utilities/Boot\ Camp\ Assistant.app

     

    It will probably ask for your password. Then it will say you need to download a developer tool from Apple. Agree to download it. (You don't need to install the whole X-Code, if it asks.) Once its been installed (its automatic), you need to go BACK to Terminal and run that command again. This time it will work.

     

    After you've done that - open your hacked Boot Camp Assitant (it should run now) and have it make the Windows installation drive for you. Have the Windows ISO handy, and plug in a flash drive thats about 4-8 GB or more. The entire flash drive will be erased. This process can take a while. When its done, restart your mac and hold the option key. The USB drive that Boot Camp made for you will be there for you to install windows from. Its a yellow disk icon labeled EFI Boot.

     

    I did this on a Late 2010 Macbook Air, which offically does not have a true version of UEFI. It worked anyway. This does the job. I think it might be because I edited the UEFI line in the plist and then had Boot Camp make the USB drive for me.

     

    Worked. Like. A. Charm.

  • CharlieEEE Level 1 Level 1 (0 points)

    The Windows Installer can create and install to a drive in a gpt disk if you boot from EFI. If you boot in the legacy way it wont let you.

  • zoomos Level 1 Level 1 (0 points)

    I tried your method and it still doesn't work for me, previous attempts I was only editing 2 items in the info.plist but the other 2 didn't have an effect.

     

    I have a 12.1 iMac Mid 2011 and it will not boot using usb at all. I tried 2 USB drives and even a USB Enclosure HDD with 3 different HDD's

     

    I guess I'll have to buy some DVD's.

  • CharlieEEE Level 1 Level 1 (0 points)

    Hmm. If it still won't boot from even an bootcamp made USB, you might want to consider rEFIt (http://refit.sourceforge.net/doc/). It's an efi boot loader that can definitely load USB drives. Supposedly it's uninstallable when you are done, but I've never tried. It's a bit less elegant than apples boot menu.

     

    The again, I'm trying this on a MacBook Air. Those might be different since they don't have cd drives.

  • landmarkaudio Level 1 Level 1 (0 points)

    All, I have tried all of the above solutions.  I need USB to boot simply because my bootcamp install crashed and I am away from without discs, etc.  Is it possible that there are just some USB sticks that will not boot?  The latest thing I tried is using Diskpart on a PC to format the thumbdrive (PNY 32GB) and copy install files onto it.  Even using rEFIt I get the "bootable device not found" error.  Really stumped. 

     

    2011 MBPro, 10.9.1  Bootcamp was installed before the update to 10.9...

  • landmarkaudio Level 1 Level 1 (0 points)

    How did you fix the no bootable device found error?

  • zoomos Level 1 Level 1 (0 points)

    I think you are having the same problem I had, If you hold down option and you do not see the USB thumb, you have to use a DVD.

     

    I found a blank TDK DVD-R and it works perfectly, do not buy Sony DVD-R, they do not work with mac. (Medium Write Error)

     

    If your superdrive is broke, you'll have to fix it or use the virtualbox method http://blog.laaz.org/tech/2012/04/24/installing-windows-7-on-macbook-pro-without -superdrive/

  • redneuron Level 1 Level 1 (0 points)

    great job jognt, wonderful post (though i found out about it only after a 2-day research in to the subject).

    however, i still cannot find a solution to installing windows 7 from a usb.

    i'd be grateful for any advice if you have the time:

     

    i have a macbook late 2008 - core 2 due, 2gb ram, 250gb hdd and the internal superdrive.

    the hdd has osx snow leopard with win7 32-bit partitioned in bootcamp.

     

    i performed a little surgery to my little mac so it could run much faster than before:

    1. replaced one of the 1gb ram sticks to a 4gb ram stick (=5gb of total ram). would be happier with 8gb, but upon replacing both sticks i get a memory error which i could solve up to this moment (though this is probably not related to nmy problem).

    2. replaced the superdrive with a 250gb ssd from samsung (840 series).

     

    i downloaded mavericks osx 10.9.1 and loaded it into a 16gb usb, which installed flawlessly on the ssd (125gb partition).

    as i've formated the usb using snow leopard's disk utility and hadn't install any lions, i had no recovery partition (which disables "find my mac" along with other stuff). i decided to add a recovery partition, and have successfully done so using a custom app named Recovery Editor (instructions can be found here: http://forums.macrumors.com/showthread.php?t=1606779).

     

    next, i've tried to install windows 7 64-bit on the same drive (ssd) on the second partition - 125gb formatted to fat32. i've placed win installation files in the usb using the modified boot camp assistant (removed "pre" from "PreUSBBootSupportedModels" and "PreUEFIModels", added my model under "DARequiredROMVersions" and "UEFIModels").

     

    before even trying to use this usb (and following a mass amount of people reporting peoblems), i decided to use your method: formatted the usb with diskpart (fat32, active), added the windows installation files from an iso (which includes both 32- and 64-bit versions), copied the bootcamp v5 support software and restarted the computer.

     

    however, pressing the option key shows 4 options - the snow leopard partition and win7 32-bit partition on the hdd and mavericks partition and recovery partition on the ssd.

    the usb is not recognized.

    i tried clearing the pram (option+command+r+p) and eject and insert the usb after pressing option to see if it will add the usb to the list.

     

    from what i've read around, some people were able to use their usb if they disconnected the hdd and placed the ssd instead (leaving the cdrom place empty), but i would rather avoid this.

     

    might anyone have an idea how to fix this?

     

    many thanks.

  • huhuskunk Level 1 Level 1 (0 points)

    So guys, sorry for my bad english.

     

    I saw many of you have troubles. Above instructions are correct.

     

    For those, this didn't work, you should try to install via Appstore Xcode 5.

     

    Yes that's all, you just have to install to make it work.

     

    To be sure to avoid issues, I recommend to edit the info.plist directly by using Xcode.

     

    Good luck.

  • Kit 1225 Level 1 Level 1 (0 points)

    It doesn't work on my MacBook Air 13" late 2010 OSX10.9.1 Bootcamp 5.1.0.

     

    /Applications/Utilities/Boot Camp Assistant.app: the codesign_allocate helper tool cannot be found or used

     

     

    so sad

  • timonline79 Level 1 Level 1 (0 points)

    You are a life saver. I had the original file saved as info.plist.bak and it was still conflicting with the signing process because as soon as I moved it to my documents, it works flawlessly.

     

    Thanks

  • Wanderglobe Level 1 Level 1 (0 points)

    Worked for me. Thanks.

  • Jujucap Level 1 Level 1 (0 points)

    Hello, your explication is very clear and helpfull but i have a problem that you could maybe resolve?  when i'm in my terminal i can't type my password it's really weird and i'm blocked. What i'm suppose to do?

    Thank for everything

Previous 1 6 7 8 9 10 Next