Previous 1 8 9 10 11 12 Next 254 Replies Latest reply: Nov 20, 2015 9:23 AM by l00nix Go to original post
  • Sassy Beard Level 1 (0 points)

    thanks! I found a more clear guide on how to do this, it's working (i think)

    It's been copying windows files for about 3 hours now and hasn't moved, it's almost half way done.

    Nevermind, it seems to be working fine now. sorry.

  • MattTheRose Level 1 (0 points)

    How did you fix this problem? I am having the same problem. You said you fixed it but did not explain how. This is driving me crazy! HELP please!

  • MattTheRose Level 1 (0 points)

    /Applications/Utilities/Boot Camp replacing existing signature

    /Applications/Utilities/Boot Camp code object is not signed at all

    In subcomponent: /Applications/Utilities/Boot Camp


    This message keeps appearing when I use the terminal and enter the command suggested by this thread. I have no idea why, though, obviously, it has something to do with the time machine feature. I NEED to get this working. Anyone who can point me in the direction of how to bypass this error would be awesome!

  • boso400 Level 1 (0 points)

    Thank you! Thank you! Now I can stop crying IT WORKED!!!

  • Dj Saurabh Level 1 (0 points)

    Evry thing goes fine but after bootcamp partition and says no bootable divise found...Insert a bootable media nad press a key...!!!
    Plz help

  • Dio_Brando Level 1 (0 points)



    I have a Mid 2010 Mac Mini (4,1 model) with Mavericks on it and I'm trying to set a native Dual Boot with Windows 8.1 x64 EnterpriseOS using a pendrive installation.


    I followed some advices and guides here and there:

    1) copy the Info.pslist and put the backup on the Desktop

    2) edit the Info.pslist

    • putting Bootrom at the top in the DARequiredROMVersions section
    • deleting "Pre" from USBBootSupportedModels section
    • add in the the one before, at the top, my model string
    • removing my model from Win7OnlyModels section


    Now that looks like this:





















































    3) Installed XCode

    4) performed the command as it follows:

    sudo codesign -f -s - /Applications/Utilities/Boot\ Camp\\ Camp\ Assistant


    /Applications/Utilities/Boot Camp Camp Assistant: replacing existing signature


    BootCamp Assistant now recognizes the chance of install Windows 8 and do it not only from DVD

    Schermata 2014-03-26 alle 03.16.34.png

    5) Set the pendrive up with BootCamp Assistant 5 from a Mac Book Retina Late 2013. Contents look as it follows:

    Schermata 2014-03-26 alle 03.21.01.png

    By the way, the drivers are last version I suppose:


    BuildInfo BuildNumber="5640" ProductName="Boot Camp">


      <ProductManufacturer>Apple Inc.</ProductManufacturer>





    6) Partitioned the MacHD that now looks like:


       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:      GUID_partition_scheme                        *250.1 GB   disk0

       1:                        EFI EFI                     209.7 MB   disk0s1

       2:                  Apple_HFS MacOSX                  49.2 GB    disk0s2

       3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

       4:       Microsoft Basic Data Untitled                200.0 GB   disk0s4


    When I boot into Pendrive, 8.1 Setup begins but then I get into the MBR/GPT Error



    7) Installed gdisk and discovered that I already have a Hybrid MBR (Win8.1 compatible right?)


    sudo gdisk /dev/disk0


    GPT fdisk (gdisk) version 0.8.10


    Warning: Devices opened with shared lock will not have their

    partition table automatically reloaded!

    Partition table scan:

      MBR: hybrid

      BSD: not present

      APM: not present

      GPT: present


    Found valid GPT with hybrid MBR; using GPT.


    8) Checked the partitions on Pendrive:



       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:     FDisk_partition_scheme                        *7.9 GB     disk1

       1:                 DOS_FAT_32 WININSTALL              7.9 GB     disk1s1


    9) Installed rEFIt.
    Here are several possibilities as u can see from the sshot:



    The only one that brings me to the Windows 8.1 Installation Setup is the highlighted one: bootx64.efi

    On the left u have 32bit efi that doesn't work obviously because I'm trying to install a x64 OS, the others on the right neither and I suspect it's the same reason that in the OSX "normal" boot choice I see OSX, Recovery and EFI Boot Partitions...


    Before trying to create a UEFI custom pendrive or modifying the partition system,

    how can I be sure that partition of BootCamp installation on Pendrive is really active?



    Sorry for the endless post...

  • Dio_Brando Level 1 (0 points)



    diskutil on pendrive


    diskutil info /dev/disk1

       Device Identifier:        disk1

       Device Node:              /dev/disk1

       Part of Whole:            disk1

       Device / Media Name:      Kingston DataTraveler 3.0 Media


       Volume Name:              Not applicable (no file system)


       Mounted:                  Not applicable (no file system)


       File System:              None


       Content (IOContent):      FDisk_partition_scheme

       OS Can Be Installed:      No

       Media Type:               Generic

       Protocol:                 USB

       SMART Status:             Not Supported


       Total Size:               7.9 GB (7862353920 Bytes) (exactly 15356160 512-Byte-Units)

       Volume Free Space:        Not applicable (no file system)

       Device Block Size:        512 Bytes


       Read-Only Media:          No

       Read-Only Volume:         Not applicable (no file system)

       Ejectable:                Yes


       Whole:                    Yes

       Internal:                 No

       OS 9 Drivers:             No

       Low Level Format:         Not supported





    Volume      3      F      WININSTALL      FAT32      Removable      7498 Mb

    DISKPART> detail partition


    Partition 1

    Type: 08
    Hidden: No

    Active: Yes

    Offset: 1024



    So...the partition active, filesystem is FAT32, MBR is hybrid but I can't install Win 8 though ...suggestions?

  • Dio_Brando Level 1 (0 points)

    Ok solved that.

    I changed the Hybrid MBR to the Protective MBR.


    The point least on old Mac. If u use the BootCamp assistant to partition and a pendrive USB installation, ti creates a hybrid MBR as it would with Windows 7, because it's not totally (u)EFI compliant, but, the pendrive filesystem is FAT32 and Win8 only installs through/in NTFS partitions.

    So...2 choices:

    1) format NTFS, prepare the pendrive installation and keep the Hybrid MBR

    2) convert the hybrid MBR to protective MBR (you can use Gdisk) Link



    Now I got into another problems, regarding BootCamp. I already read about it...the hardware is not straight supported, so after the Win 8.1 installation a popup came out saying "The version of BootCamp is not intended for this computer model".

    I should sort it out, forcing it through the msi/run as installation. Otherwise I'll try install drivers one by one.


    Let ya know...

  • Nuno_spl Level 1 (0 points)

    HI I've the same laptop as you a Macbook Pro Early 2011.


    My superdrive is broken and I need to install Windows on my machine from USB, how did you manage to do that?

    I created the usb install using Boot Camp, but wont boot from usb !!!


    Please, I need some help.




  • Joe Boss Level 1 (0 points)

    CharlieEEE wrote:


    For all those who are having trouble, here is what I did and I got it to work on a late 2010 Macbook Air (which officially cannot boot from a USB drive and does not support Windows 8).


    First, edit the plist of Boot Camp Assistant.

    1. Go to Applications/Utilities
    2. Right click Boot Camp Assistant and view package contents
    3. Find Info.plist in the Contents folder and edit it in Text Edit (it will make you duplicate the file first)


    Before you do anything, make a backup of Info.plist or the whole Boot Camp Assitant app so that you can go back if necessary. Rename it something like "Info old.plist" or "Original Boot Camp Assistant."


    You want to edit FOUR things:

    • Add your model to DARequiredROMVersions
    • Delete the word "Pre" from UEFIModels and add your model
    • Delete the word "Pre" from USBBootSupportedModels and add your model
    • Remove your model from Win7OnlyModels (if its there)


    To add your model to these lines, just copy and paste an exsiting row and replace the data between the two <string> tags with your model code. You can find the right codes to use for the plist by going to Apple Menu > About This Mac > More Info > System Report. Use the "Boot ROM Version" and "Model Identifier" as appropriate in the plist.


    Once you make these changes, save the file and replace the old Info.plist with your new one. It will ask you to type your password.


    The last step is to do a code sign. Boot Camp Assitant will not run if it's been edited. You need to resign it. Open Terminal (use spotlight to find it) and type this:

    sudo codesign -fs - /Applications/Utilities/Boot\ Camp\


    It will probably ask for your password. Then it will say you need to download a developer tool from Apple. Agree to download it. (You don't need to install the whole X-Code, if it asks.) Once its been installed (its automatic), you need to go BACK to Terminal and run that command again. This time it will work.


    After you've done that - open your hacked Boot Camp Assitant (it should run now) and have it make the Windows installation drive for you. Have the Windows ISO handy, and plug in a flash drive thats about 4-8 GB or more. The entire flash drive will be erased. This process can take a while. When its done, restart your mac and hold the option key. The USB drive that Boot Camp made for you will be there for you to install windows from. Its a yellow disk icon labeled EFI Boot.


    I did this on a Late 2010 Macbook Air, which offically does not have a true version of UEFI. It worked anyway. This does the job. I think it might be because I edited the UEFI line in the plist and then had Boot Camp make the USB drive for me.


    Worked. Like. A. Charm.

    Perfect, thank you CharlieEEE!!!!!!!

  • Filipstaudi Level 1 (0 points)

    Aorta003 wrote:


    After doing those steps I am still getting the error after trying to start bootcamp.  I am also getting this message in the terminal


    /Applications/Utilities/Boot Camp replacing existing signature

    /Applications/Utilities/Boot Camp code object is not signed at all

    I fixed this by adding --deep at end of terminal command.


    So it became:

    sudo codesign -fs - /Applications/Utilities/Boot\ Camp\ --deep

  • pumar Level 1 (0 points)

    For my MBP mid-2010, this worked nicely for creating the USB drive (but you don't need to use Bootcamp for that, by the way). Installation failed, badly.

    I posted a rough guideline in a different thread, that's the only thing that worked for me - and trust me, I did pretty much everything else:

  • Georgemaxim Level 1 (10 points)

    this solved my problem with crashing boot camp after modifying the plist.



  • Dio_Brando Level 1 (0 points)

    Solved that too.


    Simply I don't use BootCamp drivers at all, let Windows 8.1 find what it needs and then pick up what the system can't find from BootCamp 4.x: Nvidia 320m, Coprocessor, SMBus, Bluetooth.


    The problem is with audio: even though I download Cirrus drivers the system keeps saying "the drivers are up to date". So is there a way to force it?





    can u please provide detailed steps to your solution?
    I have the exact OS installed: Windows 8.1 Enterprise (64 bit)

Previous 1 8 9 10 11 12 Next