Previous 1 9 10 11 12 13 Next 250 Replies Latest reply: Sep 1, 2015 7:18 AM by karwerk Go to original post
  • RockerMau Level 1 Level 1 (0 points)

    You my friend, saved me!

  • kiyux Level 1 Level 1 (0 points)

    Me, I had issues with this that were solved by installing (and starting once) Xcode, just in case somebody experiences the same problem.

     

    In short: you need Xcode for the signature move.

  • roger1762 Level 1 Level 1 (0 points)

    Hi

    I would like to un-do the usb-enable option.

    How can I go back to the original bootcamp application that came with my macbook pro 8,2 ?

    Thanks

     

    p.s. i unfortunately do not have the original info.plist file.

  • iou40p Level 1 Level 1 (0 points)

    Hi All, i have changed the file and bootcamp let's me create the USB install, however my imac can't/won't find the usb drive to boot from on reboot? Any Help? Am on a Imac 7,1 Boot Rom IM71.007A.B03

     

    Thanks

  • iou40p Level 1 Level 1 (0 points)

    Hi Roger

     

    Here is mine, don't why it shouldn't work. Don't worry it's the original. Just edit the file and replace. You might have to recert the file, not sure. If boot camp wont run after you have changed the file run this in terminal

     

    Terminal

    sudo codesign -fs - /Applications/Utilities/Boot\ Camp\ Assistant.app

     

    Bootcamp File Code.

    <?xml version="1.0" encoding="UTF-8"?>

    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

    <plist version="1.0">

    <dict>

        <key>32BitSupportedModels</key>

        <array>

            <string>MacBook7,1</string>

            <string>MacBookAir5,2</string>

            <string>MacBookPro10,1</string>

            <string>MacPro5,1</string>

            <string>Macmini5,3</string>

            <string>iMac12,2</string>

        </array>

        <key>BuildMachineOSBuild</key>

        <string>13D21</string>

        <key>CFBundleDevelopmentRegion</key>

        <string>English</string>

        <key>CFBundleDisplayName</key>

        <string>Boot Camp Assistant</string>

        <key>CFBundleExecutable</key>

        <string>Boot Camp Assistant</string>

        <key>CFBundleGetInfoString</key>

        <string>Boot Camp Assistant 5.1.2, Copyright © 2014 Apple Inc. All rights reserved</string>

        <key>CFBundleIconFile</key>

        <string>DA</string>

        <key>CFBundleIdentifier</key>

        <string>com.apple.bootcampassistant</string>

        <key>CFBundleInfoDictionaryVersion</key>

        <string>6.0</string>

        <key>CFBundleName</key>

        <string>Boot Camp Assistant</string>

        <key>CFBundlePackageType</key>

        <string>APPL</string>

        <key>CFBundleShortVersionString</key>

        <string>5.1.2</string>

        <key>CFBundleSignature</key>

        <string>????</string>

        <key>CFBundleVersion</key>

        <string>484</string>

        <key>DARequiredROMVersions</key>

        <array>

            <string>IM41.0055.B08</string>

            <string>IM42.0071.B03</string>

            <string>IM51.0090.B03</string>

            <string>IM52.0090.B03</string>

            <string>IM61.0093.B01</string>

            <string>MP11.005C.B04</string>

            <string>MB11.0061.B03</string>

            <string>MBP11.0055.B08</string>

            <string>MBP12.0061.B03</string>

            <string>MM11.0055.B08</string>

        </array>

        <key>DTCompiler</key>

        <string>com.apple.compilers.llvm.clang.1_0</string>

        <key>DTPlatformBuild</key>

        <string>5A2053</string>

        <key>DTPlatformVersion</key>

        <string>GM</string>

        <key>DTSDKBuild</key>

        <string>13D21</string>

        <key>DTSDKName</key>

        <string></string>

        <key>DTXcode</key>

        <string>0501</string>

        <key>DTXcodeBuild</key>

        <string>5A2053</string>

        <key>LSApplicationCategoryType</key>

        <string>public.app-category.utilities</string>

        <key>LSMinimumSystemVersion</key>

        <string>10.9.0</string>

        <key>NSMainNibFile</key>

        <string>MainMenu</string>

        <key>NSPrincipalClass</key>

        <string>NSApplication</string>

        <key>PreESDRequiredModels</key>

        <array>

            <string>MacBook7</string>

            <string>MacBookAir5</string>

            <string>MacBookPro10</string>

            <string>MacPro5</string>

            <string>Macmini6</string>

            <string>iMac13</string>

        </array>

        <key>PreUEFIModels</key>

        <array>

            <string>MacBook7</string>

            <string>MacBookAir5</string>

            <string>MacBookPro10</string>

            <string>MacPro5</string>

            <string>Macmini6</string>

            <string>iMac13</string>

        </array>

        <key>PreUSBBootSupportedModels</key>

        <array>

            <string>MacBook7,1</string>

            <string>MacBookAir3,2</string>

            <string>MacBookPro8,3</string>

            <string>MacPro5,1</string>

            <string>Macmini4,1</string>

            <string>iMac12,2</string>

        </array>

        <key>Win7OnlyModels</key>

        <array>

            <string>MacBook7,1</string>

            <string>MacBookAir3,2</string>

            <string>MacBookPro5,5</string>

            <string>MacPro2,1</string>

            <string>Macmini4,1</string>

            <string>iMac10,1</string>

        </array>

    </dict>

    </plist>

  • fcedric Level 1 Level 1 (0 points)

    Many Thanks,

    My superdrive refuse to read DVD DL...

  • Ishayu Level 1 Level 1 (0 points)

    Doesn't  work for me. I've got a MacBook Pro 15" Ultimo 2011.

     

    I replaced the internal DVD drive with an extra harddisk unto which I want to install Windows 7.

     

    Boot Camp creates USB drives which you cannot boot from. rEFIt allows me to boot from it, but I always get "No bootable device" or a BCD error (if I try to boot with EFI).

     

    I've been trying to get Windows 7 on this device for nearly a month now and I'm about to give up. This is insanity. :|

  • Smatpyth Level 1 Level 1 (0 points)

    I have a MacBook Pro Retina, 15-inch, Late 2013, with 1 TB SSD, no other drives (optical, etc) so can only use a USB for BootCamp. Same issues with USB 2.0 stick.

     

    Would be nice if there was a simple BootCamp install for SSD systems.

     

    No Bootcamp for me :-(

  • aman.m Level 1 Level 1 (0 points)

    remove the old info.plist backup from the contents folder (move it out to the desktop and delete it from the folder)... that fixed it for me...

  • Flemdogmillionaire Level 1 Level 1 (0 points)

    Is there a way to get this working for Windows 8? I tried this method and it says Windows 8 is not supported for my Macbook Pro (late 2008, 15 inch).

  • benfromshoreview Level 1 Level 1 (0 points)

    This still worked for me as of July 20 on my (fairly) old MBP. Fantastic, thanks.

  • aaron4tc Level 1 Level 1 (0 points)

    Brilliant! It just works! Save me hours of time on research. A big thank you

  • maholine Level 1 Level 1 (0 points)

    worked for me thanks a lot

     

    MBP 8.1

  • blackandwhite_tk Level 1 Level 1 (0 points)

    To the people having problems with:

     

         /Applications/Utilities/Boot Camp Assistant.app: replacing existing signature

         /Applications/Utilities/Boot Camp Assistant.app: code object is not signed at all

     

    add --deep to the last bit of code in step 4. So like this instead:

     

         sudo codesign -fs - /Applications/Utilities/Boot\ Camp\ Assistant.app --deep


    You're welcome.

  • shaharyar696 Level 1 Level 1 (0 points)

    I've done the same thing as you do, i changed my Boot camp Info.plist to make it support making USB installing drives on my Mac, after i changed Info.plist Boot camp crashes and then it didn't run after several attempts, then after searching for solution i did the same thing,'open terminal and write the above code as you mention, then it appears as /Applications/Utilities/Boot Camp Assistant.app: replacing existing signature. after that i still can't open my boot camp assistant app, every time i try to open it, a message pop up like, "Boot Camp Assistant can't be open error -1712

    I'am using Macbook Pro 13,, OSX 10.9.4 Mavericks

    P.S Help me in his regards if you can, I'll be thaksfull to you :-|

Previous 1 9 10 11 12 13 Next