Skip navigation

Enable Bootcamp to install from usb for OSX 10.9**WORKS**

80882 Views 147 Replies Latest reply: Apr 15, 2014 9:58 AM by pumar RSS
  • Bibi40kai Level 1 Level 1 (0 points)

    this is the proper command line:

    sudo codesign -fs - /Applications/Utilities/Boot\ Camp\ Assistant.app

  • Bibi40kai Level 1 Level 1 (0 points)

    Thank you Jognt for reply.

    i tried on both my MBP81 and IM121. They both came with optical drives (OD) which i replaced with SSD

     

    i tried to boot Windows installer from USB OD and it get's stuck on that black screen with blinking cursor (no other usb devices connected)

     

    i tried to boot Windows installer from USB stick, both created with BootCamp and other methodes i used before Mavericks, the result is the same ... black screen with blinking cursor

     

    i'm trying to install Win 7 SP1 X64

  • r3mOt3r Level 1 Level 1 (0 points)

    i did that, and this what shows in terminal

     

    /Applications/Utilities/Boot Camp Assistant.app: replacing existing signature

    /Applications/Utilities/Boot Camp Assistant.app: code object is not signed at all

    In subcomponent: /Applications/Utilities/Boot Camp Assistant.app/Contents/.com.apple.timemachine.supported

     

    how can i fix it ?

  • Alekhoff Level 1 Level 1 (0 points)

    I also get this messeage ?? Anyone fixed this ? For people how have diffuclty writing to info.plist file this terminal trick did it for me!

     

    sudo chmod 777 /Applications/Utilities/Boot\ Camp\ Assistant.app/Contents

    sudo chown 777 /Applications/Utilities/Boot\ Camp\ Assistant.app/Contents

     

    sudo chmod 777 /Applications/Utilities/Boot\ Camp\ Assistant.app/Contents/info.plist

    sudo chown 777 /Applications/Utilities/Boot\ Camp\ Assistant.app/Contents/info.plist

  • Quic5 Level 1 Level 1 (0 points)

    HI!

     

    Qustion:

    Is this true?

     

    The "USB method is not supported on Macs that have an optical drive", even when it is broken.

    Fix the drive and use a DVD.

    Bootcamp will not load Windows installer - No bootable device, insert disk then press any key

    Is my problame ... We have a 27"imac 2009 and the optical drive is gone...

    I try the Mavericks, and the mountain lion too. I didi everything with the Info.plist ect... and , i tried 3 tipe of windows7 and i still stuck on this point

    Bootcamp will not load Windows installer - No bootable device, insert disk then press any key

  • Jognt Level 1 Level 1 (30 points)

    Hi Bibi40kai. Do you let Bootcamp Assistant reboot your mac into the installer, or do you manually select the boot device?

     

    As I understand it, Bootcamp Assistant will attempt to boot of the Optical Drive before the USB device. If you don't manually select a boot device it is possible that it is trying to boot of of your 2nd harddrive (that is in the ODD slot), but failing because there are no install files on it after which it somehow also fails to switch to booting from USB.

     

    Have you tried holding Option while rebooting your mac and Manually selecting "Windows" with the yellow disk icon?

    If you have, then I think the last thing to check would be to temporarily disconnect your second harddisk. You don't need to remove it from your Mac, but disconnecting it should make sure it doesn't hinder the boot process.

     

    ===============

    Hi Quic5, your post is somewhat hard to understand because of a single question with multiple linked pages (in different formatting no less).

     

    I can tell you though that this:

    "USB method is not supported on Macs that have an optical drive" is NOT true.

     

    My Macbook Pro mid 2012 and black Macbook mid 2006 both managed to install from USB and they both have optical drives.

    ================

     

    General troubleshooting:

    If you hold Option wile booting and only see "EFI Boot" (windows 8) and no "Windows" (windows 7 and 8) option to select, then it is possible that the USB drive has not gotten it's partition set to Active. Bootcamp Assistant should set it to Active automatically (I assume, not based on facts) but if you create a USB installer manually, keep in mind that it needs to be set as an Active partition to be recognized as a bootable device.

  • 0132VTSaleen883 Level 1 Level 1 (0 points)

    This worked great... thank you so much for sharing.  I tried the other solutions that were pre Mavericks and they did not work.

  • JNov92 Level 1 Level 1 (0 points)

    Hi, I first started following the previous instructions, which led my Bootcamp to crashing numerous times. I tried your way and Bootcamp finally worked normally again until when I chose to install Windows 7, they asked me for a  CD. Which basically means I'm back to square one. Can you help me with this?

     

    My info.plist is now like this:


    <?xml version="1.0" encoding="UTF-8"?>

    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

    <plist version="1.0">

    <dict>

              <key>32BitSupportedModels</key>

              <array>

                        <string>MacBook7,1</string>

                        <string>MacBookAir5,2</string>

                        <string>MacBookPro10,1</string>

                        <string>MacPro5,1</string>

                        <string>Macmini5,3</string>

                        <string>iMac12,2</string>

              </array>

              <key>BuildMachineOSBuild</key>

              <string>13A566b</string>

              <key>CFBundleDevelopmentRegion</key>

              <string>English</string>

              <key>CFBundleDisplayName</key>

              <string>Boot Camp Assistant</string>

              <key>CFBundleExecutable</key>

              <string>Boot Camp Assistant</string>

              <key>CFBundleGetInfoString</key>

              <string>Boot Camp Assistant 5.1.0, Copyright © 2013 Apple Inc. All rights reserved</string>

              <key>CFBundleIconFile</key>

              <string>DA</string>

              <key>CFBundleIdentifier</key>

              <string>com.apple.bootcampassistant</string>

              <key>CFBundleInfoDictionaryVersion</key>

              <string>6.0</string>

              <key>CFBundleName</key>

              <string>Boot Camp Assistant</string>

              <key>CFBundlePackageType</key>

              <string>APPL</string>

              <key>CFBundleShortVersionString</key>

              <string>5.1.0</string>

              <key>CFBundleSignature</key>

              <string>????</string>

              <key>CFBundleVersion</key>

              <string>473</string>

              <key>DARequiredROMVersions</key>

              <array>

                        <string>IM41.0055.B08</string>

                        <string>IM42.0071.B03</string>

                        <string>IM51.0090.B03</string>

                        <string>IM52.0090.B03</string>

                        <string>IM61.0093.B01</string>

                        <string>MP11.005C.B04</string>

                        <string>MB11.0061.B03</string>

                        <string>MBP11.0055.B08</string>

                        <string>MBP12.0061.B03</string>

                        <string>MBP81.0047.B27</string>

                        <string>MM11.0055.B08</string>

              </array>

              <key>DTCompiler</key>

              <string>com.apple.compilers.llvm.clang.1_0</string>

              <key>DTPlatformBuild</key>

              <string>5A11344p</string>

              <key>DTPlatformVersion</key>

              <string>GM</string>

              <key>DTSDKBuild</key>

              <string>13A566b</string>

              <key>DTSDKName</key>

              <string></string>

              <key>DTXcode</key>

              <string>0500</string>

              <key>DTXcodeBuild</key>

              <string>5A11344p</string>

              <key>LSApplicationCategoryType</key>

              <string>public.app-category.utilities</string>

              <key>LSMinimumSystemVersion</key>

              <string>10.9.0</string>

              <key>NSMainNibFile</key>

              <string>MainMenu</string>

              <key>NSPrincipalClass</key>

              <string>NSApplication</string>

              <key>PreESDRequiredModels</key>

              <array>

                        <string>MacBook7</string>

                        <string>MacBookAir5</string>

                        <string>MacBookPro10</string>

                        <string>MacPro5</string>

                        <string>Macmini6</string>

                        <string>iMac12</string>

              </array>

              <key>PreUEFIModels</key>

              <array>

                        <string>MacBook7</string>

                        <string>MacBookAir5</string>

                        <string>MacBookPro10</string>

                        <string>MacPro5</string>

                        <string>Macmini6</string>

                        <string>iMac13</string>

              </array>

              <key>USBBootSupportedModels</key>

              <array>

                        <string>MacBook7,1</string>

                        <string>MacBookAir3,2</string>

                        <string>MacBookPro8,1</string>

                        <string>MacBookPro8,3</string>

                        <string>MacPro5,1</string>

                        <string>Macmini4,1</string>

                        <string>iMac12,2</string>

     

              </array>

              <key>Win7OnlyModels</key>

              <array>

                        <string>MacBook7,1</string>

                        <string>MacBookAir3,2</string>

                        <string>MacBookPro5,5</string>

                        <string>MacPro2,1</string>

                        <string>Macmini4,1</string>

                        <string>iMac10,1</string>

              </array>

    </dict>

    </plist>

    Screen Shot 2013-11-03 at 12.13.32 AM.pngBoth Boot ROM Version and Model Identifier has been inserted.

  • Chico_sirio Level 1 Level 1 (0 points)

    You are great man, just work as I want and now I can create a bootable usb stick........

    Thanks alot

  • r3mOt3r Level 1 Level 1 (0 points)

    am still getting this in terminal

     

    /Applications/Utilities/Boot Camp Assistant.app: replacing existing signature

    /Applications/Utilities/Boot Camp Assistant.app: code object is not signed at all

    In subcomponent: /Applications/Utilities/Boot Camp Assistant.app/Contents/.com.apple.timemachine.supported

     

     

    any fix please ?

  • r3mOt3r Level 1 Level 1 (0 points)

    finally fixed my problem, but now i have other problem lol

     

    No Boot Device ? any help ?

  • r3mOt3r Level 1 Level 1 (0 points)

    i fixed my problem, paste me full error which show on ur terminal and i will do my best help u

  • Quic5 Level 1 Level 1 (0 points)

    HI Joghnt!

    I have a 2009 Imac27' and the optical drive is dead.

    Thats why I try to install from usb everything.

    I did this Info.plist storry and thats works

    And when i try to intsall windows7 with bootcamp. When the instalation is rebooting:

    "Bootcamp will not load Windows installer - No bootable device, insert disk then press any key"

    When I reboot again with hold option key I see that efiboot yellow USB icon .. then I click it .. after stuck.

    Reboot again and check the partitions and the BOOTCAMP partition is ok... active.

    I Tried to 3 differnt windows7 and I tried in osx10.9, 10.8

    I find what mr robocop21 wrot:

    Step 1) FORGET BOOTCAMP (you heard it right)

    Step 2) Go to disk utility from launchpad - other folder

    Step 3) Select the single partition Mac HDD

    Step 4) Go to partition tab and make two partitions of any size by clicking the + sign at the bottom

    Step 5) Now simply select the new partition by clicking it once, Go to Erase tab and then click erase

    Step 6) Now it will show a blank Partition

    Step 7) Insert the Windows DVD and select it as the start up disk through the System Prefrences menu

    Step 8) Restart and press option key at the chime

    Step 9) The boot option shows up with Mac OS / Restore / EFi boot options

    Step 10) Select EFI Boot Option and click return

    Step 11) The next screen starts the windows installation

    Step 12) After the initial screen it will show the HDD option to choose which partition to use

    Step 13) Select the blank / unformatted partition and click format from below

    Step 14) Once it gets formated click next and voila, it starts the installation

    Step 15) Just dont touch anything untill the setup finishes after two or three restarts (Do not Touch)

    Step 16) Once the setup is complete, Google n download the Bootcamp Drivers for Windows 8 from Apple Site

    Step 17) Download the zip file and select setup and this will setup the much needed drivers for all the devices

     

    My problame is my disc drive is not working

     

    This Csound1 Guy said:

    USB method is not supported on Macs that have an optical drive

     

    any  idea?

     

    I don't wanna use Parallel and Vmware just only bootcamp...

  • Mr Backlin Level 1 Level 1 (0 points)

    I got the USB installer creation part of Bootcamp to show up.  Now, like others, it keeps saying, no boot device found, press any key, blah blah.  I'm assuming its because its looking for boot info from the optical drive first before USB.  I tried rebooting while holding Option and the only USB option I was given was EFI Boot along with my Macintosh HD, Recovery. 

     

    Is there something else I'm missing?  Can someone help out?

  • Jognt Level 1 Level 1 (30 points)

    Usb method not supported on macs with ODD = Not true. Don't know how often I have said this now, but please don't listen to these people..

     

    Quic5 and Mr Backlin, I experienced the same issue which I managed to solve. I'm not 100% sure what fixed it (since I tried several things) but here is what I suspect.

     

    The partition on the USB drive needs to be set as *active* to notify the mac that it can actually boot from it. This is not needed for EFI which is why you can see the EFI Boot option.

     

    The way I suspect I fixed it is by making the partition active in Windows like so:

    1. Open a command prompt (type CMD in the Start Menu search bar, press enter);

    2. Type "diskpart";

    3. Type "list disk";

    4. Look for the entry of your USB drive and remember it's number (checking disk sizes usually helps in spotting it);

    5. Type "select disk x", where x is the disk entry you checked in step 4;

    6. Type "clean";

    7. Type "create partition primary";

    8. Type "format fs=FAT32 quick";

    9. Type "active";

    10. You're done, type "exit" twice. (once to exit diskpart, again to exit command prompt);

     

    If you already filled your USB drive and don't feel like cleaning it and doing it again, you can try skipping steps 6-8 and just typing "active" after selecting the disk. I haven't tried it before but I see no reason it shouldn't work.

     

    If you don't have access to a Windows PC, you can try the following:

    http://www.insanelymac.com/forum/topic/22844-how-to-setting-your-partition-activ e-using-fdisk-in-macosx/

     

    My experience was that this did not work properly though, so *your mileage may vary*.

     

    Since it's 5am here and I really really really wish I could fall asleep, I'll leave you with this. I'll run some tests tomorrow or the day after to check what solution is best, quickest, and easiest to do.

1 2 3 4 5 ... 10 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.