Previous 1 2 3 4 5 6 Next 218 Replies Latest reply: Apr 27, 2015 8:07 PM by parifuture Go to original post
  • Mr Backlin Level 1 Level 1 (0 points)

    I'll have to try that.  The thing is, I used the Bootcamp USB creation tool.  So why wouldn't it work?  The weird thing is, I had to create a USB tool for my MBA.  It worked there.  So I thought, I would use my MBA to create the drive and then plug it into my iMac...still no go. 

  • Jognt Level 1 Level 1 (30 points)

    Hmm, very good argument Mr Backlin. I have no idea why it didn't work in that case. One would think that a USB drive prepped by the Bootcamp Assistant works as advertised..

     

    As I said, this may be a fix for those that created their own bootable USB drives. If it works for you, please let us know .

     

    Seeing as it's 7:30am here now, I'll see if I can get some testing/troubleshooting done on my Macbook. Don't think sleep will be coming any time soon anyway xD.

  • Mr Backlin Level 1 Level 1 (0 points)

    Well, I tried skipping steps 6,7,8 and it didn't work.  I guess the next step is to try the full set of steps.  After you go through command prompt to deal with partition creation on the drive, it is a simple matter of dragging the files back over or is there another tool I should use to do that?

  • JNov92 Level 1 Level 1 (0 points)

    Hi Jognt,

     

    I hope you don't mind helping me as well. I posted my problem on the previous page. I did what was asked. I have an early 2011 MBP (MBP 8,1). But until now Bootcamp still asks me for a CD. Did I do something wrong? Thank you!

  • Jognt Level 1 Level 1 (30 points)

    What did not work? One of the following came up:

    "No partition selected" ?

    "Partition marked as active" but it didn't show up @ boot?

     

    After you re-created the partition using diskpart, it should be enough to copy the content of a Windows ISO/DVD over to the USB drive along with the required Bootcamp drivers.

  • Jognt Level 1 Level 1 (30 points)

    Jnov92, it asks for a windows installation disk, not specifically a DVD .

    You most likely want to use an ISO to install Windows? If so, mount the ISO (doubleclick it) and Bootcamp Assisstant should stop nagging you. It basically asks for a valid installation drive so it knows for sure you can install Windows when you reboot. It does not (well, should not) care whether that "drive" is a DVD, USB, or mounted disk image.

     

    Sorry I missed your question the first time JNov92! I saw a lot of PList information and assumed you needed BITTe's help since I don't know anything about PList editing for USB compatibility.

  • JNov92 Level 1 Level 1 (0 points)

    This is what I have. I got this from a friend and he installed it to his computer and everything was fine with his, because he has a newer version of Macbook. Screen Shot 2013-11-04 at 7.11.22 AM.png

  • Jognt Level 1 Level 1 (30 points)

    Looks like a Windows ISO unpacked and combined with Bootcampt software. No need to use Bootcamp Assistant in that case.

     

    Have you already partitioned the drive? If not, you can do so using disk utility. split your drive so there is room for a windows partition, and format that (windows) partition as FAT32. That will automagically set your drive up for Bootcamp.

     

    You can copy those files from the screenshot to a USB drive in Finder. Just make sure to prep the drive as I mentioned earlier (making the partition on the USB drive active)

  • r3mOt3r Level 1 Level 1 (0 points)

    tried this and still no boot device MBP late 2011

  • Jognt Level 1 Level 1 (30 points)

    What did you try? @ r3mot3r.

     

    =======

    Having read a few threads around the web it appears the USB drive created by Bootcamp Assistant should be bootable. I do not know what caused it to not show up in your situation Mr Backlin. You may try removing the USB drive at the boot-option menu, and plugging it back in after a second. If you reboot without unplugging/replugging it it sometimes doesn't show up properly.

     

    =======

    Just ran some tests trying to boot from:

    1. USB formatted FAT32 using Disk Utility;

    2. USB formatted FAT32 using Diskpart in Windows;

    3. USB formatted FAT32 using Diskpart in Windows with partition set active;

     

    Note: All tests were performed with the content of a Windows 7 professional 64-bit SP-1 ISO.

     

    Result:

    Only the third option showed up as bootable.

     

    Conclusion:

    In order for the USB drive to show up as bootable without using bootcamp utility you need to clean, create, format, and set the partition as active using Diskpart in Windows.

     

    Diskpart is available in most CMD prompt. You can use another Windows PC, or open a CMD prompt during a Windows installation using SHIFT+F10.

     

    If the drive is not recognized in the boot menu, remove it from the USB connection, and plug it back in after a second. This triggers the boot menu to rescan for bootable content.

  • r3mOt3r Level 1 Level 1 (0 points)

    i tried all Diskpart steps like u said on pervious post and still don't boot and don't show when i press ALT, i just see Mac HD and recovery partition

  • Jognt Level 1 Level 1 (30 points)

    Strange. Can you please post the exact steps you took?

    example:

    plugged in 64gb USB drive

    cleaned & formatted  in windows with diskpart

    set active

    copied files from iso

    copied files from bootcamp 4 or 5

    rebooted while holding alt

    unplugging and replugging usb drive

  • r3mOt3r Level 1 Level 1 (0 points)

    i pluged in 8GB usb drive, then i did exact steps like this

     

    The way I suspect I fixed it is by making the partition active in Windows like so:

    1. Open a command prompt (type CMD in the Start Menu search bar, press enter);

    2. Type "diskpart";

    3. Type "list disk";

    4. Look for the entry of your USB drive and remember it's number (checking disk sizes usually helps in spotting it);

    5. Type "select disk x", where x is the disk entry you checked in step 4;

    6. Type "clean";

    7. Type "create partition primary";

    8. Type "format fs=FAT32 quick";

    9. Type "active";

    10. You're done, type "exit" twice. (once to exit diskpart, again to exit command prompt);

     

    then used bootcamp to create usb with win 7 x64

     

    then i downloaded support drivers to main folder of usb

     

    then i reboot with alt, but i dont see usb icon, i just see mac hd and recovery partitions

  • JNov92 Level 1 Level 1 (0 points)

    Hi Jognt,

     

    Tried making the partition active using terminal but it says fdisk illegal option. Any suggestions?

  • Mr Backlin Level 1 Level 1 (0 points)

    Sorry for not clarifying.  It did not show up on boot.  It still said no boot device and when rebooting and holding option, only EFI was there also.

Previous 1 2 3 4 5 6 Next