Previous 1 11 12 13 14 15 Next 211 Replies Latest reply: Jan 31, 2015 7:00 AM by peterpaulfromvenlo Go to original post Branched to a new discussion.
  • AKSMDIHS Level 1 Level 1 (0 points)

    I wasn't having many issues with 3.7.1, but now that I have updated to 3.7.2, I am having all sorts of problems. The main one is that since updating, ARD now uses up to 89% of my CPU. (OSX 10.9.2  - 8 GB DDR3)

     

    And I am barely doing anything.

     

    I was on the phone with Apple and it was suggested I toss the Library/Container file, which I did, knowing that I would have to start all over re-building my lists etc.

     

    It worked well, without the huge load, but everytime I quit ARD, it lost everything. So each time I opened it, I would have to put in a password and begin all over again.

     

    So I went to the file I had 'trashed' and just exported the plist back. Everything is fine, except it is once again using obnoxious amounts of the CPU and therfore slowing everythingh down considerably.

     

    Any ideas?  Thanks

  • Mohonnk Level 1 Level 1 (0 points)

    Not experiencing the CPU % overload you are experiencing over here. I'm also on OS 10.9.2. 3.7.2 has been a big improvement over the last upgrade, where I had to trash the Library/Container file often.

    Hopefully someone can help.

  • bmiller-tam Level 1 Level 1 (0 points)

    With 3.7.2, I'm still seeing some clients' status reported as "Access Denied." I can control those clients individually, but can't copy files or run terminal commands while their status is "Access Denied." I'd hoped this would be fixed with the update.

     

    I tweaked the script posted here earlier to accommodate the new version number, and it seems to work as expected.

  • borgeano Level 2 Level 2 (280 points)

    Same thing happens to me... usually solves itself after quitting and restarting the program, but I wish it just worked... *sigh*

  • macspeckelist Level 1 Level 1 (0 points)

    I posted this to another discussion a couple of weeks ago but this thread seems to be getting more activity so I thought I'd post it here as well.

     

    March 18

    For weeks I've been trying to work through the bugs that 3.7 and 3.7.1 introduced, 3.7.2 cleared up a little but now I've got another.

     

    CPU runs a minimum of 80 percent as high as 120. configd jumps to at least 60percent so I can barely type a number in the ARD filter box, scroll, or click on another list. Quit ARD and configd goes back to normal.

     

    Network traffic seems higher as well - but hoping that it's updating the plist. It should have 652 computers in All Computers but dropped to 579. Quit app, relaunch, ok back to 652. ???.

     

    Reboot is no help. I've already spent way too much time tweaking the plist and other troubleshooting suggestions. Maybe I've become too dependent on ARD!!! These troubles are pushing me to look at other solutions. A clean install on another laptop may be the next step.

     

    March 21

    more info - I was running 10.8.5 and previously had tried total removal and clean installation of ARD but must have missed something.

     

    After upgrading to 10.9.2 I removed this folder: "/Library/Containers/com.apple.RemoteDesktop".

     

    Lost all computers, lists, groups, templates, and saved tasks. Kind of a shotgun approach, and I'll have to rebuild from scratch, but now adding computers back in and CPU is running at 10 percent! Fortunately all Copy and Install template items and packages are saved in in specific folders, and Send UNIX templates are saved in my personal Knowledgebase so I should be back in business soon. I just hope it holds up!

     

    March25

    Lost my notes but while clearing out for a clean install but I found a half-dozen or so "receipts" files. I think they were named something like "com.apple.RemoteDesktop.receipts.plist" or maybe "com.apple.RemoteDesktop.bom". Sorry but they were not in the usual place. Reinstalled starting with 3.3 and immediately checked for updates. Software Update came back with 3.7.2 which I installed.

     

    Adding machines back in went slick. Back up to 478 which may be more accurate than my previous numbers since we've decommissioned quite a few.

     

    Still getting hung up on "Authentication" status occassionally but nowhere near as often as before. Quit ARD, wait a few seconds, then relaunch seems to help. Except for a quick install this morning when I really could have used it!

     

    CPU is much lower - even during a network scan it's under 50 percent, under 10 while inactive.

     

    Getting more hopeful but also realizing that I might rely on it too much and need to keep my eyes open for alternatives!

  • j.tec Level 1 Level 1 (0 points)

    Only way i got ARD back to normal was trashing everything relating to it, re-installing from 3.3, updating to 3.5 and then finally 3.6.1. No issues, it works perfectly but then again i didn't update my main laptop to Mavericks which seems to be half of the problem people are experiencing here. I believe there were links posted in this thread for the 3.6.1 update but here it is again http://support.apple.com/kb/dl1570

     

    I think the moment you go to 3.7 everything is screwed and the 3.7.2 update has done little to rectify this.

     

    Alternatives? There aren't any as solid as ARD (or was for some as the case is now) but here i'll stay on 10.8.5 with a relatively stable Mac Mail & ARD admin - i'm so gutted Apple made a complete car crash out of so many vital elements of the Mavericks OS and if i wasn't rolling out 30 new machines i would be sure to image them with 10.8.5 builds instead because of this.

  • irob_swe Level 1 Level 1 (5 points)

    Sometimes ”Access denied” occur but everything seems normal and you can send unix commands. The normally fix is to restart the ARD agent (client) and the script below might be useful. If ARD is pesky you might have to make a normal ssh connection and send the one-liner.

     

    I suggest you first try to access the computer with ssh. If you aint got ssh access you won't be able to send unix commands, so try to enable it with the GUI (ARD). When you have ssh access try to restart the ARD agent too and if you don't use the command below make sure you set all priv's.

     

    Here is the script I submit to fully enable ARD for every user and restart agent.

    There is also a hook if you want to set computers identifiers - I usually set computer model and serial number.

     

    #!/bin/bash
    
    # DESCRIPTION:
    # Script to set the computer info in the ARD agent
    # Full info: more /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart
    # Also this tech note: http://support.apple.com/kb/HT2370
    
     # REQUIREMENTS:
    # Must be run as root
    
     # To kickstart a pesky ARD agent:
    /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -privs -all -allowAccessFor -allUsers -restart -agent -verbose
    
    # Note: A variable="" leave what's already set in agent so use variable=" " to *clear* a field
    I1="" # Second identifier: Edit12, GFX, Box5, Live3, Admin
    I2="" # Floor/House: Floor 4, House A1
    I3="`echo $(system_profiler SPHardwareDataType | grep "Model Identifier" | awk -F': ' '{print $2}')`"
    I4="`echo $(system_profiler SPHardwareDataType | grep "Serial Number" | awk -F': ' '{print $2}')`"
    
    # I3="`echo $(sysctl hw.model | awk '{ print $2}')`"
    
    # To set computer info fields remove the hash tag:
    # /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -configure -computerinfo -set1 -1 "$I1" -set2 -2 "$I2" -set3 -3 "$I3" -set4 -4 "$I4"
    
    # EOF
    

     

    (Modify the command if you need custom privilegies, but that might be the reason you can't manage things over ARD)

  • bmiller-tam Level 1 Level 1 (0 points)

    Thanks, irob_swe!  This looks like a handy little script. I've used kickstart to restart the agent when the clients' status is incorrectly reported as "offline," but I'll give it a shot and see if it fixes the "Access Denied" issue. Appreciate the help!

  • irob_swe Level 1 Level 1 (5 points)

    First try: ssh username@ip_adress to see if that's why you don't manage to send unix commands.

    If that works -> kickstart while being at it

    If not, fire up ARD and enable ssh in system preferences and try again.

  • bmiller-tam Level 1 Level 1 (0 points)

    Will do. I think I'll hide an kickstart script on the client hard disk and use SSH to launch it when needed. Much obliged for the tips!

  • irob_swe Level 1 Level 1 (5 points)

    There is no need to hide such script as the kickstart binary is already there. The command you have to run is a one liner so just save it in ARD on your computer so you know where it is. Then copy/paste to any ssh session if you can't use ARD.

  • bmiller-tam Level 1 Level 1 (0 points)

    Thanks, irob_swe. I was actually referring to your script that grabs the serial number and model ID and restarts the agent. That's probably a run-once item, but I figure it might come in handy if ARD can't be revived with the standard one-liner.

  • irob_swe Level 1 Level 1 (5 points)

    If you use floor/building/class room etc you might want to run it if the computer is moved but otherwise it's just when you migrate to other harware with ASR. It's live feed just like current application/current user but still handy to know what you deal with or sort by.

  • tilly777 Level 1 Level 1 (0 points)

    Does anyone have a suggestion concerning the "Share Screen" feature?

     

    This was operational, for the most part, before this whole ordeal started last fall. I use to able to share my screen with 32 clients. Since this famous update started, that option has been non-functional. With 3.7.2, I can now only share with one client at a time.

     

    On another note, doing updates via the unix command takes a LOT longer. Don't know if there is an answer for that.

  • Pmac74 Level 1 Level 1 (0 points)

    I'm having a very similar problem. 30 Clients all running 10.9.2... some appear in bonjour but not all. Even with the few that do appear, ARD will not allow me to access them. They won't even respond! What is happening?