8 Replies Latest reply: Nov 13, 2013 10:38 AM by Jiiia
Jiiia Level 1 Level 1 (0 points)



I have a Mid-2012 MacbookAir with all the latest software updates. There are only three firmware updates that always show up over and over again after I've installed them. I've tried everything but the firmware just won't get updated.



  • Macbook Air SMC Firmware Update 1.9
  • Thunderbolt Firmware Update 1.2
  • Macbook Air Flash Storage Firmware Update 1.1


What I've tried:

  • Reset SMC
  • Fix drive and drive permissions in recovery mode
  • Install updates manually from apple.com in safe-mode
  • Delete contents of /system/library/firmware updates/ folder


Yes the charger has been connected to the computer while updating. I have never used FileVault so it's not on. My computer is working fine, but I'd like to have these updates installed because they fix some serious problems that might eventually break my computer or erase all my data if left unfixed. On top of that I can't install Mavericks until I have Flash Storage Firmware 1.1 update installed.


Does anyone have any ideas what to do next?

MacBook Air, OS X Mountain Lion (10.8.5), Bootcamp Windows 7
  • Linc Davis Level 10 Level 10 (177,895 points)

    Did the updates install successfully?

  • Jiiia Level 1 Level 1 (0 points)

    Yes. After each update I get a notification that the update was installed succesfully. But AppStore still offers the updates and the System Information tells me this:


    SMC: 2.5 f7 (latest is 2.5 f9)

    Apple SSD TS128E: TPVABBF0

    Thunderbolt Bus: 11.2

  • PlotinusVeritas Level 6 Level 6 (14,720 points)

    Yes, seen that glitch more than a few times, eventually it will vanish.


    If you installed it fine, no worries.

  • Jiiia Level 1 Level 1 (0 points)

    So how long should it take for the problem to vanish? I know that at least the Thunderbolt update has been there for months.


    App Store also mentions that after the Flash Storage update my computer should shut down but that doesn't happen. It also says that after restarting there should be a gray indicator bar but it doesn't appear. It also says computer fans should run at full speed but they don't. To me it seems quite evident that the updates are not being installed.


    I also noticed that after the SMC update I don't get a notification that the update was succesful.

  • Linc Davis Level 10 Level 10 (177,895 points)

    Please read this whole message before doing anything.


    Back up all data. Quit the App Store application if it’s running. Test after each of the following steps until the problem is resolved.


    Step 1


    Triple-click anywhere in the line below on this page to select it:



    Right-click or control-click the highlighted line and select

    Services Reveal

    from the contextual menu.* A Finder window should open with a folder selected. Move the contents of the selected folder to the Trash. You may be prompted for your administrator password.

    *If you don't see the contextual menu item, copy the selected text to the Clipboard by pressing the key combination  command-C. In the Finder, select

    Go Go to Folder...

    from the menu bar, paste into the box that opens (command-V). You won't see what you pasted because a line break is included. Press return.

    Step 2

    Do as in Step 1 with this line:



    If there's no change, quit the App Store and restore the file you moved from your backup, overwriting the one that may have been created in its place. Otherwise, recreate your settings in the Software Update preference pane.



    Step 3


    Hold down the option key and select


    Go Library


    from the Finder menu bar. Move the following items from the Library folder to the Trash (some may not exist):


    • Caches/com.apple.SoftwareUpdate
    • Preferences/com.apple.SoftwareUpdate.plist
    • Preferences/ByHost/com.apple.SoftwareUpdate.*.plist
    • Saved Application State/com.apple.SoftwareUpdate.savedState


    Here, "*" stand for a long string of letters, numbers, and dashes.


    Step 4


    If you still have problems, quit the App Store again.


    Select this line and copy it to the Clipboard:

    open $TMPDIR../C


    Launch the Terminal application in any of the following ways:


    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.


    Paste into the Terminal window. Depending on which web browser you use, you may have to press the return key. A folder should open. Inside that folder, there may be a subfolder with the name "com.apple.SoftwareUpdate". If so, delete it. You can then quit Terminal.

  • Jiiia Level 1 Level 1 (0 points)

    Thank you for the tips. Unfortunately they didn't fix the problem. I emptied the Updates folder, removed Preferences/com.apple.SoftwareUpdate.plist and cleaned the tempdir. The rest of the files didn't exist.


    I've found threads that discuss similar problems:


    Some users have managed to fix the problem by installing a new copy of OS X to an external drive and launching the updates from that OS. I guess I'll try that next.

  • Linc Davis Level 10 Level 10 (177,895 points)

    To install the updates, you must be on AC power with all wired peripherals disconnected.

  • Jiiia Level 1 Level 1 (0 points)

    I fixed the problem my reinstalling OS X.


    While I was installing the new OS, I got a notification saying that my Macintosh HD partition was not GUID partitioned, so I had to manually repartition it for the installation to work. That might have been the source of the firmware update problems.


    I might have messed up the partitions earlier while I was installing Windows and deleted the Recovery 10.8 partition.