Previous 1 2 Next 25 Replies Latest reply: Mar 4, 2014 1:25 PM by BillMcD54321
otacon72 Level 1 Level 1

The issues encountered are vast... msvcr80.dll issues.. Apple Mobile Device failed to start... and on and on... Never understand how a simple update can completely screw up everything and make iTunes unusable.


Go into Programs and Features and ANYTHING that says "Apple" with something after it, uninstall it.


Download a fresh copy on iTunes

Right click on iTunes64Setup.exe left click on Run as Administrator. Even if you're only use on your computer and it's an Administrator account do it.

Cross your fingers, throw some salt over your shoulder, say a prayer. If the install completes with no error measages you're done.



If you still get the msvcr80.dll error


Google How to use scannow Windows 'Whatever Version you're running'


This will check the integrity of your system files.


If everything checks out you need to replace the missing dll file


Use Google again for Missing msvcr80.dll



I had to put the dll back in Windows/System32/ for iTunes to install properly.

Windows 7
  • otacon72 Level 1 Level 1

    The programs to uninstall are:



    Apple Application Support

    Apple Mobile Device Support

    Apple Software Update

  • cjla Level 1 Level 1

    Thank you so much. Your solution helped me.

  • AJC in CO Level 1 Level 1

    You saved the day (actually night!)  I tried uninstalling and reinstalling the iTunes updates a couple of times without success. Then uninstalled the four programs you indicated, and reinstalled the updated iTunes.  Worked perfectly.

    Thank you for the helpful advice.

  • K-gpah Level 1 Level 1

    Success!  Thank you.

  • owen02 Level 1 Level 1

    i did all that, i still cant open it a message says "the file itunes library.itl cannot be read because it was created by a newer version of itunes"

  • The heck Level 1 Level 1

    Thats probably because you dint  unistalled all the programs in the right order.

    Use the Control Panel to uninstall iTunes and related software components in the following order and then restart your computer:

    1. iTunes
    2. Apple Software Update
    3. Apple Mobile Device Support
    4. Bonjour
    5. Apple Application Support (iTunes 9 or later)

    Important: Uninstalling these components in a different order, or only uninstalling some of these components may have unintended affects.

  • megentry1 Level 1 Level 1

    I am running the 32-bit version of Windows 7.


    I too, encountered these problems when attempting to update.


    I began the update from within iTunes.  It got past the download phase, but during the installation phase, for the first time ever, I encoundeted an installation failure.  It told me to try again, but if it failed, to download the standalone file and install it manually.  Unfortunately, though, the (failed) installation still managed to have gotten far enough along so as to leave my machine in a state that I could no longer launch iTunes.


    When I tried to launch, I received the missing MSVCR80.dll--just like others have reported.  I tried to install this "missing" file by downloading the Microsoft Visual C++ Redistributable (I forget which one, as there are several flavors, but "SP1" and "MFC" were part of the descriptive name from the Microsoft Download Center).  DO NOT, under any circumstances, TRY TO OBTAIN THIS MISSING FILE FROM ONE OF THOSE WEB SITES OFFERING THIS (or other) FILE(s).  Most if not all of these sites, are likely malicious in nature.


    At-any-rate, while I ran the installation of the vcredist_x86.exe  file, I briefly saw some form of positive progress, I never seemed to get a definitive completion (i.e., nothing told me the install completed successfully).  Nor did I see any error message.  I also tried a .NET Framework 4.0 repair as this suggestion was also offered elsewhere on the Apple iTunes Forum.  Unfortunately, neither of those suggestions solved my problems, as I still continued to receive the missing MSVCR80.dll message, and iTunes would not launch.


    I then followed the directions found elsewhere in this thread by uninstalling the Apple applications (in the order listed), rebooted (and for good measure) I also ran ccleaner after the system came back up), and tried the install again using the iTunesSetup.exe file (RunAs Administrator option).


    During this attempt, now I received a DIFFERENT error message:  Specifically, the Apple Mobile Device service could not be started.  Attempting to start it manually from the Services panel, wouldn't work, either.  I told the install to "Ignore" this error, and even the installation made it to the end and stated the installation was successful, it definitely was not.


    The Apple Mobile Device error encountered during installation mentioned ensuring there were sufficient permissions.  As the installation was performed using the RunAs option, this should have used Administrator permissions.  Still no dice, however.  So I completely uninstalled everything again (in the order specified).  Rebooted.  This time, I also manually removed directories left behind in C:\Program Files\Common Files\Apple directory.


    I kept any plugins that existed, but dumped all of the *.resources files I could find.  They all had today's date on the file directories, so I knew they'd been "touched" by the various installation efforts--and who knew whether something left behind might be causing issues.  I blew these away since it got left behind by the uninstall operation (a major annoyance these applications don't do a better job of cleaning up after themselves when "removed").


    Did the same sort of thing in C:\Program Files\iTunes.  I also Re-ran ccleaner (again), and rebooted one more time, as there was still some reference in Registry to APSDAEMON.exe, which, now, no longer existed, but was still trying to be started via the entry in HKLM\Software\Microsoft\Windows\CurrentVersion\Run.  Found the entry and simply deleted it, which kept me from getting that paticular error at restart.


    Last, but not least, I downloaded the FORMER version of iTunes from Filehippo, since they keep all of the previous versions.  Apple might do that, too, but I didn't know for sure, nor did I know where to find it, whereas, I knew exactly where to get this from Filehippo....


    Right, wrong or indifferent--that's what I did.  I know some might not recommend obtaining a file from a source other than the company creating the application--especially since this seems to fly in the face of my own recommendation about sites that offer missing files.  While similar, it's not quite the same, and I've had good success with Filehippo.  A risk I was willing to accept....


    I ran the installation file for, and voila:  iTunes (the former version not the ill-fated new one) was reinstalled (no error messages during installation); best of all, no missing MSCVR80.dll file upon application launch.


    While others seem to have gotten success by removing the apps and reinstalling, I, on the other hand, did not.


    Therefore, I will now sit tight at my current version level until Apple better addresses this issue, which, is definitely tied to the new update, as the former version works just fine.


    I share this, just in case others, like myself, followed the directions and still had the problem.  At least, by visiting Filehippo, one can garner the previous version, and in so doing, re-establish a working version of the application.  If Apple provides former versions for download, then, by all means, obtain the file from them.  My method was more expedient at the time.


    Shared for whatever it is worth.


    Good luck to folks who experience this issue....  Hope you either get the matter solved, or you, at least, get back to a version that worked before your parade got rained on....

  • oldram Level 1 Level 1

    I'm running Windows 7 Ultimate x64 SP1 and have also experienced the upgrade experiences listed by others here while trying to get to  I had tried multiple updates with failures that specifically stated the 'Apple Mobile Device' service could not be started.  I "Ignored" this during a few of my installation attempts but iTunes still reported is was not installed correctly if I then tried to start iTunes.  I removed iTunes, reinstalled, more errors of the same type.  I used Revo Uninstaller Pro and Reg Organizer and removed iTunes, registry keys, and misc files associated with it and rebooted multiple times during all the testing and reinstallations and cleanups and nothing worked.

      I then found the recommendation above to uninstall all the applications listed in the order stated.  Using Revo Uninstaller and removing extraneous keys and files again, I performed the removal in the order listed.  I reinstalled the new version and was able to get iTunes started and logged back into the Apple store again.  I have not yet tried to hookup my iPhone to it, but I am at least hopeful that some of the stuff is working again.  Way too many hours on a 'simple' update.

      Thanks to the posters that have provided the feed back and for the list of items that finally did seem to do the trick.  I'm just sure glad this was not on my main use system this time and I'll wait for that system update until at least 1 more updated version.

      Great Info ...

  • Maryanne Curtin Level 1 Level 1

    Thanks.... your instructions were extremely helpful.


    I usually don't download the newest update .... I don't know why I decided to do it this time. grrrrr.... how many times do I have to get burned before I realize "stove is HOT!!!"


    what a mess.

  • Nycgal07 Level 1 Level 1

    I too, having followed all the directions for order of removal. Restarted too, then tried to reinstall iTunes only to have a message from iCloud control panel state that I need windows vista or newer to run iTunes!!! WTH!!! Now I need to find the previous version as well.

  • Maryanne Curtin Level 1 Level 1

    I also removed iCloud, Mobile Me and Quick Time.... in addition to the 5 mentioned previously. The publisher was Apple, so UNISTALL.


    I did all that last night. and then shut off my computer because I knew if I reinstalled iTunes and it didn't work I would be too mad to sleep.

  • Samueltorres83 Level 1 Level 1

    otacon72 You are awesome!  I uninstalled all the Apple programs you listed, rebooted, downloaded a fresh iTunes, and selectd Run as Adminstrator. After the install it worked perfectly. Thank you!


    Uninstalled these in this order


    Apple Software Update

    Apple Mobile Device Support

    Apple Application Support


  • GFGebhardt Level 1 Level 1

    Thank you! This worked! Fasted resolution from an Apple Discusison board, ever!

  • Mistypepper Level 1 Level 1

    I have done this in the correct order following Apple Support several times and it still comes up with "iTunes library.itl could not be opened because it was created by a newer version of iTunes".

    I've spent a week trying to sort this now AAAArrrrrgggg!

Previous 1 2 Next