Previous 1 2 Next 20 Replies Latest reply: Sep 7, 2014 3:58 PM by TheBRADLeyB
TheBRADLeyB Level 1 Level 1 (0 points)

I'm running a 32GB iPhone 5C on 7.1.2 on Verizon.

 

before the last update I had gone over on my data allotment and then went into the cellular data settings and turned off the cellular data for almost every app I could. Some of these included the music app, podcast app, angry birds, google drive and documents, and just any app that I don't need sucking off my cellular data allotment.

 

well the 7.1.2 software update changed the settings (I don't know why Apple changes these things when there's no reason to, it's getting frustrating having to learn how to use my phone after each update) and you can no longer go into cellular data and flip the switch for all the apps on one single page. So now I have apps like the Podcasts and Google Apps that I open, am alerted the cellular data is turned off for them but when I click settings (the other option is just a confirmation of the message receipt) it takes me to a section in the settings that is no longer listing all my apps with the cellular data switch.

 

so my problem is that I've turned off cellular data, updated

software that for no reason neutered my ability to turn it on/off for individual apps, with no way to turn the cellular data back on for those apps. I can't imagine why Apple would do this, unless app developers were complaining to Apple that people were

turning cellular data off to avoid advertisements.

 

I have reset network settings, scoured the settings menu for options, tried most things suggested for other problems and still nothing. And I'm not going to reset my phone because as soon as I load my backup I'll be in the same boat. Oh I've also tried uninstalling and redownloading the apps as well.

 

and on a side note whoever put the . Button next to the space bar during certain keypad operations is an a hole because most of the searches I do look like this:

"What is the distance.to.the.moon"


iPhone 5
  • ChrisJ4203 Level 8 Level 8 (38,055 points)

    Not sure if you have checked, but the area to turn on/off cellular data for individual apps is in Settings>Cellular. The list should be at the bottom of the page. If it is not showing there, then is Cellular data turned on there?

  • TheBRADLeyB Level 1 Level 1 (0 points)

    image.jpgimage.jpgimage.jpg

     

    That is what my Settings>Cellular Data looks like. it use to have all the apps listed individually but then after an iOS update they all disappeared. Is everyone else on iOS 7.1.2 able to see all their apps on that screen? I'm not sure why mine would be different, I don't screw with much as far as settings go or anything.

  • ChrisJ4203 Level 8 Level 8 (38,055 points)

    I don't know that all of mine are, but it could very well be that they do not show up there until you attempt to use them with cellular data. Have you tried accessing an app requiring data when on cellular network that is not listed there?

  • TheBRADLeyB Level 1 Level 1 (0 points)

    Well when I open an app that cellular data is turned off for it will alert me with a message and two options "settings" (which takes me to the cellular data page in settings) and "ok" which let's me just continue in the app. Pressing any other buttons won't do anything until I address the message. I just checked the settings page via the pop up message to see if it would add that app and it did not.

  • nb105 Level 1 Level 1 (0 points)

    I have exactly the same problem as you.I only noticed this morning when I wanted to turn on data for one of my apps because I had no wifi signal,two days ago I was able to do this.

  • TheBRADLeyB Level 1 Level 1 (0 points)

    so now I've done everything from resetting settings, resetting network settings, turning wifi off, turning phone in and off, messing with cellular data and background app refresh as well as notifications.


    trying to use an app that has no cellular data while wifi is

    off does not force the app to show up under Settings > Cellular Data.


    it appears as though a lot of people are having this problem and sometimes the above mentioned things work and sometimes they don't. It looks like having Cellular Data turned off for

    certain apps during an iO

    God **** it now I have to write things in the Notes app and copy/paste them here because it's randomly not inputting my text and when I start typing it says "GGo" instead of Go, double typing the first letter. Why the **** doesn't Apple have a mobile app/setup of this?

     

     

    Anyway it looks like if you have Cellular Data turned off for an app and do an iOS update it causes this bug. Sometimes the things above work, sometimes not. This is insanely frustrating.

  • ChrisJ4203 Level 8 Level 8 (38,055 points)

    If you are now experiencing typing issues, then you have a problem with the iOS or your backup. The last two steps of user troubleshooting are restore from backup and restore as new. If you restore from backup and it continues the problem, then restore as new. If it works then, you can try loading the backup. But if that does reload the problem, then you will need to restore the device as new again and delete that backup. After the restore, you can sync back all of your content, just make sure you have synced everything before you restore.

  • Jaydin.c333 Level 2 Level 2 (150 points)

    sorry to jump in but have you reset all the settings

     

    settings>generial>reset>reset all settings?

  • TheBRADLeyB Level 1 Level 1 (0 points)

    IIt's only this website that's giving me an issue typing. All other apps and websites are fine. This site does keep logging me out though. Maybe I'll open it on Safari and suffer through Safari's setup.

  • Jaydin.c333 Level 2 Level 2 (150 points)

    ok

  • TheBRADLeyB Level 1 Level 1 (0 points)

    YEah, all that did was make me re do all my notification settings and remove my backgrounds for the most part. Right now after looking through and trying everything I could find on other threads I give up. I refuse to reset the iPhone and reload a backup because since this has been a problem since the latest iOS update I have no backups of my phone before then and I'm pretty confident if I was to backup my phone and reset it I would accomplish nothing but wasting 4 hours of my life. I guess I just have to hope Apple has a 7.1.3 release soon and it fixes it.

  • ChrisJ4203 Level 8 Level 8 (38,055 points)

    To be honest, I don't know that a new iOS would fix it. I'm not saying that you are not experiencing this problem, but no one that I know is experiencing it. While my sample group is not the largest, we do have a variety of iPhones here in the house, all able to run iOS 7.1.2 and none are experiencing this. How you decide to approach this is your decision. Good luck.

  • TheBRADLeyB Level 1 Level 1 (0 points)

    YYeah it's kind of a unique glitch because it appears you have to have altered the Cellular Data for your apps prior to updating. Or maybe another trigger I'm not catching. I've found a lot of people postong about the 7.1.2 problem but most of them received no responses and a few had the issue fixed by doing various things such as turning the wifi off and attempting to use the apps or some of the other suggestions. I honestly thought that Apple had just removed the cellular data option because all of this seemed to coincide with my attempts to turn cellular data off for the podcasts app which after the update suddenly gained a cellular data option in its settings while I lost the options in Settings>Cellular Data. So I'm just frustrated. Luckily the apps I turned data off for were luxury apps. I do thank you for the help though.

  • ChrisJ4203 Level 8 Level 8 (38,055 points)


    You're welcome.

Previous 1 2 Next