Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iCal not syncing with Exchange calender in OS X 10.10.2

iCal is not syncing with an Exchange-based calendar with the OSX 10.10.2 update on my 2012 Macbook Air.


Any calendar events added since the software update are not replicated to the main Exchange account, nor are new events made in other calendar programs replicated back to iCal. This includes calendar events made on the Apple Calendar app on an iPhone 6/iOS 8.1. iCal shows events made before the software update, just none after. Google Apps-based calendars in iCal are not effected, only Exchange-based ones.


I have deleted and re-authorized the Exchange calendar in the Calendar applications on the Mac and the iPhone, and this problem still exists. My workaround is to abandon iCal and to use BusyCal 2 for OSX, which does sync with the Exchange-based calendar. BusyCal 2 does sync with iPhone Calendar, so the issue is specifically iCal in 10.10.2


1. Is anyone else experiencing this problem?

2. Does anyone have a potential solution?


Thanks in advance,

Wayan

OS X Yosemite (10.10.2)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Hey everyone, thanks to this thread, we now have a solution. Or at least it worked for me.


Clear Calendar Cache:

1. Go to system preferences and open internet accounts. Selected the Exchange account and turn off calendar.

2. Close iCal and any other calendar application you might have running

3. In Finder, go to HD/Users/User Name/Library/Calendars and delete the Calendar Cache files (may need to empty Recycle Bin)

4. Restart iCal, which will rebuild the caches

5. Turn on your Exchange calendar

Posted on

There’s more to the conversation

Read all replies

Feb 23, 2015 12:02 PM in response to MGarito In response to MGarito

Outlook for Mac is just as bad, if not worse (in my opinion). I purchased both BusyCal and BusyContacts. Much, much better experience. And the developer clearly deserves compensation for getting these right (since Apple can't seem to do so). I just wish there was a BusyMail app too!

Feb 23, 2015 12:02 PM

Reply Helpful
Question marked as Solved

Feb 23, 2015 12:48 PM in response to Wayan_V In response to Wayan_V

Hey everyone, thanks to this thread, we now have a solution. Or at least it worked for me.


Clear Calendar Cache:

1. Go to system preferences and open internet accounts. Selected the Exchange account and turn off calendar.

2. Close iCal and any other calendar application you might have running

3. In Finder, go to HD/Users/User Name/Library/Calendars and delete the Calendar Cache files (may need to empty Recycle Bin)

4. Restart iCal, which will rebuild the caches

5. Turn on your Exchange calendar

Feb 23, 2015 12:48 PM

Reply Helpful (17)
User profile for user: Wayan_V

Question: iCal not syncing with Exchange calender in OS X 10.10.2