Announcement: The Apple TV app is here

The new Apple TV app is available on iPhone, iPad, Apple TV 4K, and Apple TV HD. If you have a question or knowledge to share with the community, we want to hear from you.

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Can't login to iMessage and FaceTime

My mac won't let me login.


I had tried:

  • Updating
  • Restart
  • Turn off/on iCloud
  • Reset my Mac.


But it keep standing like this forever:

User uploaded file


Do anyone know what to do??


I run on a MacBook Air 11" from 2015 on OS X El Capitan

MacBook Air, OS X El Capitan (10.11.4), from early 2015

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Good news, seems everything is OK now.

I can login now on my Macbook and send iMessages \0/

Posted on

Question marked as Helpful

Sep 5, 2016 9:37 AM in response to JBrynt In response to JBrynt

I've been in detailed discussions with Apple about this for a few weeks now and finally a solution has been found.


Problem description:


Mac fails to log in to Messages, FaceTime and App Store, with an error such as "an unknown error occurred". All other logins and iCloud functionality is normal - only these three items are affected.


Solution:


There is a known issue in which the Mac may fail to log in to the App Store if there is no "en0" Ethernet port present. I know it sounds weird but it is a fact. It can happen (not sure how) that a computer ends up with no "en0" assigned, which was my case - my WiFi had somehow become assigned to "en3" and no "en0" was present. Once this en0 issue is resolved, the App Store magically works again - and I found that the login issue with Messages and FaceTime was likewise resolved at the same time.


To resolve this issue, delete WiFi plist files in /Library/Preferences/SystemConfiguration. (Note this is at the System level, not at the User level). You can find the how-to with a Google search. Then reboot, whereupon the rebuilt plist file will properly assign en0. After that all these logins should start working again.


To find out what Ethernet port your WiFi is assigned to, go to Apple logo - About This Mac - System Report - Network/WiFi.


Hopes this helps somebody. It worked for me!

There’s more to the conversation

Read all replies

Mar 22, 2016 2:23 PM in response to traffsh0w In response to traffsh0w

  • Generating app-specific password doesn't help;
  • Turning off 2-step verification and trying again doesn't help, as well;
  • Turning on 2-step verification - doesn't help;
  • Signing out from iCloud in System Preferences - doesn't help;
  • Signing on back - doesn't help;
  • Signing on to appleid.apple.com with/w-o 2 step verification - is okay.



User uploaded file

Mar 22, 2016 2:23 PM

Reply Helpful

Mar 22, 2016 2:58 PM in response to Amanda Schubert In response to Amanda Schubert

Hi All,


Another thread suggests that a Contact with Apple Support suggests there may be an issue with these two apps in the OS X 10.11.4 update.


Try the Combo Update Download OS X El Capitan 10.11.4 Combo Update



User uploaded file

9:58 pm Tuesday; March 22, 2016


 iMac 2.5Ghz i5 2011 (El Capitan)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 Couple of iPhones and an iPad

Mar 22, 2016 2:58 PM

Reply Helpful

Mar 22, 2016 5:40 PM in response to bevnetcraven In response to bevnetcraven

Nothing works... I tried two fresh installs before calling Apple and they wanted me to try another - third - fresh install. When I questioned their reasoning they checked and realized there was an issue. I thought this would be fixed within hours. Still no sign of a fix. Really annoying.

Mar 22, 2016 5:40 PM

Reply Helpful
User profile for user: Amanda Schubert

Question: Can't login to iMessage and FaceTime