Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Trying to upgrade OS 10.6.8 to el capitan. App store says 10.6.8 is compatible, but when I start updater, it says it needs 10.11. Not sure how to proceed.

I have an imac running 10.6.8. App store says El Capitan is compatible with that, but when I start the updater, it says OS has to be 10.11. Not sure how to proceed.

iMac, Mac OS X (10.6.8)

Posted on

Reply
Question marked as Apple Recommended
Answer:
Answer:

You need to download the installer from the App Store app. I agree with others in that you're probably downloading El Capitan updaters from the Apple web site instead of downloading El Capitan from the App Store app.


You need to go here:


User uploaded file

Posted on

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Apple Recommended

Apr 16, 2016 1:48 PM in response to emadian In response to emadian

You need to download the installer from the App Store app. I agree with others in that you're probably downloading El Capitan updaters from the Apple web site instead of downloading El Capitan from the App Store app.


You need to go here:


User uploaded file

Apr 16, 2016 1:48 PM

Reply Helpful

Jan 19, 2017 8:23 AM in response to bpv1970 In response to bpv1970

Check that your computer is compatible with Mountain Lion/Mavericks/Yosemite/El Capitan.


To check the model number hold down the option/alt key, go to the Apple menu and select System Information.


iMac (Mid 2007 or newer) model number 7,1 or higher


MacBook (Late 2008 Aluminum, or Early 2009 or newer) model number 5,1 or higher El Capitan requires early 2015


MacBook Pro (Mid/Late 2007 or newer) model number 3,1 or higher

`

MacBook Air (Late 2008 or newer) model number 2,1 or higher


Mac mini (Early 2009 or newer) model number 3,1 or higher


Mac Pro (Early 2008 or newer) model number 3,1 or higher


Xserve (Early 2009) model number 3,1 or higher

Your Mac needs:


OS X v10.6.8 or OS X Lion already installed


2 GB or more of memory (More is better - 4 GB minimum seems to be the consensus)


8 GB or more of available space

Check to make sure your applications are compatible. PowerPC applications are no longer supported after 10.6.


Application Compatibility


Applications Compatibility (2)


El Capitan 10.11 Compatibility information


macOS Sierra 10.12: Compatible Apps


Also check to make sure there is a compatible driver for your printer.


Do a backup before installing, preferable 2 backups on 2 different drives.

Jan 19, 2017 8:23 AM

Reply Helpful
User profile for user: emadian

Question: Trying to upgrade OS 10.6.8 to el capitan. App store says 10.6.8 is compatible, but when I start updater, it says it needs 10.11. Not sure how to proceed.