Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: External HD Drives Improperly Eject with High Sierra

Why are HDs using a Thunderbolt 3 to 2 adapter or bridge improperly disconnecting randomly and more frequently?


Here's my journal of experiences. Perhaps, Apple can use this to identify the issue. Because $50 is a lot to pay for an adapter that does not work anymore.


» With a 2013 iMac running El Capitan my two Seagate external HDs were using thunderbolt connections and were solid.


» I upgraded to the 2017 iMac running High Sierra out of the box (10.13.1). The two Seagate drives were daisy-chained using the Thunderbolt 3 to 2 adapter. The hard drives were working perfectly.


» It was after I updated to a 10.13.2 supplement that the problem started to occur randomly. When the drives were not being accessed for a bit usually. The drives would drop out and the Improper Ejection Error would appear. I was concerned about the hard drives failing (but BOTH at the same time?). They passed every examination test as being in top working order. So, I replaced the cables — another wad out of my pocket to Apple. To no avail.


» 10.13.3 came out. Perhaps this will take care of the matter. Just the opposite. It has become worse. It is more regularly disconnecting the drive and giving the Eject error.


» 10.13.3 supplement update came out and I installed it on February 21 2018. Its now even worse! In some instances – once the external Seagate drive appears on the desktop and within less than 2 minutes, the drive is gone and the Unexpected ejection error appears on the screen.


In every case, I have to disconnect the drives. Power them down. Then plug them in and power up for them to return. I can immediately unmount them and check them in DiskUtility. They are fine. Remount. And down they go.


» One commonality I see in all complaints.

Everyone seems to be connecting to the Thunderbolt 3 port with adapters — such as the Apple Thunderbolt 3 to 2&1 adapter. And all are having the same issue.


» The Seagates are the Flexdrive units with multiple base connectors. I switched the drives to the standard USB 2.0/3.0 base connector. Neither drive failed for the entire day and never ejected. I took another drive I was using via USB 3.0 and connected it to the Tbolt adapter. It dropped out just the same.


Perhaps the issue could be found somewhere just after the 10.13.2 supplement updates?


Perhaps I can downgrade to 10.13.1 or 10.13.2?

null-OTHER, iOS 10.3.3, iMac 3.8GHZ 2017

Posted on

Reply

Feb 26, 2018 11:26 AM in response to design-creative In response to design-creative

I have a Seagate USB3 external drive that since the 10.13.3 update has started doing the same thing you are experiencing with your Thunderbolt drive. This is an indication to me that the problem is independent of the bus being used. The drive used to be very stable, I was using one partition as a scratch disk for Photoshop. Over this weekend I ran the system update to 10.13.3. Today I had to remove my external drive from the scratch disk list because it keeps dropping offline. It immediately comes back onto the desktop on it's own but the damage is done, Photoshop crashes when it unexpectedly loses it's scratch disk. I upgraded to 10.13.3 because I was getting random screen black out problems. This update fixed one problem and caused a mush worse one.

Feb 26, 2018 11:26 AM

Reply Helpful

Feb 27, 2018 9:42 AM in response to Jimmarz60 In response to Jimmarz60

Unsure of what Mac you are using. But... someone mentioned this and I have tried the following. With the iMac 27", the Apple Thunderbolt 3 adapter is too heavy and it does not have a tight enough fit. I placed a support under it to keep it from hanging and causing tension on the port connection. Since I have supported the boxy heavy adapter and there is no tension pulling on the connection — for two days now, I have not had a problem with the Improper ejection error! It's crazy. Maybe there is something else at play here? But the fact is, the adapter is not longer just hanging. And I am no longer getting the improper ejection of my hard drives. I have three drives daisy chained together and working fine!


But I am going to keep watch on this though!

Feb 27, 2018 9:42 AM

Reply Helpful (1)

Mar 15, 2018 9:22 PM in response to design-creative In response to design-creative

This is absolutely not a physical problem. My exact same setup with USB2-connected Seagate driver worked perfectly with multiple previous versions. Now with HS, I get multiple disconnections each night while my MBPw/TB is sleeping. The OS developers need to fix this.

Mar 15, 2018 9:22 PM

Reply Helpful

Mar 23, 2018 5:52 PM in response to lingenfr In response to lingenfr

Well as it happens... I looked further into this with Seagate Customer support and they referred me to the product lines and compatibility charts. Turns out the Seagate Goflex Drive with the Thunderbolt 1 connector is not compatible with Thunderbolt 3 and there is no firmware updates.


I removed the Seagate Drive from its plastic casing and plugged it into a Thunderbolt 2 docking station. Works perfectly. No ejections. Not error messages. So, for me, it was the Seagate Thunderbolt Connector that was the issue.


My recommendation is that you look up your hard drive brand and model on the manufacturer web site and see if it is compatible still. Or if a firmware update is necessary.

Mar 23, 2018 5:52 PM

Reply Helpful

Mar 27, 2018 9:09 AM in response to design-creative In response to design-creative

im having problems with my seagate 2 tb hard drive since updating to high sierra 10.13.3. im using a usb 3 dock station and it randomly ejects my drive. im a music producer using ableton live and whenever the hard drive ejects, ableton crashes. all of my virtual instruments, sounds and music project files are on that drive. its very frustrating because i make music for a living and this problem is killing my money

Mar 27, 2018 9:09 AM

Reply Helpful

Mar 27, 2018 9:20 AM in response to tharealcstylez In response to tharealcstylez

Contact the manufacturer of your USB Dock Station to see what they say -- firmware update? Or, not compatible with the 10.13.3 update. Because, like you, everything was working fine... until 10.13.3 updated. Then it all fell apart. I think Apple must have dropped some support code in there which supported certain USB items and older Thunderbolt connections. As I mentioned, I purchased a new upright HDD docking station with Thunderbolt 2 connection. And, USB 3.1 connection. Both types are working fine with no ejection issues.


As soon as I plug up the old Thunderbolt 1 connector to the drive — it ejects within less than a minute.


Hope this helps.

Mar 27, 2018 9:20 AM

Reply Helpful

Mar 27, 2018 4:37 PM in response to tharealcstylez In response to tharealcstylez

Go to the Seagate website and search support for the exact name/model of the drive you are using and see if they have a listing for compatibility with it. Mine was the Seagate GoFlex 2TB drives.


https://www.seagate.com/support/by-product/desktop-external/

Mar 27, 2018 4:37 PM

Reply Helpful

Mar 27, 2018 6:00 PM in response to etresoft In response to etresoft

Yes and that did not work. The Seagate GoFlex Drive with the Thunderbolt (version 1) connector isn’t compatible with 10.13.3.


Once I changed the connector to a Thunderbolt 2 connection, I had no more issues. So I believe it was a hardware issue with the new 10.13.3 update.

Mar 27, 2018 6:00 PM

Reply Helpful
User profile for user: design-creative

Question: External HD Drives Improperly Eject with High Sierra