Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: What exactly needs to be done to keep system preferences from defaulting back to on?

I have this constant irk with system preferences re-enabling themselves in the background. There are three that keep turning back on regardless of how many times I disable them.

  • The Gatekeeper setting to prevent using apps that didn't come from Apple
  • The "Magic Quotes" text setting, which replaces the standard single quote(') and double quote(") with curly versions.
  • The "swipe between pages" behavior of the trackpad

Some context: I am a programmer, and these behaviors routinely destroy my workflow. My laptop is not a tablet or a phone and I do not want it to behave like one. The gatekeeper setting prevents me from running my own programs that I wrote. The magic quotes setting routinely destroys my apache and nginx config files. The swipe between pages setting routinely causes page loads for stuff I am working on that runs for a huge amount of time to reload before finishing. I have disabled these god knows how many times, and have also written custom info.plist files to permanently disable the behavior, but they still turn back on every time a system update runs. It simply ignores my settings and the system config I have written and turns them back on anyways. This occurs pretty much every time I update the OS, and causes about 3-6 hours of fixing broken things and tinkering under the hood to see what it broke and turn it back off every single time an update runs.


The purpose of the info.plist files is to override behavior exactly like this, and those do not prevent it from re-enabling either. The update simply ignores them and/or bypasses them. I did manage to get Gatekeeper to stay off instead of resetting every three weeks or months or whatever the default is, but it does still re-enable whenever an update takes place, leading to having to do this stupid little dance to get the system to recognize it again and reboot multiple times just to get it back to what it was already set up to do. Similar issues occur with the other two settings.


There needs to be some way to designate in whatever fashion, either technical or through the OS, that settings I have intentionally set DO NOT CHANGE FOR ANY REASON.


Thanks in advance.


PS: Please give a good slap in the teeth to whoever thought that making a plaintext editor auto-format text was a good idea. We have Pages for that stuff. Plaintext editing means, well, plaintext. As in TYPE EXACTLY WHAT I WROTE AND DON'T MAKE ASSUMPTIONS ABOUT IT. If I have a typo, that's on me. DO NOT AUTOCORRECT IT IN A PLAINTEXT EDITOR. Do not change my verbage, spelling, character syntax or any other thing in a plaintext file. Currently, I have to turn this behavior off in three different places just to get it to stop doing that, and all of those routinely reset to back on with no particular rhyme or reason for doing so.

MacBook Pro, OS X Mountain Lion (10.8.2), Upgraded OS from 10.6.8 yesterday

Posted on

Reply

Mar 2, 2018 1:30 PM in response to mopsyd In response to mopsyd

mopsyd wrote:


Please give a good slap in the teeth to whoever thought that making a plaintext editor auto-format text was a good idea.


For Apple to see your comments about that, you need to go to


http://www.apple.com/feedback


Although I cannot imagine they would ever remove the rich text features of TextEdit, if that is what you are referring to.


Do you really use TextEdit for writing code? I had the impression that these days programmers use much more professional tools like BBEdit and Sublime Text.


I've never had a problem with things changing like you describe. Have you tried the various routine fixes like a safe boot? What version of MacOS are you actually running? If it's mountain lion, you should post in that forum instead of the one for Yosemite. Is there some reason you can't update further? A lot more help would probably be available for the current release.

Mar 2, 2018 1:30 PM

Reply Helpful

Mar 2, 2018 3:30 PM in response to Tom Gewecke In response to Tom Gewecke

I don't use it for writing code, I said for editing configs. I use an IDE and/or vim for writing code. I do occasionally have to edit an .htaccess or .sql file quickly, and don't always want to open the command line to do that or wait for the overhead of a bulky code editor to make a quick tweak. There are also cases like /etc/hosts that can only be edited as an administrator, and trying to get third party editors to do that appropriately is usually a huge pain.


I am running Yosemite. They detected my OS incorrectly and would not let me update it. I do not update further because system binaries in OSX beyond Yosemite break a number of things I need to work with, such as legacy java versions for example.


I don't need a patch from Apple, nor do I expect them to issue one. I need any feasible answer that prevents settings from resetting. Point and click or writing custom configurations are both acceptable, as long as it's not something over the top like making a 6GB XCode project just to make a checkbox stay unchecked.

Mar 2, 2018 3:30 PM

Reply Helpful

Mar 3, 2018 11:54 AM in response to mopsyd In response to mopsyd

Have you tried deleting the System Preferences.plist and then restarting?


Do a backup, preferably 2 backups on 2 separate drives.


Quit System Preferences.


Go to Finder and select your user/home folder. With that Finder window as the front window, either select Finder/View/Show View options or go command - J. When the View options opens, check ’Show Library Folder’. That should make your user library folder visible in your user/home folder. Select Library. Then go to Preferences/com.apple.systempreferences.plist. Move the .plist to your desktop.


Restart the computer, open the application, and test. If it works okay, delete the plist from the desktop.


If the application is the same, return the .plist to where you got it from, overwriting the newer one.


Thanks to leonie for some information contained in this.

Mar 3, 2018 11:54 AM

Reply Helpful

Mar 3, 2018 12:51 PM in response to mopsyd In response to mopsyd

, I said for editing configs. I use an IDE and/or vim for writing code. I do occasionally have to edit an .htaccess or .sql file quickly, and don't always want to open the command line to do that or wait for the overhead of a bulky code editor to make a quick tweak.


I'm confused. You haven't said which text editor your using. I'm assuming Apple's TextEdit. But it seems that you are using the wrong tool for the job then you are complaining about it not working. TextEdit isn't for editing ascii text files. Think of it as an office text editor. If you find bbedit to slow to load, find a more minimalistic ascii text editor.


https://lifehacker.com/5817833/the-best-programming-text-editor-for-mac


google:

lightweidht macos text editor

Mar 3, 2018 12:51 PM

Reply Helpful
User profile for user: mopsyd

Question: What exactly needs to be done to keep system preferences from defaulting back to on?