Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Applications delete themselves or quit after opening

Almost all of the apps I have downloaded from the internet quit soon after opening, or even delete themselves. Even terminal quits after opening! It is not a disk problem, as first aid turns up nothing. Could I create a partition to possibly solve it? I solved one app by using iTerm2 to open the UNIX executable file, but it does not work for the other apps. I could use safe mode or recovery mode, but unless I use the hash given, I can't. I have run out of possible solutions that work with my limited access. The only cause I can think of is that it might be an unauthorized auto-update of the OS, as that usually causes problems like characters being replaced by question marks.

MacBook Air, macOS Sierra (10.12.6), No SUDO or admin, firmware locked

Posted on

Reply

Mar 2, 2018 3:54 PM in response to StopItGetSomeHelp In response to StopItGetSomeHelp

One reason an app will quit after opening or not opening at all is if it's incompatible. I've never seen an app delete itself other than macOS updates and upgrades which they are designed to do.


What apps do you mean?

Mar 2, 2018 3:54 PM

Reply Helpful

Mar 2, 2018 7:50 PM in response to StopItGetSomeHelp In response to StopItGetSomeHelp

Try setting up another admin user account to see if the same problem continues. If Back-to-My Mac is selected in System Preferences, the Guest account will not work. The intent is to see if it is specific to one account or a system wide problem. This account can be deleted later. Please post if this worked or not.


Isolating an issue by using another user account


If the problem is still there, try booting into the Safe Mode using your normal account. Disconnect all peripherals except those needed for the test. Shut down the computer and then power it back up after waiting 10 seconds. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. When you reboot normally, the initial reboot may be slower than normal. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart by using the application un-installer or by using the developer’s uninstall instructions. For each disable/delete, you will need to restart if you don't do them all at once. Please post if this worked or not.



Safe Mode - About El Capitan
also Sierra


Safe Mode Startup – El Capitan. also Sierra


If it works in the Safe Mode, try running this program when booted normally and then copy and paste the output in a reply. The program was created by Etresoft, a frequent contributor. Please use copy and paste as screen shots can be hard to read. Click “Share Report” button in the toolbar, select “Copy to Clipboard” and then paste into a reply. This will show what is running on your computer. No personal information is shown. You can run the report for free at least once, but if you run it several times, at some point it will ask you to pay a license fee.

Etrecheck – System Information

Mar 2, 2018 7:50 PM

Reply Helpful

Mar 3, 2018 9:06 AM in response to StopItGetSomeHelp In response to StopItGetSomeHelp

If firmware password is enabled the Mac user can not run safe mode , NVRAM / PRAM , SMC .

To disable the firmware see the steps in the article How to set a firmware password on your Mac - Apple Support

After disabling you can run safe mode , and if there are questions marks appearing it due to kernel panic see this article If your Mac spontaneously restarts or displays a message that it restarted or shut down because of a problem - Apple Sup…

Also third party apps that are unknown could corrupt Mac OS should not be downloaded .

And if you are concerned about auto updates see this article App Store preferences on Mac - Apple Support

See the screen shot these boxes are always checked by going to system preferences - App Store .

User uploaded file

Mar 3, 2018 9:06 AM

Reply Helpful

Mar 3, 2018 10:54 AM in response to Eric Root In response to Eric Root

EtreCheck version: 4.1 (4A162)

Report generated: 2018-03-03 11:05:47

Download EtreCheck from https://etrecheck.com

Runtime: 4:07

Performance: Good


Problem: Apps are crashing

Description:

Most apps I have downloaded crash upon running, some even delete themselves upon running. Terminal also crashes. One instance has been stopped by running the Unix executable file within the application, but has worked for only one app. Restarting has not fixed it. Disk utility has not fixed it.


Major Issues:

Anything that appears on this list needs immediate attention.


No Time Machine backup - Time Machine backup not found.

Proxies - Network proxies detected. This could be evidence of malware.

Heavy CPU usage - Some processes are using an unusually high amount of CPU.


Minor Issues:

These issues do not need immediate attention but they may indicate future problems.


Heavy RAM usage - This machine is using a large amount of RAM.

Unsigned files - There is unsigned software installed. It appears to be legitimate but should be reviewed.

Insufficient permissions - EtreCheck running under a standard user. Diagnostic information may not be available.

32-bit Apps - This machine has 32-bits apps that may have problems in the future.


Hardware Information:

MacBook Air (11-inch, Early 2015)

MacBook Air Model: MacBookAir7,1

1 1.6 GHz Intel Core i5 (i5-5250U) CPU: 2-core

8 RAM Not upgradeable

BANK 0/DIMM0

4 GB DDR3 1600 ok

BANK 1/DIMM0

4 GB DDR3 1600 ok

Battery: Health = Normal - Cycle count = 221


Video Information:

Intel HD Graphics 6000 - VRAM: 1536 MB

Color LCD 1366 x 768


Drives:

disk0 - APPLE SSD AP0128H 121.33 GB (Solid State - TRIM: Yes)

Internal PCI-Express 5.0 GT/s x4 NVM Express

disk0s1 - EFI [EFI] 315 MB

disk0s2 [Core Storage Container] 120.37 GB

disk1 - Macintosh HD (Journaled HFS+) 120.01 GB

disk0s3 - Recovery HD [Recovery] 650 MB


Mounted Volumes:

disk1 - Macintosh HD 120.01 GB (41.92 GB free)

Journaled HFS+

Mount point: /


disk2s1 - A************y 16 MB (3 MB free)

HFS+

Mount point: /Volumes/A************y


Network:

Interface en3: Thunderbolt Ethernet

Proxy Auto Config

Interface en0: Wi-Fi

802.11 a/b/g/n/ac

One IPv4 address

Proxy Auto Config

Interface en2: Bluetooth PAN

Proxy Auto Config

Interface bridge0: Thunderbolt Bridge

Proxy Auto Config


System Software:

macOS Sierra 10.12.6 (16G1212)

Time since boot: About an hour

System Load: 4.86 (1 min ago) 8.43 (5 min ago) 9.70 (15 min ago)


Security:

SystemStatus
GatekeeperMac App Store and identified developers
System Integrity ProtectionEnabled


Unsigned Files:

Launchd: /Library/LaunchDaemons/com.jamfsoftware.startupItem.plist

Executable: /Library/Application Support/JAMF/ManagementFrameworkScripts/StartupScript.sh

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchAgents/com.oracle.java.Java-Updater.plist

Executable: /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Resources/Java Updater.app/Contents/MacOS/Java Updater -bgcheck

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchDaemons/com.oracle.java.Helper-Tool.plist

Executable: /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Resources/Helper-Tool

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchDaemons/iboss.setPAC.plist

Executable: /usr/local/bin/iboss.setPAC.sh

Details: Restrictive app permissions - possibly adware

Launchd: /Library/LaunchDaemons/iboss.netid.plist

Executable: /usr/local/bin/iboss.netid.sh

Details: Restrictive app permissions - possibly adware

Launchd: /Library/LaunchDaemons/com.jamfsoftware.jamfnation.auto_update_magic.plist

Executable: /bin/sh /Library/Scripts/auto_update_magic.sh


32-bit Applications:

NameVersion
SecurityFixer10.8
unpakg4.5
SNES9X copy1.53
Snes9XX1.53
Snes9x1.53
NWEA Lockdown Browser3.0.0.2
BNES.app0.5.0
SNES9X copy 21.53
Pearson LockDown1.0.7
Microsoft Excel15.21.1
VideoPad Video Editor5.10
Stykz1.0.1
SNES9X1.53
Adobe Flash Player Install Manager28.0.0.137
ivygenerator
Ivy generator
quicklookd325.0
DVD Player5.8
OE-CAKE!1.1.2b
unpkg4.5
Microsoft Word15.21.1
Xaos3.5
Microsoft PowerPoint15.21.1
InkServer10.9


System Launch Agents:

[Not Loaded] 7 Apple tasks
[Loaded] 202 Apple tasks
[Running] 76 Apple tasks


System Launch Daemons:

[Not Loaded] 40 Apple tasks
[Loaded] 188 Apple tasks
[Running] 89 Apple tasks
[Other] 2 Apple tasks


Launch Agents:

[Running] com.jamfsoftware.jamf.agent.plist (JAMF Software - installed 2018-02-28)
[Loaded] com.oracle.java.Java-Updater.plist (? d46737c7 - installed 2017-09-05)
[Other] com.adobe.ARMDCHelper.cc24aef4a1b90ed56a725c38014c95072f92651fb65e1bf9c8e43c37a2 3d420d.plist (Adobe Systems, Inc. - installed 2018-02-14)


Launch Daemons:

[Loaded] com.adobe.ARMDC.SMJobBlessHelper.plist (Adobe Systems, Inc. - installed 2018-02-14)
[Not Loaded] com.jamfsoftware.startupItem.plist (? 44b5eabd - installed 2018-02-28)
[Running] iboss.netid.plist (? 318a6cea - installed 2016-09-09)
[Loaded] com.adobe.fpsaud.plist (Adobe Systems, Inc. - installed 2017-12-14)
[Loaded] com.oracle.java.Helper-Tool.plist (? e3fefdd2 - installed 2017-09-05)
[Loaded] iboss.setPAC.plist (? 3137a9ae - installed 2016-09-09)
[Loaded] com.adobe.ARMDC.Communicator.plist (Adobe Systems, Inc. - installed 2018-02-14)
[Running] com.jamfsoftware.jamf.daemon.plist (JAMF Software - installed 2018-02-28)
[Loaded] com.jamfsoftware.jamfnation.auto_update_magic.plist (? 5dafcdd2 - installed 2017-04-28)
[Loaded] com.jamfsoftware.task.1.plist (JAMF Software - installed 2018-02-28)
[Loaded] com.microsoft.office.licensingV2.helper.plist (Microsoft Corporation - installed 2016-04-11)


User Launch Agents:

[Loaded] com.google.keystone.agent.plist (Google, Inc. - installed 2017-09-27)


User Login Items:

iTunesHelper Application (Apple, Inc. - installed 2018-02-21)

(/Applications/iTunes.app/Contents/MacOS/iTunesHelper.app)


Internet Plug-ins:

FlashPlayer-10.6: 28.0.0.137 (installed 2018-02-05)

QuickTime Plugin: 7.7.3 (installed 2018-02-21)

AdobePDFViewerNPAPI: 17.012.20098 (installed 2018-02-25)

AdobePDFViewer: 18.011.20038 (installed 2018-02-25)

Flash Player: 28.0.0.137 (installed 2018-02-05)

npTGEQPlugin: 7.5.3 (installed 2014-06-29)

PepperFlashPlayer: 25.0.0.148 (installed 2017-06-23)

DirectorShockwave: 12.2.4r194 (installed 2016-02-22)

JavaAppletPlugin: Java 8 Update 151 build 12 (installed 2017-11-29)


User Internet Plug-ins:

SecureBrowser: Unknown (installed 2017-12-28)

Unity Web Player: UnityPlayer version 2.5.5f1 (installed 2017-11-21)


3rd Party Preference Panes:

Flash Player (installed 2017-12-14)

Java (installed 2017-11-29)


Time Machine:

Time Machine Not Configured!


Top Processes by CPU:

Process (count)Source% of CPU
Google Chrome Helper (69)Google, Inc.135
Digital Color MeterApple35
WindowServerApple34
DashboardClient (3)Apple21
Google ChromeGoogle, Inc.18


Top Processes by Memory:

Process (count)SourceRAM usage
Google Chrome Helper (69)Google, Inc.3.88 GB
kernel_taskApple681 MB
mdworker (12)Apple154 MB
Google ChromeGoogle, Inc.133 MB
DashboardClient (3)Apple124 MB


Top Processes by Network Use:

ProcessSourceInputOutput
mDNSResponderApple71 KB45 KB
apsdApple9 KB8 KB
ntpdApple3 KB3 KB
netbiosdApple810 B558 B


Top Processes by Energy Use:

Process (count)SourceEnergy usage (0-100)
Google Chrome Helper (69)Google, Inc.52
WindowServerApple16
Google ChromeGoogle, Inc.10
DashboardClient (3)Apple8
jamfJAMF Software6


Virtual Memory Information:

Available RAM1.28 GB
Free RAM17 MB
Used RAM6.72 GB
Cached files1.26 GB
Swap Used1.21 GB


Diagnostics Information (past 7 days):

2018-03-03 09:28:32 Trash Crash

Detected over-release of a CFTypeRef

2018-03-03 08:53:49 cloudd Crash

Terminating app due to uncaught exception NSGenericException reason: Failed to step 6922: select apsEnvironment isApplication isCKSystemService canMasquerade canSetEnvironment allowCustomAccounts canAccessProtectionData canSetDeviceIdentifier hasAccessDuringBuddy hasLightweightPCS hasTCCAuthorization allowsPowerNapScheduling isOOPUI allowsParticipantPII displaysSystemAcceptPrompt appIdentifier clientPrefix from AppBundle where appBundleIdentifier AND sourceAppBundleIdentifier - errcode:1b0a msg:disk IO error size: null path:UsersUSERLibraryCachesCloudKitMetadata fs:nullnullabort calledterminating with uncaught exception of type NSException

2018-03-03 08:41:43 Safari.app Crash

Configuration error: No SDK cache entry for extension

2018-03-03 08:41:41 iBooks.app Crash

Configuration error: No SDK cache entry for extension

2018-03-02 16:40:50 quicklookd.app Crash

quicklookd seems struck trying to quit crashingabort called

2018-03-02 16:11:18 Applications Crash

Configuration error: No SDK cache entry for extension

2018-03-02 16:11:18 GarageBand.app Crash

Configuration error: No SDK cache entry for extension

2018-03-02 16:11:18 iOSFilesExtension Crash

Configuration error: No SDK cache entry for extension

2018-03-02 16:09:18 Photos.app Crash

Configuration error: No SDK cache entry for extension

2018-03-02 16:09:18 OtherUsersExtension Crash

Configuration error: No SDK cache entry for extension


Directory /Library/Logs/DiagnosticReports is not accessible.

Run as an administrator account to see more information.


End of report

Mar 3, 2018 10:54 AM

Reply Helpful

Mar 3, 2018 10:09 PM in response to StopItGetSomeHelp In response to StopItGetSomeHelp

StopItGetSomeHelp wrote:


I can't use another account because I don't have admin access

This could explain most of your problems. Who if anyone has Admin access. If no one then you need to create an admin account.


See John Galt's instructions… Re: Lost Administrator Access

Mar 3, 2018 10:09 PM

Reply Helpful

Mar 5, 2018 6:34 AM in response to Eric Root In response to Eric Root

Sorry I was unable to reply, I was without internet yesterday. I force quit the one google chrome helper that was using so much memory, and it was one of my extensions that I never use. Was I supposed to quit chrome as well? What Do I do next?

Mar 5, 2018 6:34 AM

Reply Helpful

Mar 5, 2018 7:38 AM in response to StopItGetSomeHelp In response to StopItGetSomeHelp

Quit all available Chrome items.

The reason for the apps quitting is because there is not enough power for them to run, see that in the last part of the etrecheck list. Take Chrome out of the login items if it is there, even better: take all items out of the Login Items!

Then restart the mac and do-not-start-Chrome. Use Safari OR Firefox.

There may be some 32-bit software that is not Sierra compatible: check that on roaringapps.com

Mar 5, 2018 7:38 AM

Reply Helpful

Mar 5, 2018 8:42 AM in response to Lexiepex In response to Lexiepex

I did all of those things, apps still quit. Most of the 32-bit apps that I had were not on roaringapps.com

My computer has a LOT more available RAM and memory, though. I'll try changing something in the app's files to see if it works.

Mar 5, 2018 8:42 AM

Reply Helpful
User profile for user: StopItGetSomeHelp

Question: Applications delete themselves or quit after opening