Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iMac powers down randomly (27” 2017)

My iMac continues to power down randomly, or my display goes dead/black. I must unplug the AC power cord, and wait several seconds or more before plugging back in - only then will it power back on. When I run the Hardware test, it always passes - code APC0000.

I brought it to my local (in Mexico) Authorized Mac Store before Christmas 2017. They kept it 3 weeks and eventually they replaced both the power supply and the main/logic board. Yet, the power down problem continues. (I bought my iMac in May 2017, but it's essentially got many new innards as of late Dec 2017). I brought it a second time to the local Mac Store, they reinstalled the OS (an older one than what I brought in, 10.13.0, I updated it to the latest when I got it home, 10.13.3). They had it a second 3 weeks and said it stayed on for 4 days - which I don’t belive. It still it powers down and has powered down every day, many times since I have had it back (one week).

Below I have pasted both an EtreCheck report and a Terminal "log show" listing for earlier crashing.

I reinstall the newest OS X (High Sierra). Since the problem existed with my older OS (one before High Sierra) and continues to happen with High Sierra and on this new supply & main board, this means to me that it is NOT A SOFTWARE (OS) PROBLEM. It is certainly a hardware problem. (Correct?) I think the new power supply installed in late December 2017 is either (1) fine and it is something else (2 supplies can’t easily exhibit the same problem); (2) defective (powers down randomly just like the older supply? Which seems unlikely), or (3) the new supply is not physically installed correctly (just like the old supply?). Maybe there is a failing, misplaced or missing heat sensor, AC or ground fault protection cable?

I am not certain if the ”hold down D” hardware test checks for bad heat sensors - my computer does not display an “extended HW test” option. I have tried both a local (D during power up) and an Internet (Option-D during power up) hardware test. Both show zero faults.

I have tried and tried many many times to reproduce the problem, but it is always random. Never consistent. It has powered off during rebooting (while the Apple logo & scroll bar still appears). It has powered down while Mail, or iTunes, or Disk Utility or Finder are in focus (or on top/active). It has even powered down when the screen is asleep (such as if I put it to Sleep and leave it over night - it is powered off in the morning). It has powered down in Safe Mode. It has powered down while it is cold (just turned on after being shut down and unplugged for AC power all night) and warm (after being in use for 10 minutes, or an hour…), so I am sure it is not a heat problem. I can never feel any warmth on the rear. Maybe a bad heat sensor that was not found when the new supply was installed?

When the power turns off, there is no warning. No message appears, No screen flicker, the screen goes black very quickly. The ONLY way to power the iMac ON again, is to unplug the AC power cord. The rear power switch does nothing until the AC power cord is unplugged, then eventually replugged. After I replug the AC power back in, the screen turns back on and the iMac powers back on. I never need to push the rear power switch. (I think this is because I have the Setting to "reboot after a power failure" turned on. This is the expected behavior.) However, once the problem happens, it is strange that the rear switch does not work. This perhaps suggests a power supply protection mode has been turned on?

I have the iMac 120 VAC power cable plugged directly into a professional SurgeX AC power device. This prevents the AC power voltage from exceeding 120 VAC. This product has auto over-voltage protection/turn off and the SurgeX has never tripped or shut down. I know this SurgeX product shuts down with overvoltages, because I tested it with an AC Variac This makes me VERY confident that the iMac power supply has not “seen” an AC over-voltage condition. However, perhaps the iMac is acting like it is experiencing an over-voltage condition? Perhaps the over voltage choke if failing? I think the iMac power supply has an input “clamp” circuit that protects the power supply in various ways? Perhaps this part of the iMac power supply is not working properly. But on two different power supplies? Maybe the supply was installed with a simple error, maybe the new supply is failing also?

I read online that a failing Terabyte hard drive may show a similar symptom. perhaps mt 3 TB drive is to blame?

ETRECHECK [I swap between two different Time Machines, one that has a complete backup, another that recently ran out of room, thus the "backup disk too small red flag - that I'm not worried about since I have a second newer complete Time Machine backup]:

EtreCheck version: 3.4.6 (460)

Report generated 2018-02-06 21:01:46

Download EtreCheck from https://etrecheck.com

Runtime: 1:37

Performance: Excellent

Click the [Lookup] links for more information from Apple Support Communities.

Click the [Details] links for more information about that line.

Problem: Other problem

Description:

iMac powers down randomly (or display goes black/dead?). I must unplug the power cord before it will restart.

Hardware Information:

iMac (Retina 5K, 27-inch, 2017)

[Technical Specifications] - [User Guide] - [Warranty & Service]

iMac - model: iMac18,3

1 4.2 GHz Intel Core i7 (i7-7700K) CPU: 4-core

16 GB RAM Upgradeable - [Instructions]

BANK 0/DIMM0

8 GB DDR4 2400 MHz ok

BANK 0/DIMM1

Empty

BANK 1/DIMM0

8 GB DDR4 2400 MHz ok

BANK 1/DIMM1

Empty

Handoff/Airdrop2: supported

Wireless: en1: 802.11 a/b/g/n/ac

iCloud Quota: 140.32 GB available

Video Information:

Radeon Pro 580 - VRAM: 8 GB

iMac 5120 x 2880

Disk Information:

APPLE HDD ST3000DM001 disk0: (3 TB) (Rotational)

[Show SMART report]

EFI (disk0s1 - MS-DOS FAT32) <not mounted> [EFI]: 210 MB

(disk0s2) <not mounted> [CoreStorage Container]: 3.00 TB

(disk0s3) <not mounted> [Recovery]: 650 MB

APPLE SSD SM0128L disk1: (121.33 GB) (Solid State - TRIM: Yes)

(disk1s1) <not mounted> [EFI]: 315 MB

(disk1s2) <not mounted> [CoreStorage Container]: 120.88 GB

(disk1s3) <not mounted> [Boot]: 134 MB

USB Information:

USB30Bus

Broadcom Corp. Bluetooth USB Host Controller

Apple Inc. FaceTime HD Camera (Built-in)

Logitech Trackball

USB31Bus

Thunderbolt Information:

Apple Inc. thunderbolt_bus

Virtual disks:

Macintosh HD (disk2 - Journaled HFS+) / [Startup]: 3.11 TB (1.53 TB free)

Physical disk: disk1s2 120.88 GB Online

Physical disk: disk0s2 3.00 TB Online

System Software:

macOS High Sierra 10.13.3 (17D47) - Time since boot: less than an hour

Gatekeeper:

Mac App Store and identified developers

Kernel Extensions:

/Library/Extensions

[loaded] com.AmbrosiaSW.AudioSupport (4.1.4 - SDK 10.11) [Lookup]

/System/Library/Extensions

[not loaded] com.Belcarra.iokit.USBLAN_netpart (2.0.2) [Lookup]

[not loaded] com.Belcarra.iokit.USBLAN_usbpart (2.0.2) [Lookup]

[not loaded] com.RemoteControl.USBLAN.usbpart (2.0.6) [Lookup]

[not loaded] com.palm.ClassicNotSeizeDriver (3.2.1) [Lookup]

[not loaded] com.sounddevices.driver.USBPreAudio (4.0) [Lookup]

/System/Library/Extensions/Belcarra.USBLAN_netpart.kext/Contents/PlugIns

[not loaded] com.belcarra.iokit.netpart.panther (1.6.1) [Lookup]

/System/Library/Extensions/Belcarra.USBLAN_usbpart.kext/Contents/PlugIns

[not loaded] com.belcarra.iokit.usbpart.panther (1.6.1) [Lookup]

/System/Library/Extensions/RemoteControl.USBLAN_usbpart.kext/Contents/PlugIns

[not loaded] com.RemoteControl.USBLAN.panther (1.6.1) [Lookup]

System Launch Agents:

[not loaded] 8 Apple tasks

[loaded] 173 Apple tasks

[running] 109 Apple tasks

System Launch Daemons:

[not loaded] 37 Apple tasks

[loaded] 181 Apple tasks

[running] 112 Apple tasks

Launch Agents:

[loaded] com.google.keystone.agent.plist (Google, Inc. - installed 2017-09-27) [Lookup]

Launch Daemons:

[loaded] com.adobe.fpsaud.plist (Adobe Systems, Inc. - installed 2017-12-14) [Lookup]

[loaded] com.ambrosiasw.ambrosiaaudiosupporthelper.daemon.plist (Ambrosia Software, Inc. - installed 2016-09-03) [Lookup]

[loaded] com.google.keystone.daemon.plist (Google, Inc. - installed 2017-10-14) [Lookup]

[loaded] com.microsoft.autoupdate.helper.plist (Microsoft Corporation - installed 2017-04-28) [Lookup]

[loaded] com.rogueamoeba.instanton-agent.plist (Rogue Amoeba Software, LLC - installed 2017-08-14) [Lookup]

User Launch Agents:

[loaded] com.apple.SafariBookmarksSyncer.plist (? ? ? - installed 2009-03-16)

[loaded] com.dropbox.DropboxMacUpdate.agent.plist (Dropbox, Inc. - installed 2017-08-11) [Lookup]

User Login Items:

iTunesHelper Application (Apple, Inc. - installed 2018-01-24)

(/Applications/iTunes.app/Contents/MacOS/iTunesHelper.app)

Dropbox Application

(/Applications/Dropbox.app)

Audio Hijack 3 Schedule Helper Application

(/Library/Application Support/Audio Hijack/Audio Hijack 3 Schedule Helper.app)

Internet Plug-ins:

FlashPlayer-10.6: 28.0.0.137 (installed 2018-01-10) [Lookup]

QuickTime Plugin: 7.7.3 (installed 2018-01-19)

Flash Player: 28.0.0.137 (installed 2018-01-10) Outdated! Update

iPhotoPhotocast: 7.0 (installed 2013-04-28)

JavaAppletPlugin: 15.0.1 (installed 2013-12-07) Check version

SharePointBrowserPlugin: 14.7.2 (installed 2017-03-14) [Lookup]

User internet Plug-ins:

CitrixOnlineWebDeploymentPlugin: 1.0.105 (installed 2013-04-25) [Lookup]

WebEx64: 1.0 (installed 2016-04-07) [Lookup]

WebEx: 1.0 (installed 2010-07-08) [Lookup]

3rd Party Preference Panes:

Application Enhancer (installed 2010-12-23) [Lookup]

Flash Player (installed 2017-12-14) [Lookup]

HP Scanners (installed 2010-12-23) [Lookup]

Time Machine:

Skip System Files: NO

Mobile backups: OFF

Auto backup: NO - Auto backup turned off

Volumes being backed up:

Macintosh HD: Disk size: 3.11 TB Disk used: 1.59 TB

Destinations:

Data [Network]

Total size: 3.00 TB

Total number of backups: 7

Oldest backup: 7/8/17, 6:29 AM

Last backup: 2/2/18, 9:51 PM

Size of backup disk: Too small

Backup size 3.00 TB < (Disk used 1.59 TB X 3)

Counting Out Time Capsule 2 [Network]

Total size: 3.00 TB

Total number of backups: 0

Oldest backup: -

Last backup: -

Size of backup disk: Too small

Backup size 3.00 TB < (Disk used 1.59 TB X 3)

Top Processes by CPU:

23% cloudphotosd

11% cloudd

4% com.apple.WebKit.WebContent

3% kernel_task

1% mds

Top Processes by Memory:

1.31 GB kernel_task

252 MB com.apple.WebKit.WebContent

238 MB Finder

208 MB sharedfilelistd

154 MB Dropbox

Top Processes by Network Use:

Input Output Process name

923 KB 264 KB com.apple.WebKit.Networking

131 KB 226 KB Dropbox

239 KB 18 KB mDNSResponder

74 KB 128 KB nsurlsessiond

91 KB 33 KB apsd

Top Processes by Energy Use:

5.82 cloudd

4.78 com.apple.WebKit.WebContent

2.32 cloudphotosd

1.98 mds

Virtual Memory Information:

10.43 GB Available RAM

7.87 GB Free RAM

5.57 GB Used RAM

2.55 GB Cached files

0 B Swap Used

Software installs (last 30 days):

Adobe Flash Player: (installed 2018-01-10)

Install information may not be complete.

Diagnostics Events (last 3 days for minor events):

2018-02-06 20:37:55 Last shutdown cause: 0 - Power loss

Last login: Tue Feb 6 20:38:11 on console

Steve-iMac-2:~ steve$ log show --style syslog --last 48h | egrep shutdown\ cause | awk -F')' '{print substr($0,1,19), $NF}'

2018-02-05 09:04:19 Previous shutdown cause: 5

2018-02-06 14:16:55 Previous shutdown cause: 0

2018-02-06 16:27:39 Previous shutdown cause: 0

2018-02-06 18:21:36 Previous shutdown cause: 0

2018-02-06 19:00:43 Previous shutdown cause: 0

2018-02-06 20:07:59 Previous shutdown cause: 0

2018-02-06 20:09:54 Previous shutdown cause: 0

2018-02-06 20:12:55 Previous shutdown cause: 0

2018-02-06 20:14:48 Previous shutdown cause: 0

2018-02-06 20:23:42 Previous shutdown cause: 5

2018-02-06 20:31:59 Previous shutdown cause: 0

2018-02-06 20:35:40 Previous shutdown cause: 0

2018-02-06 20:37:55 Previous shutdown cause: 0

2018-02-06 21:27:32 Previous shutdown cause: 0

2018-02-06 21:34:02 Previous shutdown cause: 0

2018-02-06 21:37:28 Previous shutdown cause: 0

2018-02-06 21:46:54 Previous shutdown cause: 0

2018-02-06 21:51:53 Previous shutdown cause: 0

Steve-iMac-2:~ steve$

iMac (Retina 5K, 27-inch, 2017), macOS High Sierra (10.13.3)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

It sounds like the disk was made improperly. The Apple Support Topic is the correct way to accomplish it.

Posted on

Question marked as Helpful

Mar 11, 2018 9:57 AM in response to SteveSWall In response to SteveSWall

The best way to test would be to install High Sierra on an external disk, with only the default apps and boot from that. If it runs as expected then it's probably a software issue with some app you installed. If not, it's probably hardware.

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Helpful

Mar 11, 2018 9:57 AM in response to SteveSWall In response to SteveSWall

The best way to test would be to install High Sierra on an external disk, with only the default apps and boot from that. If it runs as expected then it's probably a software issue with some app you installed. If not, it's probably hardware.

Mar 11, 2018 9:57 AM

Reply Helpful (1)

Mar 10, 2018 9:05 AM in response to macjack In response to macjack

Ok. Thanks! I’m downloading High Sierra now (but my iMac shut down within a few minutes, of course). I’ll update you once I've got it successfully on a USB drive and have run the OS from USB for a while. It may take a while...


Steve

Mar 10, 2018 9:05 AM

Reply Helpful

Mar 11, 2018 9:32 AM in response to SteveSWall In response to SteveSWall

My iMac would not stay powered on long enough for me to make a bootable USB drive. A friend made me a High Sierra USB install drive. When I boot with the Option key held, it lists “Install High Sierra” for the USB drive. While I can certainly re-install High Sierra on my iMac (I have a couple times before to attempt to fix this power down problem), I’m not certain the USB High Sierra drive was made properly for me to RUN High Sierra from USB?


Is there a difference between an “install” and one that is “bootable?”


To create the USB drive, my friend said he used this:

https://macdaddy.io/install-disk-creator/

Whereas, to create the USB drive, I was working on this:

How to create a bootable installer for macOS - Apple Support

Mar 11, 2018 9:32 AM

Reply Helpful

Mar 11, 2018 12:58 PM in response to SteveSWall In response to SteveSWall

I successfully created a USB drive with the Apple Support link I included above (”create a bootable installer”). I ran the Terminal command and it created the expected “Install macOS High Sierra.app” file on the USB drive. But I am still confused.


Since my iMac will not remain powered up long enough for me to quickly select the USB drive as the Startup Disk in System Preferences then restart, I have tried instead to hold down Option while starting up my iMac. According to the Apple Support link instructions, this is not the proper way to boot from a USB bootable drive. In other words, is it true that the only way to boot from my new USB drive is to first select it as my Startup disc? (The holding Option approach does not allow booting from the USB drive, only installing. So is the above Apple Support link not creating a bootable USB as it advertises, only an install one?)


(FYI aside: When I do try holding Option on restart, the screen that comes up lets me select either my iMac‘s internal hard drive, or the “Install macOS High Sierra.” When I select this USB “Install,” it does not boot from it, it gives me the expected install options (Restore from Time Machine, Install macOS anew, Get help on the Internt or Disk Utility.). Still, my iMac has powered off once while the Apple logo and startup scroll bar is working on loading from the USB drive. But it is remaining powered now that I’ve tried the Option key restart again.)

Mar 11, 2018 12:58 PM

Reply Helpful

Mar 11, 2018 1:42 PM in response to SteveSWall In response to SteveSWall

Yes, I'm afraid we both read that wrong. That support topic seems to be for making an install disk.

Try the steps here:

Create a bootable USB drive - iFixit

I usually just download an installer and then choose my external disk as the install location.

Mar 11, 2018 1:42 PM

Reply Helpful

Mar 11, 2018 1:56 PM in response to macjack In response to macjack

Your iFixit link’s procedure is exactly the same as the Apple Support one. They both use the same Terminal command.


I’ll ping a friend who may know how to make a bootable USB drive. And here I thought Google Search knew everything. 😎


Maybe it would be easier for me to borrow a friend’s MacBook and go buy a Thunderbolt cable and boot in Target mode?


Thank you for the continued help!

Mar 11, 2018 1:56 PM

Reply Helpful

Mar 11, 2018 4:07 PM in response to SteveSWall In response to SteveSWall

A little further FYI thing. I was able to keep my iMac powered on long enough to find out that the USB install drive does not appear as a choice in the Startup Disk list in System Preferences. Not a surprise. I’ll post more once I have another workable approach to either boot from another USB drive or from another Mac with Target mode.

Mar 11, 2018 4:07 PM

Reply Helpful

Mar 12, 2018 12:04 PM in response to SteveSWall In response to SteveSWall

I still cannot ”boot” from my two different external drives. I have both a USB thumb drive, and a Western Digital 500GB. They each have the “Install macOS High Sierra.app” on them. Yet, no matter what I do, they only allow me to:

1) Restore from a Time Machine Backup

2) Install High Sierra (anew)

3) Get Internet Help

or

4) Run Disk Utility.


Despite many searches for how, as macjack says above, to “boot from that (external drive)” I cannot boot. Only Install, or re-install. I have tried holding Option down while rebooting, it shows me both, yet I can only “Install.” Neither of my external druves appears under my iMac’s Startup Disks under System Preferences. I must be doing something wrong I’ve booted from external sources for years; (Steve Jobs must still be dead).


Now what? Perhaps borrow someone’s Mac and a Thunderbolt cable a try Target mode?

Mar 12, 2018 12:04 PM

Reply Helpful

Mar 12, 2018 1:00 PM in response to SteveSWall In response to SteveSWall

Is your Mac Restarting into Recovery Mode when this happens? Because it shouldn't be in Recovery Mode to use the installer. The installer on your external disk should work. Exactly what happens when you connect your external and choose to install Mac OS when you launch the installer?

Mar 12, 2018 1:00 PM

Reply Helpful

Mar 12, 2018 1:38 PM in response to macjack In response to macjack

My iMac is not going into Recovery mode. The Recovery disk does not appear when I hold down the Option key on reboot. If I hold nothing down, it boots into the internal Fusion drive’s High Sierra, but the power goes off within tens of seconds. (I like your theory that it’s some old, perhaps non-64-bit application I just need to nuke. I’m certain I have a lot of them, most not in use. If I could just slowly look at the Applications list of 32- vs 64-bit applications...)


When I choose either of the external “installers” (thumb drive or WD 500GB), the small arrow icon appears below the selected High Sierra graphic. I click the arrow, then the Apple logo appears with the scroll bar below. Eventually, the 4 choices appear (Restore Time Machine, Install macOS, Internet Help, Disk Util). Thus, I’m “booted” - but in my feable mind I envision ”booting“ giving me a Finder and Applications, etc. So maybe I could install the OS on an external, as opposed to having them just be a install discs. (OK, I’ll get back to reality)


(The 4 choices are in Spanish because once I returned with my iMac from my local Mexican Mac Store, they obviously changed a language setting. I dont speak Spanish, and I have removed Spanish from my Language settings - so I don’t know how to get it back to all English. But I’ll worry about that once it stays powered. 😁)


Since I have already re-installed the OS (as did the Mac Store, twice I think) and the power downs continue, I think I need to get a Thunderbolt cable and a friend’s laptop and try Target mode. Too bad an iPad can’t do target mode? Maybe via Airplay ? (I can fantasize, can’t I?) I’m not sure how to search for the possible offending Application(s).

Mar 12, 2018 1:38 PM

Reply Helpful

Mar 14, 2018 3:38 PM in response to SteveSWall In response to SteveSWall

I used Carbon Copy Cloner to make two different “backups” of a friend’s MacBook High Sierra installation. One copy is on a Western Digital 500GB USB drive with wall wart power supply. The second copy is on a 128GB USB Thumb drive (but boy is the Thumb drive slow). Both of these external drives are formatted to be bootable (GUID Partition Map) and also have a Recovery volume.


When I hold Option down and power up my iMac, 5 choices are shown: my iMac’s internal OS, the WD 500GB OS & its Recovery, plus the Thumb drive’s OS & its Recovery.


No matter which of the five OSes I select, my iMac boots - but after some time, the iMac still powers off randomly. Sometimes it powers off while the Apple logo and bootup-scroll bar are still on-screen, sometimes the desktop appears then it powers off, sometimes I can run applications for an hour then it powers off. It seems to be getting more and more difficult to have it power back on after I unplug the power cord - I have to either wait longer before plugging it back in and it powers up without me hitting the rear power switch (internal OS last loaded); or, and curiously, sometimes, after it powers down and unplugging the cord and plugging back in, it will not power up on its own, I must push the rear power switch to get the iMac to power itself back on. (I think this may be because my iMac’s preferences are set to auto reboot after a power failure, but the 4 external OSes are not set this way.)


No matter, I think this clearly points to a hardware problem, and NOT a bad or corrupt OS, and NOT a bad application (such as a 32-bit application being unhappy forcing a power down in this 64-bit machine).


How might I figure out if it is the power supply or the logic board - or could it be something else? Since both the power supply and logic board are new as of late December, it’s the “something else” which might cause this symptom that I truly wonder most about. I’ll chalk it up to bad luck that I had one “power-down randomly” failure when I first brought it in (December) and now with a new power supply and logic board, I still have the same problem. Jeez.


[After 2 trips, and 6 full weeks in the (PV Mexico) Mac Store (not Apple Store) for “repair” plus a new logic board and power supply (likely one that’s faulty it seems?) - all with no resolution, I am rather compelled to attempt as much troubleshooting as I can, so I can point them in the proper direction. Not surprisingly, I’ve lost my trust in their expertise and am tempted to drive the extra 5 hours to another store (the closest), but haven’t made up my mind yet. Or maybe I need to fly back to the USA?]

Mar 14, 2018 3:38 PM

Reply Helpful

Mar 14, 2018 4:04 PM in response to SteveSWall In response to SteveSWall

Apple will be able to more throughly test your Mac for hardware issues. Apple Hardware Test is a bit limited. While it does test for bad sensors, it's not always reliable. If it reports a problem, you can be pretty sure there is one. But if it reports no problems there may still be one.

Mar 14, 2018 4:04 PM

Reply Helpful
User profile for user: SteveSWall

Question: iMac powers down randomly (27” 2017)