Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: How can I stop my phone from using DST?

My area (Saskatchewan) doesn’t observe daylight savings time. When ever DST starts however, my phone jumps an hour and shows “Winnipeg” in the autoselected time zone. (Normally it shows Regina, and refreshing it will cause it to show Regina again, and restore the proper time)


Worse than that, apps like google calendar consistently seem to read my device time zone as Winnipeg half the year, and so move my appointments around.

Posted on

Reply

Page content loaded

Mar 11, 2018 5:57 AM in response to Cultist O In response to Cultist O

Problem 1 is probably due to your cell provider, report the issue to them. If you want to avoid it altogether go to Settings > General > Date & Time and turn off Set Automatically.


For problem 2 you need to contact Google. Or turn off Set Automatically and see if that fixes it.

Mar 11, 2018 5:57 AM

Reply Helpful

Mar 11, 2018 2:17 PM in response to deggie In response to deggie

My cell provider only provides service to the region affected by this problem, so I trust them more when they tell me Problem 1 is not on their end. Turning off the automatic time zone causes other problems, and I shouldn't have to switch it manually every time I cross a border.


Problem 2 is not only a problem with Google, it is a problem with every other calendar app I have tried. They tell me that they are receiving the Winnipeg time zone from the device, and that there's nothing they can do.


My suspicion is that something is receiving GMT-6, and interpreting that as Winnipeg, so has an issue when Winnipeg changes to GMT-5 but we do not

Mar 11, 2018 2:17 PM

Reply Helpful
User profile for user: Cultist O

Question: How can I stop my phone from using DST?