Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: I can't delete files in target disk mode on a MacBook Air (macOS Sierra ?)

My wife's mac won't start-up past the log in screen (it's a MacBook Air released around 2010, I think using Sierra OS).

I think the issue is that the hard drive is completely full. Here's the process I've followed so far in trying to work out what's going on. If you want to skip the process part, the thing I'm stuck on is being unable to delete files from her mac when accessing the hard drive as a target disk from my mac.

So here's the steps I've taken so far. I started with following this article:

SOLVED: My mac is stuck on the white startup screen! - MacBook Pro 13" - iFixit

1. Reset NVRAM (done)

2. Made sure the start-up disk selection is still the Macintosh HD.

3. Tried starting in Safe Mode (nothing happens when I press or hold down the shift key after turning it on, it just goes straight to the normal log-in screen)

4. Used Disk Utility to diagnose and repair the disk

At this point I found that there weren't any issues with the disk, but did see that the hard drive is completely full.

So then I started following this article...

macbook won't start completely; hard drive full

...and I've connected my mac (MacBook Air 2015 running macOS Sierra 10.12.6) to my wife's and set it up as a target drive in order to attempt to delete files to free up space.

Now I've hit two (related?) problems.


The first is a notification that pops up when the device registers.

macOS can’t repair the disk “Macintosh HD”.

You can still open or copy files on the disk, but you can’t save changes to files on the disk. Back up the disk and reformat it as soon as you can.


The second is that when I attempt to delete a file (e.g. by dragging it into the trash), I receive the notice,


The item 'x' can’t be moved to the Trash because it can’t be deleted.

In light of the first issue, I've started backing up critical files on to my computer.

I'm stuck in addressing the second problem. I can see that in the access permissions it says I can 'only read' the files. When I unlock the access permissions, there is no option of changing my permission status or of adding myself as an additional user. Nor can I change the current set-up privileges. The gear icon brings up no further available options.

User uploaded file


I've seen this article with a similar problem:

I can't delete items in OS X (external startup drive) - TechSpot Forums


I tried disabling the FireVault on my wife's computer through the disk utility menu, and I think it worked, but I don't know how to check if that is the case.


I've looked at the suggested solution in the article, but unfortunately I don't understand what it says.


Can anyone help from here, and am I even on the right track with what the problem is (i.e. a full hard drive)?

MacBook Air

Posted on

Reply

Page content loaded

There are no replies.
User profile for user: JMarkAllen

Question: I can't delete files in target disk mode on a MacBook Air (macOS Sierra ?)