Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Text messages are not showing on lock screen on iPhone X

I have an iPhone X and since getting this phone, and especially when charging overnight, my text messages are not showing up on my lock screen. In fact, most of the time I don't even know I have missed texts until I go into the message app and see I have missed texts. I have updated all my settings to have them show on my lock screen and it still isn't happening. Please advise what I need to do so I don't have any more missed texts.

iPhone X, iOS 11.2.6

Posted on

Reply
Question marked as Apple Recommended
Answer:
Answer:

Simply go to Settings>Notifications>Messages, and make sure “Allow Notifications” is on.

Posted on

Page content loaded

Mar 12, 2018 9:03 AM in response to Shamarafromgretna In response to Shamarafromgretna

Is your phone connected to cellular network and cellular data overnight? SMS requires a cellular voice connection. MMS requires a cellular data connection. iMessage requires either cellular data or Wi-Fi. If the phone is not connected to power than Wi-Fi shuts off 30 seconds after the phone locks to preserve battery life. If you have Voice over Wi-Fi this can make a difference.

Mar 12, 2018 9:03 AM

Reply Helpful
User profile for user: Shamarafromgretna

Question: Text messages are not showing on lock screen on iPhone X