Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Alesis Q25 with macOS High Sierra

Hi! Am seriously considering purchasing an Alesis Q25, and just want to make sure it is fully compatible with my iMac (High Sierra 10.13.2) and my Logic Pro X (10.4.1).


Indications I have found on the web thus far are generally positive. Just fishing here for some additional reassurance before I take the plunge (OK, not a huge investment, but just want to make sure in any case 🙂)


Thanks in advance!


Mr. BlueTunes

Logic Pro X, macOS Sierra (10.12.6), Scarlet 2i2 USB interface

Posted on

Reply

There’s more to the conversation

Read all replies

Page content loaded

User profile for user: Mr.BlueTunes

Question: Alesis Q25 with macOS High Sierra