Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: macOS high sierra system files taking too much space

All of a sudden my mac is reporting that there is only 6GB left on my SSD.

The OS claims that the system files are taking up way more storage than they actually are.

I ran OmniDiskSweeper and it reports that I'm using 121.6GB whereas macOS reports I'm using 236GB.


Does anyone know what I can do as there does not seem to be anything there I can delete?

MacBook Pro, macOS High Sierra (10.13.3), null

Posted on

Reply

Page content loaded

Mar 14, 2018 1:39 PM in response to jarvinho In response to jarvinho

Get Correct Storage Information


Do not use the information from the Storage section of the About This Mac dialog. Ignore the Storage information as it is typically wrong. To find out the correct information for any disk: Select a Desktop disk icon. Press Command-I to open the Get Info window and look at the topmost panel displayed. You will find the disk information displayed for Capacity, Available, and Used. If you have more than one disk/partition then repeat for each one on your Desktop.

Mar 14, 2018 1:39 PM

Reply Helpful

Mar 14, 2018 2:19 PM in response to jarvinho In response to jarvinho

Then that is correct. You only have 6GBs of free space. It isn't the operating system which uses around 32GBs. The rest is used by files put in your Home folder.


How to Free Up Space on The Hard Drive


  1. You can remove data from your Home folder except for the /Home/Library/ folder.
  2. Visit The XLab FAQs and read the FAQ on freeing up space on your hard drive.
  3. Also, see Freeing space on your Mac OS X startup disk.
  4. Free up storage space on your Mac.
  5. See Where did my Disk Space go?.
  6. Be sure to Empty the Trash to recover the space.
  7. Replace the drive with a larger one. Check out OWC for drives, tutorials, and toolkits.
  8. Use OmniDiskSweeper or GrandPerspective to search your drive for large files and where they are located.

Mar 14, 2018 2:19 PM

Reply Helpful

Mar 15, 2018 12:12 AM in response to Kappy In response to Kappy

Unfortunately, none of those answers is at all useful in this situation.

There are no files taking up the extra space. As I pointed out in the original post, I ran OmniDIskSweeper which shows I only have 121.6GB of files, not the 236GB claimed by the system.

There appears to be something, which is not a visible file or files, that macOS thinks is taking up almost double the amount of storage it should be.

Mar 15, 2018 12:12 AM

Reply Helpful (1)

Apr 5, 2018 9:01 AM in response to jarvinho In response to jarvinho

I ran into the same situation as most everyone here. After I installed the 10.13.4 update. The install went sort of odd. It actually froze up about a third the way through. I had to restart the iMac. Once I did that it completed the install but it took a good long while to do so. Once it was complete, I noticed I went from 1.92TB of free space to 99GB of free space. DaisyDisk showed it as a hidden items in the Library. I tried using Terminal and checking TimeCapsule date stamps like many suggested was the problem. However that was not it. With more digging into the Library folder with DaisyDisk, I discovered the Application Support folder was huge! Further in, I found it was the Adobe preference.dat file. It was 1.89TB in size! Not sure why that was. AND I discovered I had a huge number of old files from past versions of Adobe Software — I thought the uninstall removed all that junk?


So. I found the file. Deleted it. Immediately recovered all my free space. All my Adobe software works fine. So, who knows what just happened. But for me, it was the Adobe prefs.dat file that was the issue.


Hope this helps.

Apr 5, 2018 9:01 AM

Reply Helpful

Apr 30, 2018 7:17 AM in response to GingerKoko In response to GingerKoko

In my research, this isn't the first time something like this happened with the MacOS. I am not knowledgeable enough to know WHAT causes it to happen. However, with DaisyDisk I was able to find the overloaded files. For me, it happened to be the Adobe preference.dat file — it bloomed up to 1.89TB in size. I did a back up of my drive. Then, I deleted the Adobe file. Everything has been fine since.


Now, I will say after installing the High Sierra upgrade. I noticed somewhere in the process it took a really long time — longer than usual with the progress bar during the first start up. Over an hour! I gulped and then did a hard boot with the power button. It then launched fine. And then I saw the HD space was completely gone.


That's my experience with it. Hope this helps.

Apr 30, 2018 7:17 AM

Reply Helpful
User profile for user: jarvinho

Question: macOS high sierra system files taking too much space