Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.


Question: Pages Autocorrect Too Fast

Pages Autocorrect used to be very helpful, but now it's driving me crazy. It will frequently guess at the word I'm typing and complete it for me while I'm in the middle of the word. As I keep typing, this causes a misspelled word. About half the time this premature autocorrect will complete the word with the wrong word entirely. I wish there was a way to slow this down. I don't want to completely turn it off. I think this change coincided with my upgrade to High Sierra, but I'm not sure.

MacBook Pro (15-inch, Late 2016), macOS High Sierra (10.13.3)

Posted on


Page content loaded

Mar 14, 2018 2:56 PM in response to ndimmick In response to ndimmick

Hi n'

There's no user-accessible control on the rapidity of autocorrect, sometimes known as the spillchucker, except the on-off switch in the Edit menu.

User uploaded file

It is possible, and often more efficient to keep Check Spelling… and Check Grammar… both on (√) and Correct Spelling Automatically off ( ). You'll likely find fewer workflow interruptions fewer corrections to make with these settings.



PS: To make your wishes know to Apple, use the Pages menu in Pages. Choose Provide Pages Feedback, and make a feature enhancement request.


Mar 14, 2018 2:56 PM

Reply Helpful
User profile for user: ndimmick

Question: Pages Autocorrect Too Fast