Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Macmail switching to MD5 challenge-response

Hi. My mac mail keeps switching its authentication from password to MD5 challenge-response. It seems only to be messing up one of my two email addresses, and it keeps changing from not sending to not receiving, all very arbitrary. I change it back to password, and have tried quitting mail, restarting the computer, and the authentication keeps switching back to MD5 challenge-response. Any ideas? Thanks.

IMAC (RETINA 5K, 27-INCH, LATE 2015)

Posted on

Reply
Question marked as Helpful

Mar 15, 2018 8:54 PM in response to goldwolf01 In response to goldwolf01

Turn off the “automatically scribble on my mail server settings seemingly randomly” option in the mail preferences. Okay, I’m paraphrasing that slightly, but there’s really a checkbox in the server settings that does basically that. Automatically manage connection settings in Mail on your Mac - Apple Support Try disabling that, and see if the settings stick.

Question marked as Helpful

Mar 16, 2018 7:44 AM in response to goldwolf01 In response to goldwolf01

A challenge-response MD5 hash of the password is preferable to authentication involving a cleartext password. Preferably all happening over SSL/TLS link and not over an unencrypted cleartext network link. MD5 is a better choice, if the server supports it. I’d find a replacement for any mail server that even offers unencrypted cleartext network connections much less requires those. Seems there’s either a problem with this mail server and its support for MD5 authentication, or maybe there is something else going on here.

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Helpful

Mar 15, 2018 8:54 PM in response to goldwolf01 In response to goldwolf01

Turn off the “automatically scribble on my mail server settings seemingly randomly” option in the mail preferences. Okay, I’m paraphrasing that slightly, but there’s really a checkbox in the server settings that does basically that. Automatically manage connection settings in Mail on your Mac - Apple Support Try disabling that, and see if the settings stick.

Mar 15, 2018 8:54 PM

Reply Helpful (1)

Mar 15, 2018 10:14 PM in response to MrHoffman In response to MrHoffman

Thanks! I actually prefer the paraphrase.

This may have done the trick. Of course, right before I made this change, things started behaving again.

I'll see if it still works tomorrow.


Do you have any idea why MD5 challenge-response would be designated? I've seen some old forum posts that say it's more secure...which I guess it is if you can't send or receive emails.


Thanks again.

Mar 15, 2018 10:14 PM

Reply Helpful
Question marked as Helpful

Mar 16, 2018 7:44 AM in response to goldwolf01 In response to goldwolf01

A challenge-response MD5 hash of the password is preferable to authentication involving a cleartext password. Preferably all happening over SSL/TLS link and not over an unencrypted cleartext network link. MD5 is a better choice, if the server supports it. I’d find a replacement for any mail server that even offers unencrypted cleartext network connections much less requires those. Seems there’s either a problem with this mail server and its support for MD5 authentication, or maybe there is something else going on here.

Mar 16, 2018 7:44 AM

Reply Helpful (1)
User profile for user: goldwolf01

Question: Macmail switching to MD5 challenge-response