Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: block pop up adds on safari not working

iPad Pro

IOS 11.2.6

256 memory

Safari pop up adds are getting worse.

Amazon you are lucky specifically .

I have accidentally selected the X thinking it would go away

I was directed to a site that ask questions .

While I am reading something this pop up hi jacks the page.

I usually just delete the tab and start over.

This morning I selected X

most of the time I select reading mode but some sites don’t have it.



Troubleshooting

Settings/Safari turned off and on block pop up ads/Ask sites not to track/Allow cookies

I also cleared history.


This is a very annoying problem.

We can send a man to the moon but we can’t stop pop ups.


Thanks Steve

iPad Pro Wi-Fi, iOS 11.2.6

Posted on

Reply
Question marked as Solved
Answer:
Answer:

1. Force close Safari application. https://support.apple.com/en-us/HT201330


2 Clear History Caches and Website Data. https://support.apple.com/en-us/HT201265


3. Settings > Safari > Search


Turn off Search Engine Suggestions,

Safari Suggestions,

Quick Website Search

and

Preload Top Hit.


4. Highlight and delete the entry in the Safari’s search bar.


Press spacebar key on the keyboard twice.

Enter the URL for the site manually and then “Go”.

Test for a while.

After a while, re-enable those disabled Safari search options.



https://www.youtube.com/watch?v=NDeb7XGaiWc

Posted on

Page content loaded

Question marked as Solved

Mar 18, 2018 3:11 AM in response to surftail In response to surftail

1. Force close Safari application. https://support.apple.com/en-us/HT201330


2 Clear History Caches and Website Data. https://support.apple.com/en-us/HT201265


3. Settings > Safari > Search


Turn off Search Engine Suggestions,

Safari Suggestions,

Quick Website Search

and

Preload Top Hit.


4. Highlight and delete the entry in the Safari’s search bar.


Press spacebar key on the keyboard twice.

Enter the URL for the site manually and then “Go”.

Test for a while.

After a while, re-enable those disabled Safari search options.



https://www.youtube.com/watch?v=NDeb7XGaiWc

Mar 18, 2018 3:11 AM

Reply Helpful

Mar 18, 2018 7:23 AM in response to surftail In response to surftail

Safari – Popup takes over



Safari – Popup takes over (2)



Popup remover – Scam Zapper



If the pop-up reloads, force quit Safari (command - option/alt - esc) and reopen with the shift key held down. If that doesn't work, disconnect from the Internet, go to Safari/History and delete the website. Quit and reopen with the shift key held down. Then reconnect to the Internet.

Mar 18, 2018 7:23 AM

Reply Helpful

Mar 18, 2018 9:20 AM in response to surftail In response to surftail

I have cleared browsing. Made sure all security settings correct. i have deleted all websites. I have contacted Apple Support. I close out the popup every time, multiple times a day. I only view trusted sites and it keeps happening. It’s happening to many Apple Safari users.

Mar 18, 2018 9:20 AM

Reply Helpful

Mar 18, 2018 9:43 AM in response to surftail In response to surftail

Try double clicking the Home button and swipe Safari upwards. Go to Settings/Safari and clear History and Website Data. Open Safari and test.


Safari - Clear the history and cookies on your iPhone, iPad, or iPod touch



Safari website data on your iPhone or iPad - How to clear




Safari - Stop pop-up ads in

Mar 18, 2018 9:43 AM

Reply Helpful
User profile for user: surftail

Question: block pop up adds on safari not working