Announcement: Announcing the newest addition to Apple Support Communities, Apple Arcade!

If you have a question or knowledge to share with the community, we want to hear from you.

Announcement: Get Ready for macOS Catalina

Experience dedicated apps for music, TV, and podcasts, plus smart new features like Sidecar. Learn how to get ready >

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Webpage using significant energy / memory on Mac

Hello,

I'm continuing to get this alert at the top of Safari.

This webpage is using significant energy. Closing it may improve the responsiveness of your Mac.

How do I get rid of it?

I'm running macOS High Sierra on my MacBook Air. Version 10.13.4


Thank you,

Tim ***

[Re-Titled by Host]

MacBook Air

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Click your Apple menu  top left in your screen.


From the drop down menu click Force Quit then select Safari then click Force Quit.



Then relaunch Safari.

Posted on

Question marked as Helpful

Apr 19, 2018 6:38 PM in response to tekey In response to tekey

I have recently purchased a new iMac 27". It replaces a 2014 Mac mini. I, too, continue to get that "warning", especially on Facebook. I never saw it on my Mini at all which was running the same OS and all else being equal. What would make the new machine do this I've wondered. I even called support and they were not able to assist at all. Now I see I'm actually not the only one with this issue which, at least, makes me feel a bit better....LOL. I've tried everything, resetting, running "First Aid" from Utilities, checking resolution, etc. and it still shows up. Seems to be only with Safari, not with Firefox. Hoping to see some response from someone who has come up with some type of reasonable explanation.

Question marked as Helpful

Apr 18, 2018 3:44 PM in response to tekey In response to tekey

Same here. This began fairly recently. I have no Safari extensions, I have no apps that didn't come from the App Store. i have no keepers or cleaners and my etrecheck showed that my mac performance was excellent. I usually get this message when I'm on CNN or CBS and there is a video accompanying the news story. I've never had this before. I've been thinking I was hacked but obviously others here are experiencing this too.

There’s more to the conversation

Read all replies

Apr 10, 2018 2:30 PM in response to tekey In response to tekey

If the above doesn't work, Safari/Preferences/Advanced - enable the Develop menu, then go there and Empty Caches. Quit/reopen Safari and test. Then try Safari/History/Show History and delete all history items. Quit/reopen Safari and test. You can also try try Safari/Clear History…. The down side is it clears all cookies. Doing this may cause some sites to no longer recognize your computer as one that has visited the web site. Go to Finder and select your user/home folder. With that Finder window as the front window, either select Finder/View/Show View options or go command - J. When the View options opens, check ’Show Library Folder’. That should make your user library folder visible in your user/home folder. Select Library/Caches/com.apple.Safari/Cache.db and move it to the trash.


Go to Safari Preferences/Extensions and turn all extensions off. Test. If okay, turn the extensions on one by one until you figure out what extension is causing the problem.


Safari Corruption See post by Linc Davis


If that doesn't work, try running this program in your normal user account , then copy and paste the output in a reply. The program was created by etresoft, a frequent contributor. Please use copy and paste as screen shots can be hard to read. On the screen with Options, please open Options and check the bottom 2 boxes before running. Click “Share Report” button in the toolbar, select “Copy Report” and then paste into a reply. This will show what is running on your computer. No personal information is shown.

Etrecheck – System Information

Apr 10, 2018 2:30 PM

Reply Helpful

Apr 10, 2018 3:11 PM in response to Eric Root In response to Eric Root

Thank you for this. I actually did most of this when I first looked for a thread re this error. I didn't find my exact notice since mine didn't say the page was reloaded, but I followed instructions and removed caches folder, caches.db file, Safari folder, history files, all in safe mode and restarted and ran the etrecheck, but continued to get the notice. Quitting Safari, so fare seems to have done the trick. I'll keep an eye out.

Thank you for your help! I truly appreciate it.

Tim

Apr 10, 2018 3:11 PM

Reply Helpful

Apr 11, 2018 12:51 PM in response to tekey In response to tekey

EtreCheck version: 4.1.4 (4A203)

Report generated: 2018-04-10 09:30:37

Download EtreCheck from https://etrecheck.com

Runtime: 4:38

Performance: Good


Problem: Other problem

Description:

Webpage was reloaded because it was using significant memory.


Major Issues:

Anything that appears on this list needs immediate attention.


No Time Machine backup- Time Machine backup not found.


Minor Issues:

These issues do not need immediate attention but they may indicate future problems.


Apps with heavy CPU usage- There have been numerous cases of apps with heavy CPU usage.

Unsigned files- There is unsigned software installed. They appear to be legitimate but should be reviewed.

32-bit Apps- This machine has 32-bits apps that may have problems in the future.


Hardware Information:

MacBook Air (13-inch, Early 2015)

MacBook Air Model: MacBookAir7,2

1 1.6 GHz Intel Core i5 (i5-5250U) CPU: 2-core

4 GB RAMNot upgradeable

BANK 0/DIMM0

2 GB DDR3 1600 ok

BANK 1/DIMM0

2 GB DDR3 1600 ok

Battery: Health = Normal - Cycle count = 150


Video Information:

Intel HD Graphics 6000 - VRAM: 1536 MB

Color LCD 1440 x 900


Drives:

disk0 - APPLE SSD SM0256G 251.00 GB (Solid State - TRIM: Yes)

Internal PCI 5.0 GT/s x4 Serial ATA

disk0s1 - EFI (MS-DOS FAT32) [EFI] 210 MB

disk0s2 250.79 GB

disk1s1 - Macintosh HD (APFS) 250.79 GB 139.91 GB

disk1s2 - Preboot (APFS) [APFS Preboot] 250.79 GB 19 MB

disk1s3 - Recovery (APFS) [Recovery] 250.79 GB 518 MB

disk1s4 - VM (APFS) [APFS VM] 250.79 GB 2.15 GB


Mounted Volumes:

disk1s1 - Macintosh HD 250.79 GB (108.07 GB free)

APFS

Mount point: /


disk1s4 - VM [APFS VM] 250.79 GB (108.07 GB free)

APFS

Mount point: /private/var/vm


Network:

Interface en3: iPhone

Interface en4: iPhone 2

Interface en0: Wi-Fi

802.11 a/b/g/n/ac

One IPv4 address

3 IPv6 addresses

Interface en2: Bluetooth PAN

Interface bridge0: Thunderbolt Bridge

iCloud Quota: 20.64 GB available


System Software:

macOS High Sierra 10.13.4 (17E199)

Time since boot: Less than an hour

System Load: 3.66 (1 min ago) 8.41 (5 min ago) 4.76 (15 min ago)


Security:

SystemStatus
GatekeeperMac App Store and identified developers
System Integrity ProtectionEnabled


Unsigned Files:

Launchd: /Library/LaunchDaemons/com.microsoft.office.licensing.helper.plist

Executable: /Library/PrivilegedHelperTools/com.microsoft.office.licensing.helper

Details: Exact match found in the whitelist - probably OK


32-bit Applications:

41 32-bit apps


Kernel Extensions:

/Applications/zoom.us.app

[Not Loaded] ZoomAudioDevice.kext (1.1 - SDK 10.8)


System Launch Agents:

[Not Loaded]8 Apple tasks
[Loaded]175 Apple tasks
[Running]109 Apple tasks
[Other]One Apple task


System Launch Daemons:

[Not Loaded]37 Apple tasks
[Loaded]187 Apple tasks
[Running]111 Apple tasks


Launch Agents:

[Loaded]com.microsoft.update.agent.plist (Microsoft Corporation - installed 2017-12-19)
[Running]com.epson.pma.launcher.plist (Seiko Epson Corporation - installed 2017-10-19)
[Not Loaded]com.teamviewer.teamviewer_desktop.plist (? d4765397 - installed 2015-06-16)
[Not Loaded]com.teamviewer.teamviewer.plist (? aa311aa9 - installed 2015-06-16)
[Running]com.epson.scannermonitor.plist (Seiko Epson Corporation - installed 2017-06-06)
[Loaded]com.epson.esua.launcher.plist (Seiko Epson Corporation - installed 2017-11-07)
[Running]com.epson.eventmanager.agent.plist (Seiko Epson Corporation - installed 2017-09-27)
[Running]com.epson.Epson_Low_Ink_Reminder.launcher.plist (Seiko Epson Corporation - installed 2018-02-07)


Launch Daemons:

[Loaded]com.microsoft.autoupdate.helper.plist (Microsoft Corporation - installed 2017-12-19)
[Not Loaded]com.teamviewer.teamviewer_service.plist (? b485a599 - installed 2015-06-16)
[Loaded]com.adobe.fpsaud.plist (Adobe Systems, Inc. - installed 2018-02-23)
[Loaded]com.microsoft.office.licensing.helper.plist (? 6d8cb30e - installed 2015-06-04)


User Launch Agents:

[Loaded]com.google.keystone.agent.plist (Google, Inc. - installed 2018-02-03)
[Loaded]com.dropbox.DropboxMacUpdate.agent.plist (Dropbox, Inc. - installed 2017-08-10)
[Loaded]com.macpaw.CleanMyMac3.Scheduler.plist (? 0 - installed 2016-09-22)


User Login Items:

iTunesHelper Application (Apple, Inc. - installed 2018-03-30)

(/Applications/iTunes.app/Contents/MacOS/iTunesHelper.app)

Beats Updater Application

(/Applications/Beats Updater.app)

Dropbox Application (Dropbox, Inc.

(/Applications/Dropbox.app)


Internet Plug-ins:

Silverlight: 5.1.40728.0 (installed 2015-11-27)

FlashPlayer-10.6: 29.0.0.113 (installed 2018-03-13)

QuickTime Plugin: 7.7.3 (installed 2018-03-30)

Flash Player: 29.0.0.113 (installed 2018-03-13)

SharePointBrowserPlugin: 14.7.7 (installed 2017-12-19)


User Internet Plug-ins:

WebEx64: 1.0 (installed 2015-08-11)

CitrixOnlineWebDeploymentPlugin: 1.0.105 (installed 2013-04-25)

ZoomUsPlugIn: 4.0.25926.0306 (installed 2017-03-15)

FreeScreenSharingPlugin: Unknown (installed 2014-06-03)


Safari Extensions:

Evernote Web Clipper.safariextz - Evernote Corp. - http://evernote.com (installed 2016-02-05)
Amazon Assistant for Safari.safariextz - Amazon - https://www.amazon.com/gp/BIT/AmazonAssistant/TOU(installed 2018-01-11)
Streak.safariextz - Rewardly Inc. - https://www.streak.com (installed 2016-06-03)
Honey.safariextz - Honey Science Corporation - https://www.joinhoney.com (installed 2018-03-25)


3rd Party Preference Panes:

Flash Player (installed 2018-02-23)


Time Machine:

Time Machine Not Configured!


Top Processes by CPU:

Process (count)Source% of CPU
WindowServerApple9
mdworker (21)Apple6
Epson Scanner MonitorSeiko Epson Corporation3
kernel_taskApple2
sandboxdApple2


Top Processes by Memory:

Process (count)SourceRAM usage
kernel_taskApple616 MB
mdworker (21)Apple332 MB
SafariApple244 MB
com.apple.WebKit.WebContentApple232 MB
Dropbox (3)Dropbox, Inc.95 MB


Top Processes by Network Use:

ProcessSourceInputOutput
DropboxDropbox, Inc.74 KB209 KB
mDNSResponderApple67 KB20 KB
apsdApple9 KB9 KB
com.apple.Safari.SafeBrowsing.ServiceApple4 KB1 KB


Top Processes by Energy Use:

Process (count)SourceEnergy usage (0-100)
WindowServerApple4
Dropbox (3)Dropbox, Inc.0
Beats Updater0
routinedApple0
launchservicesdApple0


Virtual Memory Information:

Available RAM1.08 GB
Free RAM26 MB
Used RAM2.92 GB
Cached files1.05 GB
Swap Used61 MB


Software Installs (past 30 days):

NameVersionInstall Date
Evernote7.0.32018-03-31
Wunderlist3.4.82018-04-07


Diagnostics Information (past 7 days):

2018-04-09 11:41:05 installd CPU (once)

2018-04-06 12:20:46 com.apple.WebKit.WebContent CPU (11 times)


End of report

Apr 11, 2018 12:51 PM

Reply Helpful

Apr 11, 2018 1:49 PM in response to tekey In response to tekey

Did you try disabling the Safari extensions?


Most posters recommend not using cleaning programs. They can destroy normal computer operations.


CleanMyMac3 Uninstall


Check for associated parts and pieces using these programs.


EasyFind – Spotlight Replacement



Find Any File

Apr 11, 2018 1:49 PM

Reply Helpful (1)

Apr 12, 2018 5:42 PM in response to tekey In response to tekey

Try setting up another admin user account to see if the same problem continues. Also try the Safe Mode.


Isolating an issue by using another user account


Safe Mode - About El Capitan
also Sierra


Safe Mode Startup – El Capitan. also Sierra

Apr 12, 2018 5:42 PM

Reply Helpful

Apr 13, 2018 7:41 AM in response to Eric Root In response to Eric Root

Hi Eric,

I'm unsure what any of these options will do for me. I just want to get rid of the notification. Why is it popping up when I use Safari and how do I get rid to it? I don't understand why I need to set up another admin account, or what using Safe Mode will do.

Thank you,

Tim Key

Apr 13, 2018 7:41 AM

Reply Helpful

Apr 13, 2018 7:51 AM in response to tekey In response to tekey

For trying another admin user account, the intent is to see if it is specific to one account or a system wide problem. This account can be deleted later. If it is a system wide problem, one answer might be to reinstall the OS.


The Safe Mode will reset some caches, forces a directory check, and disables all startup and login items, among other things. If the system operates normally, there may be 3rd party applications which are causing a problem.

Apr 13, 2018 7:51 AM

Reply Helpful
User profile for user: tekey

Question: Webpage using significant energy / memory on Mac