Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Cannot install Boot Camp - Start up disk does not have enough space!?

Hi,


wonder if someone might be able to help me, as i'm trying to install Boot Camp and cannot get any further than the first step!


I have a late 2016 Macbook Pro Retina, 2.9Ghz i7 with a 2Tb flash SSD and 16Gb Memory. I'm also running High Sierra 10.13.4 and have around 800Gb space left on my SSD.


Using the Boot Camp Assistant, i'm looking to install Windows 10, however when I try and progress the Boot Camp Assistant I get the following error:


User uploaded file


I know I have 800Gb+ of space, however I get this message. Looking at the information I can find online (which is to do with High Sierra rather than an older version), I can see that this maybe down to 2 factors:


1. That I use Time Machine for my back up solution and this seems to 'reserve' space.

2. That the drive is formatted using Apples APFS format.


I guess my first question is whether it is indeed one of these points which is stopping the Boot Camp Assistant from doing its job? The second, and most important question is, how do I get round this please?


I booted into the Disk Utilities and tried to create a partition myself, however it talks about 'containers' as well as 'volumes', and as I use this laptop for work, I really don't want to muck up anything.


I hope someone out there can help and steer me the right direction please.

MacBook Pro, iOS 11.3

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Run


sudo tmtuil deletelocalsnapshots 2018-04-20-000831


and repeat for each subsequent entry. After deleting all of them, please retry BC Assistant again.

Posted on

There’s more to the conversation

Read all replies

Page content loaded

Apr 21, 2018 1:44 AM in response to Loner T In response to Loner T

Hi again, thanks again for the info. I've done as you suggested and it seems to have removed most of these, however it would seem that theres 4 snapshots that I can't seem to delete?


User uploaded file



I've also tried the Boot Camp Assistant again, but still get the same error.

Apr 21, 2018 1:44 AM

Reply Helpful

Apr 21, 2018 7:31 AM in response to Loner T In response to Loner T

Hi there, i've finally sort this out thank to your suggestions.


I kept trying to delete these snapshots but they weren't all deleting, so found a terminal entry which automated the deletion:

tmutil listlocalsnapshotdates / |grep 20|while read f; do tmutil deletelocalsnapshots $f; done


After the third or fourth time running this, the snapshots all disappeared. I tried Boot Camp Assistant and it went through and worked!


Thanks Loner T for all your help

Apr 21, 2018 7:31 AM

Reply Helpful
User profile for user: matthewfrombasingstoke

Question: Cannot install Boot Camp - Start up disk does not have enough space!?