Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: External display problem after OS10.13.4 upgrade

At the start of March I bought a new Asus MX27U external display, specifically because I could connect it directly to my MacBook Pro via USB-C and it would charge my Mac at the same time. It worked perfectly.


Then 2 weeks ago I updated to OS10.13.4. The first time I connected to the display after that, the screen stayed black and it displayed ‘No connection USB-C’. The display is sensing a connection, because the light on the underside slowly alternates red and white. The Mac knows it is connected: the display shows in Display Preferences and can be set up to mirror, but still nothing appears on the display.


My Internet research has shown this to be a known issue, the OS update having disabled many external displays. Often this is when people are using an adaptor, and it appears that the update has disabled DisplayPort drivers - DisplayPort says it is working with Apple on a fix. However, I was connecting the Mac directly, not via an adaptor.


So, I tried connected to the display through HDMI, using an adaptor, since my Mac only has USB-C ports. This worked fine, but every 15-30 minutes my Mac would freeze. This seems independent of what app I am in at the time - although it was most commonly when I was using Mail, this is my most frequently used app.


My Internet research showed this to be a recognised issue when connected to external displays too!


I tried all the possible remedies I could find on the web (although all of these were for earlierproblems - no-one online has yet found a solution to the display issues created by the latest upgrade) and none worked. I also reset the SMC.


I contacted Asus support, and received this reply.

The monitor drivers do not come from our side, for TYPE-C ALT DP mode displays

The port should natively support it, so I am unsure what has changed

As we do not have 'drvers' perse for the monitors

We will however forward this, in case we have a work around or are able to do anything

We would also check with Apple - as it seems to be an issue for many vendors

I then had a web chat with an Apple advisor. He screen shared, sent me an app to upload a system report to Apple, and booked me in for an appointment at the Genius Bar. I attended the appointment this week, and they could not diagnose the problem or find a solution. Using my USB-C cable, an Acer display in the store worked fine. They looked at system reports and could see the kernel panics from when my Mac crashed, but were still none the wiser.


So, I am screwed. I bought a fabulous screen for £1,000 that I now can’t use. Apple does not even acknowledge that the latest update has created an issue. And I am caught in a no-man’s land between Asus and Apple with no prospect of a solution.


Please can someone help?

MacBook Pro (13-inch, 2017, 2 TBT3), macOS High Sierra (10.13.4)

Posted on

Reply

Page content loaded

User profile for user: Graham Matthew Booth

Question: External display problem after OS10.13.4 upgrade