Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Trouble setting up Korg Krome as midi controller for Logic Software Instruments

Oh where do I start? I keep going in circles from Logic Pro X to my Focusrite Clarett8Pre, then back to my Krome trying to figure out the proper settings to get the Krome to act as a midi controler to play and record Logic's Software Instruments. If anybody here has a similar setup and can tell me what I am missing I am all ears.


So basically, I have had a Krome workstation for a few months and haven't dabbled in its MIDI capabilities except one time earlier this year, when I was able to successfully record a Logic Pro X software instrument - the vintage keyboard. I don't know how I got it to work, but I haven't been able to repeat that moment and it is driving me crazy reading in forum/manual cycles from my DAW, to my Clarett8Pre, and the Krome.


I am running MIDI in and out of the Focusrite Clarett8Pre, which also has an Octopre connected to it. The Clarett8Pre connects to my Imac by Thunderbolt.


In Logic Pro X I start a project and add a software instrument, and set the MIDI to all channels (or is that all inputs?) under the track parameters. Back to the Korg


On the Krome I go into COMBI mode and select page and turn the first instrument from INT to EX2 (and EXT trying to figure out which one will make it to Logic but it is never picking the signal up on my new software instrument track. So, nothing. I go back to the Krome and look at the MIDI settings and still can't figure out why I can't get the new track I created to play the software instrument in Logic. Various sites recommend adding an audio input to Logic to monitor the sound, but when I do this, I get the internal Krome instrument (Grand Piano) playing into the DAW. In the COMBI menu where the selection to turn off local from INT/EXT/EX2, I see to recall seeing an option to change the input number on the first instrument of the COMBI, and instead of it going to input 01, it says something like Gch something.


I am sorry for this sounding so scatterbrained, but I spent a good three hours trying to figure this out tonight and I just can't seem to find someone with a similar setup that can tell me what I am doing wrong.


I just want to be able to use the KROME to record Logic Pro X's built in software instruments, without having to buy a standalone MIDI controller.


As a side note, would the USB out of the KROME possibly suffice as a solution to connecting to my iMac for recording and achieve what I am wanting to do, or would the USB connection put me into a latency nightmare.


Thanks, I am quite new to Logic Pro, the Krome, AND my Focusrite devices.

Another item that might be a factor is the Clarett Octopre serving as the ADAT clock device. That shouldn't matter but I've trying to weigh in any factors to why this setup is not working for me.


Thanks.

iPhone 7, iOS 11.2.1

Posted on

Reply

Page content loaded

There are no replies.
User profile for user: Alex Crabb

Question: Trouble setting up Korg Krome as midi controller for Logic Software Instruments