Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: MacBook Pro (13-inch Early 2011), macOS Sierra (10.12.6)

Getting error message that iMovie is now "incompatible" after updating macOS High Sierra 10.12.6
Trying to install Updates for 3rd time! What's up with that?

MacBook Pro, updating macOS High Sierra 10.12.6

Posted on

Reply
Question marked as Solved
Answer:
Answer:

I have seen the update at the AppStore just two hours ago. You may want to check the updates tab at the AppStore.

Posted on

Question marked as Helpful

Apr 22, 2018 1:44 PM in response to Gibby503 In response to Gibby503

Getting error message that iMovie is now "incompatible

But what is the exact error message you are seeing - literally?

The most recent version of iMovie 10.1.9 requires macOS 10.13.2 or newer, but if I remember correctly, your version should be able to run on your system version.


What happened, before you saw the error message? Did you downgrade the system from High Sierra to Sierra?

There’s more to the conversation

Read all replies

Page content loaded

Apr 22, 2018 10:11 AM in response to Gibby503 In response to Gibby503

Which version of iMovie do you currently have installed?

Are you seeing this message?

User uploaded file

This is just a warning, that the app may no longer be compatible in a future system version, that requires 64-bit applications, see:

32-bit app compatibility with macOS High Sierra 10.13.4 - Apple Support


You might be seeing this warning for iMovie 9.0.9, but not for the current version iMOvie 10.1.8.

Apr 22, 2018 10:11 AM

Reply Helpful
Question marked as Helpful

Apr 22, 2018 1:44 PM in response to Gibby503 In response to Gibby503

Getting error message that iMovie is now "incompatible

But what is the exact error message you are seeing - literally?

The most recent version of iMovie 10.1.9 requires macOS 10.13.2 or newer, but if I remember correctly, your version should be able to run on your system version.


What happened, before you saw the error message? Did you downgrade the system from High Sierra to Sierra?

Apr 22, 2018 1:44 PM

Reply Helpful (1)
User profile for user: Gibby503

Question: MacBook Pro (13-inch Early 2011), macOS Sierra (10.12.6)