Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Ethernet on 3rd Gen Apple TV

I cannot get my 3rd gen Apple TV connect to my network via the Ethernet cable. This used to work fine until my ISP (AT&T) installed a new high speed router/modem. I've gone round-n-round with AT&T tech support and they are pretty much useless as they keep saying everything is working properly on the router. The Ethernet ports are indeed working properly as I have multple Macs connected via the Ethernet ports. It's just the Apple TV's that no longer work over the Ethernet ports. Over wired Ethernet, I achieve a strong 84megs per second download speed which is totally ample to handle the Apple TVs. I actually have 3 different Apple TV's scattered throughout the house and I have tried all three (2 3rd gen and 1 4th gen) over Ethernet and all no longer automatically recognize the network nor do they permit any manual input of the needed network info either. Only wifi is available. And wifi would be an option, however, it drops signal WAY too much to be useful, which is why I'm wanting to use Ethernet. I have also tried swapping out the Ethernet cables to rule out "bad" cables but that isn't it either. Can you guys throw me a bone here? This is really quite frustrating.

Posted on

Reply

May 27, 2018 6:19 AM in response to DLimbert In response to DLimbert

I have also tried swapping out the Ethernet cables to rule out "bad" cables but that isn't it either.

You should be swapping devices to test the cables. E.g. run a notebook (or desktop computer) with the same ethernet cable as the Apple TV will be using, connected to the same port on the router, everything else the same. Then test the network: go to any site (DNS test), connect to the iTunes Store, disconnect/connect to an NTP server (automatic date & time), connect to a shared iTunes library (discovery, sharing). Then the network will be okay for the Apple TV.

If the Apple TV is then still unaware of the ethernet network, then possibly the ethernet port on the box is broken.

May 27, 2018 6:19 AM

Reply Helpful
User profile for user: DLimbert

Question: Ethernet on 3rd Gen Apple TV