Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: the disk you inserted was not readable by this computer

I have been using a Lexar USB for a while with no problems. I shut down my computer and when I powered back up and inserted my disk i received this error. I removed and inserted disk many times and received the same message. I did also click all of the options, eject, ignore and initialize at some point. I went to disk utility and did the first aid option and it failed. It appears that the data is still there because it is showing as fully used to capacity of 16GB, but I am not sure if that is correct. I am scared to do the restore option because I don't know if it will completely erase all of the data. Please help. I have been reading options on internet for hours. I can't afford to lose my data. I have MacBook air Sierra OS 10.12.3 thank you in advance to anybody who can help.

MacBook Air, OS Sierra 10.12.3

Posted on Aug 18, 2018 1:31 AM

Reply

Aug 18, 2018 7:55 AM in response to dcfromnj In response to dcfromnj

do the restore option


If you are referring to the Disk Utility Restore option, that won't erase the disk.


Get an external drive with no data on it. Select the USB drive in Disk Utility/Restore, then select your USB Drive in Restore from. Select the new drive as the destination. This will likely reformat the external drive erasing all data.

Aug 18, 2018 7:55 AM

Reply Helpful

Aug 18, 2018 3:12 PM in response to Eric Root In response to Eric Root

Eric,

Thank you so much for responding. I tried what you suggested with a new USB and restoring from my old USB in the Disk Utility/Restore screen and it is not allowing me to select my old USB as an option to "restore from".I even had someone help me follow the instructions you gave. They couldn't do it either. I have both plugged in and on the left panel they are both listed but when I go to do the restore feature it does not list my old USB in the drop down box in order for me to select it. I also tried plugging my old USB (the one that is unreadable) into a windows computer and it states that it needs to be formatted. I will try to call or taking to apple store. I am also considering purchasing one of those online recovery programs. I'm desperate! Thanks for your response.

Aug 18, 2018 3:12 PM

Reply Helpful
User profile for user: dcfromnj

Question: the disk you inserted was not readable by this computer