Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Question:

Question: Mojave time machine back up failing

Since installing 10.14 have not been able to complete a full backup using time machine to external drive. All disks check out on disk utility first aid both under OS and stand alone utility under recovery. Have erased and reformatted the external drive. Still no success. Backup begins and runs up to about 80GB ok, then fails. Restart by "back up now" continues for about 500MB and then fails again. My full backup is about 900GB so I am running unprotected.

I believe this is a Mojave problem, not a drive problem.

Any ideas?

Mac mini, macOS Mojave (10.14), Samsung display

Posted on

Reply
Question marked as Helpful

Oct 6, 2018 12:01 PM in response to namuang26 In response to namuang26

Hi guys,

I'm the developer of this application.


I apologize for the inconvenience you could have with the issue.

We have prepared the application update with the bug fix and sent it to App Store. Now App Cleaner v.6.2 update is being reviewed by Apple. I hope Apple will approve and release the update to App Store in a few days.

Since update v.6.2 is released and launched the folders will be removed, the issue will disappear.


Now, there is a simple way to bypass the issue - just add the folder

"~/Library/Containers/com.nektony.App-Cleaner"

to Time Machine exclude list.


The detailed guide how to exclude the folder from backups that is available on our website

https://nektony.com/mac-app-cleaner/troubleshooting


Regards,

Serge

Question marked as Helpful

Oct 6, 2018 12:13 PM in response to georosejr In response to georosejr

The simplest solution is to add the folder to the Time Machine exclude list.

Look at my previous answer in this thread how to do that.


One of the folders was created by App Cleaner v.5.4, another one was created by version 6.0.

You can remove those folders, if you are using only application v.6.0, there will be only one folder.

Serge

Question marked as Helpful

Oct 6, 2018 5:54 AM in response to namuang26 In response to namuang26

Like I mentioned earlier, the case sensitive workaround is masking an underlying issue that Apple still needs to address. The good news is that formatting your Time Machine backup drives as case sensitive should have no negative side effects since the disk that Apple uses in the Time Capsule version of their Airport product comes formatted this way. So even when Apple fixes the underlying issue you can continue using your case sensitive formatted Time Machine backup disks.


Note that the format of your Time Machine backup disks do not have to match the format of your Mac's operating system disks. Your Mac can be using any supported format, e.g., APFS, Mac OS Extended (Journaled), etc., and still back up to a Time Machine disk formatted in any of the supported formats that Time Machine works with. By the way, Time Machine backup disks cannot use APFS.


In a perfect world all disks would be formatted case sensitive. It is more secure and logically correct. Unfortunately some legacy operating systems were only case insensitive and programmers took advantage of this sloppiness allowed by those old operating systems. There are some very large applications, for example some of Adobe's, that break if you try to run them on a case sensitive drive. These apps probably have a lot of legacy code in them and the developer doesn't want to clean it up because it's still working. But since you're not running applications on your Time Machine disks, using case sensitivity fro Time Machine is not a problem. Time Machine disks are simply used for storage and all of the disk formats supported by Time Machine are fully "case preserving" which means they will never change the name of a file even if the case insensitive file system doesn't care.


In any case, Time Machine was designed to work with case sensitive and case insensitive formatted drives. There is currently a bug in Time Machine that is masked when case sensitive formatting is used on the backup drive. From reading this forum it sounds like there may be other things like the name of an App Cleaner & Uninstaller file that is triggering the bug. But deleting that app is not a fix either, it's simply avoiding a condition that causes Time Machine to fail when it should either tolerate the file naming error or flag it. Time Machine should be resilient to such user/app induced anomalies and not fail the entire backup process.


Finally, others have mentioned deleting the "inprogress" container from the Time Machine backup disk. At least on my machine, I am not able to delete this container. It gets marked for deletion and moved to the trash bin, but I cannot remove it from the trash bin even with admin privileges. This container stays in the trash bin forever until I reformat the Time Machine backup disk, which means it is still on the Time Machine disk. Not sure if this matters, but it's another piece of information for the Apple engineers to consider.

There’s more to the conversation

Read all replies

Page content loaded

Sep 30, 2018 11:43 AM in response to namuang26 In response to namuang26

I get a "backup failed" error message in notifications after but not before the backup finishes and Time Machine shows the files have been backed up. I assume a restore would fail but wouldn't want to find out. I have removed the latest backup folder which has been suggested by some and this does not cure the problem. I now have an "inprogress" file suffix running with Time Machine inFinder and the System Preference for Time Machine indicates it stuck calculating the time remaining and shows it is backing up 1.3 MB of 11.38 GB. My Time Machine folders are much larger that than 11.38 GB. I am going no going to disconnect Time Machine but I think it would only work for restoring an individual file and not everything as before.

Sep 30, 2018 11:43 AM

Reply Helpful

Sep 30, 2018 1:34 PM in response to namuang26 In response to namuang26

Same thing! I just made a topic about it on here and Reddit and everyone seems to think its a problem with my drive despite knowing for a fact that my drive is perfect and this issue only started after upgrading to Mojave!

Sep 30, 2018 1:34 PM

Reply Helpful (1)

Sep 30, 2018 4:37 PM in response to Dr_Macintosh In response to Dr_Macintosh

I also tried deleting the "inprogress" file including the trash file which takes a while. I then unchecked daily backups in the System Preferences for Time Machine as well. After a restart of my MacBook Pro the ensuing backup ended with the same "Time Machine Failed" message. Disk utility indicates the Backup volume is good. Finder shows the last backup folder is dated Sep 27 at 6:30 PM which is shortly before I installed Mojave. Nothing shows since then in Finder but files do show up when I enter Time Machine for files created after that date and time. Something is really screwed up.

Sep 30, 2018 4:37 PM

Reply Helpful

Sep 30, 2018 4:46 PM in response to georosejr In response to georosejr

Agreed - Mojave TM is screwed up and needs to be fixed. It is not a drive hardware problem (although of course some users may have that also). So until Apple issue a patch try SuperDuper (download from ShirtPocket.com) as suggested by dwilco268. Simple and works fine...

Sep 30, 2018 4:46 PM

Reply Helpful (1)

Sep 30, 2018 5:18 PM in response to namuang26 In response to namuang26

I may have to try an alternative backup system but will wait a while. Time Machine has been good to me. Last year I upgraded my Mac Mini with a 500 GB SSD and restored the Sierra OS to the new drive with Time Machine. It went very smoothy with no hitches. It now runs High Sierra with no problems. I need the Mac Mini for my Hi Def music that is connected to a high end audio/video system with a supplemental app that makes iTunes just a file system for my music downloads in Flac or Alac. Fortunately or unfortunately as the case may be, there is no Mojave option for the Mini so I don't have another Mac to see if the problem can be replicated.


I digress but am happy I have an alternative OS to fall back on, a Chromebook. I will not say any more about it as I am getting way off the subject.

Sep 30, 2018 5:18 PM

Reply Helpful

Sep 30, 2018 10:30 PM in response to namuang26 In response to namuang26

Apple has been unable to identify the problem or offer a solution that worked from my time with them on Twitter. I'm going to tell my support rep to escalate this to an engineer so that someone actually know about this and it can get fixed.


I have been raising **** on Reddit and hopefully someone will notice that this issue isn't isolated to me or a result of my specific config.

Sep 30, 2018 10:30 PM

Reply Helpful (2)

Oct 1, 2018 6:06 AM in response to Dr_Macintosh In response to Dr_Macintosh

Sorry I didn't see this post and I started another one. I have the same problem with Time Machine. I even replaced the HDD in my Lacie 4TB external Thunderbolt drive as it was around 4 years old. Backups still fail. I tried a new external disk and yes the same problem. The backups start OK but around half way through a 400GB backup data transfer slows and eventually throws up the error message. No issues under High Sierra.

Oct 1, 2018 6:06 AM

Reply Helpful

Oct 1, 2018 1:11 PM in response to Pathfineroz In response to Pathfineroz

Yes,

In previous versions, the problem of the ever growing backup (endless) was fixed by excluding the directory where it stored its work files.

Adding /Users/Shared/adi to the exclude list was enough.

It looks like TimeMachine is not using that folder anymore, but stores that always growing data somewhere else, triggering the problem: as TimeMachine moves on, the total size of data to be backed up grows with it until it reaches a full disk, no matter what disk size you have.

Too bad.

Oct 1, 2018 1:11 PM

Reply Helpful
User profile for user: namuang26

Question: Mojave time machine back up failing