Macs and Software that will run with Snow Leopard (Mac OS X 10.6.x)

Version 89
Last Modified: Sep 30, 2015 5:40 PM

Tips on 10.4 Tiger, 10.5 Leopard (last compatible operating system for G4 867 and above, and G5s), 10.6 Snow Leopard (end of the line for PowerPC applications), 10.7 Lion, 10.8 Mountain Lion, 10.9 Mavericks,

10.10 Yosemite, and 10.11 El Capitan.


Note this tip, and the series of tips from 10.3 (10.3 not mentioned in above links as people must have 10.4.4 or later on an Intel Mac to get to 10.6) to 10.9 I've written here all refer to Mac OS X Client.  Server versions of Mac OS X may have different limitations, and the people visiting the appropriate Server forum may be able to answer your questions better about Mac OS X Server.


When determining your Mac model, see this tip to find its age:


I would not downgrade to Leopard without erasing your data first.


Be sure to backup your data first at least twice before installing any operating system.  Shut down, and disconnect any peripherals before continuing with the installation. Read the info below to ensure you are compatible.  Finally, you may need to use the Startup Manager to boot the operating system when the 'C' key doesn't work in order to get the installer to work or repair the disk before installation if the initial attempt to install fails.  To determine if that repair is necessary, post to the forum, and someone will be able to help you to find out which repairs might be necessary.


Java is outdated in terms of security in Mac OS X 10.6.  Backup your data and at least update to 10.6.8 if your Mac says it is Intel in Apple menu -> About this Mac.   Read about updating to 10.7, and this tip about how to optimize your Java in 10.6 if you are stuck with 10.6.


10.6 retail is available from the Apple Store on (the /us/ in the link may be changed for the standard two letter country code matching the store link).  Note: Macs newer than April 1, 2010 but older than July 20, 2011 must use the original 10.6 installer disc that shipped with them to boot 10.6 from CD.  AppleCare may have those discs if you lost or misplaced it.  To determine the age of a Mac, plug it in the support status search engine, and use the serial number lookup.  Using the model name, find the release date of that model on Wikipedia or, and the followup date.


Leopard (10.5) is not to be confused with Snow Leopard (10.6) which are different paid operating systems.


If you are interested in upgrading to Lion you can read this tip, and Mountain Lion or Mavericks, this tip.  Note: Mavericks you can update to

for free, whereas both Lion and Mountain Lionyou can not.  Lion requires a minimum of 10.6.6 already be installed, unless you have the USB Flash drive for it, and Mountain Lion and Mavericks requires a minimum of 10.6.8.   Lion and Mountain Lion have different hardware requirements, but the Apple hardware requirements for Mavericks are the same Mountain Lion.


If you got a machine that came with Lion or Mountain Lion and wonder if you can install Snow Leopard on it, read the bottom of this tip first.


Snow leopard is available free for a limited time from this link if you have Mobileme and need an upgrade path to Lion that doesn't require erasing your hard drive.


Flashback malware has a patch on 10.6.8.  Users of 10.6.7 and earlier are recommended to disable Java.  For more info read this tip.


Macs that were released new as of July 20, 2011 or later, will generally not run Snow Leopard unless you follow this tip for Snow Leopard Server virtualization. Other than that, the following statements are true:

All Mac Pros will work with Snow Leopard (10.6.x), and they look like:




The PowerMac G5 towers which look like:


will not work with Snow Leopard.  Neither will the ones that are beige, blue, or graphite colored with plastic cases.


All Apple notebooks labelled MacBook with at least 1 GB of RAM, MacBook Pro, and MacBook Air below the screen or will work with Snow Leopard.
Apple notebooks labeled iBook, and Powerbook beneath the screen will not work with Snow Leopard.  Note, many of the newer MacBook Airs and MacBook Pro no longer have the label on the bottom of the screen frame, and you have to shut down the Mac, and look under the Mac for its label.  Those may only be able to use the aforementioned virtualized Snow Leopard Server.


Mac minis with at least 1 GB of RAM and 4 and 5 USB ports on the rear as shown in the image below:


Mac Mini PowerPC.jpg


will work with Snow Leopard.
Those with less than four USB ports will not work with Snow Leopard.


All iMacs that look like:

iMac Intel.jpg


Will work with Snow Leopard.


From the iMacs which look like:


iMac G5.jpg


If they are iMac Intel they can upgraded to Snow Leopard. To tell if they are Intel, they will have an EMC# on the base which is enumerated 2104, 2105, 2110, 2114, 2118, 2111, 2133, or 2134.  All others were iMac G5. Another distinction is that iMac G5's had mini-VGA ports that looked like:


Whereas iMac Intels had mini-DVI which looked like:





You can also tell if it is an iMac Intel by selecting Apple menu -> About This Mac. Core Duo and Core2Duo are Intel, whereas the G5 are not.


Notes: G5 refers to the CPU made by IBM for Apple before the migration to Intel CPU in 2006. It was found on iMacs, and PowerMacs. Powerbooks and iBooks maxed out using the Motorola G4 CPU, only to be replaced by MacBook Pros and MacBooks in 2006.. Intel made the CPU found in 2006 and newer Macs, and these are referred to as CoreSolo, CoreDuo, Core2Duo, i3, i5, i7, and Xeon. Don't confuse a G5 for an Intel CPU Mac. They are not the same except in exterior design when it comes to the iMac, and the means to tell them apart is stated above. In 2006, the Mac Mini changed from G4 to Intel CoreSolo CPU. In 2006 the iMac changed from G5 to Intel CoreDuo CPU.


All Intel Macs with sufficient RAM older than March 29, 2010 can take the retail 10.6.3 installer disc.  All Intel Macs with sufficient RAM older than August 28, 2009 can take the 10.6.0 retail installer disc.  This disc must look like snow.jpg and can't say Upgrade, Dropin, or OEM on it.


It is recommended those upgrading from PowerPC follow this tip:


It is recommended you backup your data at least twice before upgrading any software.


It is recommended you check these listings for compatible 10.6 software from:
C!Net, Snow Leopard Wiki,Macintouch, and Apple's listing of compatible printers and scanners


and Apple supplied updates for printers and scanners:


HP, Ricoh, Canon, Epson, Brother,Lexmark, Samsung, and Fuji/Xerox


Additionally, some Ricoh printers that do not have official drivers have been found to have the resolution documented by this thread:

Can't print from mac book pro to Ricoh Aficio MP C4500


And Apple's phone support with iSync:


For digital cameras, these RAW formats are supported on 10.6.  Note the most recent Mac Mini, iMac, and MacBook Pros

have SD card slots for reading camera media.  For all other camera media, Express/34 on 17" MacBook Pro and pre-June 8 2009 MacBook Pros, PCI  for Mac Pro, USB, and Firewire card readers exist for all Intel Mac models.  Additionally, many multifunction printers have card readers that will work on the Mac.  JPEG, TIFF, PNG

are all common formats supported by cameras outside of RAW, though RAW enables you to post process many more features of digital images than the other formats.


To be compatible with the Mac App Store, the Lion updater from the USB Flash drive or App Store, and the Facetime video software in Standard Definition minimum, you'll need the 10.6.6 combo, 10.6.7 combo, 10.6.7 combo with the font update, or the 10.6.8 combo followed by the Thunderbolt update if applicable.

10.6.8 has the following security updates: 10.6.8 2013 Security Update 004, 2013-005 Java update (note Java is not current until Mac OS X 10.7.3 from


Sometimes when 10.6 is installed, Rosetta, the application that allows PowerPC programs to run will not automatically install.  In those situations, you can manually install Rosetta from the 10.6 installer disc.  The following quote explains how to install it manually:


Insert the Mac OS 10.6 installation DVD When the DVD is mounted, select “Optional Installs” then “Optional Installs.mpkg”

Follow the onscreen instructions for agreeing to the software license and selecting the hard drive for installation.

In the “Installation Type” step, select the box next to Rosetta from the list of applications presented. Continue the installation process.

After successful installation, a confirmation message will appear.


These instructions appeared on .




As 10.6 is the last operating system that shipped on prebundled discs that come with Macs, it also is the last one that shipped with a prebundled set of iLife applications.  To learn which version of iLife may have come on your computer, see this tip.   10.7 and later prebundled Macs did not ship with iDVD, but will have shipped with iPhoto, iTunes, Garageband, and iMovie.   If you still desire iDVD, consult with AppleCare.


10.6 has these updates available depending on what you have on your Mac (Combo updates can be applied to any of the preceding versions, where Delta can only be applied to the immediately preceding version): Delta 10.6.2 Combo10.6.3 v1.1 Delta and 10.6.3 v1.1 Combo10.6.4 Combo, 10.6.4 Delta, 10.6.4 Mac Mini Mid 2010

10.6.5 Combo Delta

10.6.6 Delta10.6.6 Combo10.6.7 for early 2011 MacBook Pro, 10.6.7 Combo, 10.6.7 Delta, 10.6.7 font update to all previous updates10.6.8 delta v1.1 (7/25/2011) and Combo v1.1 (7/25/2011), and the followup Thunderbolt update for 2011 iMacs and  MacBook Pros for installation after 10.6.8


Which Macs can have Snow Leopard installed, and which can only have Lion installed based on Machine ID (also known as Model Identifier)?

You can find out which gray installer disc came with Macs that can install Snow Leopard newer than March 15, 2010 by reading:    Machine ID is in Apple menu -> About This Mac -> More info (on 10.7 and later the About Window has System Information instead of More info to access the System Profiler) under the hardware section.  The "x" value below can be any number.  Older Macs indicated below can use the 10.6.3 retail installer, if not the 10.6 retail installer, if they are older than August 28, 2009.  Together with partitioning, the Core2Duo (not CoreDuo, not CoreSolo), Xeon, Core i3, i5, i7 Macs which are Snow Leopard compatible can run both Snow Leopard and Lion, provided they have at least 2 GB of RAM.  Partitioning requires an erase of the hard drive. A second internal or external hard drive can boot into a separate operating system on the same Macs. The Macs below which can only run Lion and later, are also known as Lion prebundled Macs.  Lion prebundled Macs thankfully can run Windows in virtualization, which would allow them to use the Windows version of software that may only run in Snow Leopard and earlier on Mac OS X.  The Macs listed here that won't run Snow Leopard also are not able to use the retail Lion installer USB Flash drive, and must use the instructions on Macworld to create a specialty Flash drive or be cloned onto another hard drive before their prebundled hard drive dies, to be able to restore Lion.  Macs below that can't install Snow Leopard directly may be able to do so via virtualization, as described by this tip.


Mac Mini 5,x and later only run Lion and later.  Mac Mini 4,x and earlier can run Snow Leopard with at least 1 GB of RAM (that's greater than 768MB of RAM).


MacBook Pro 8,x with EMC#s 2355, 2563, 2564 can only run 10.7 or later, all other 8,x EMC#s can run 10.6.3 or later, and all 7,x can.

MacBook Pro 9,x and higher can only run 10.7 and later.


Mac Pro 5,1 that are not EMC 2629 and earlier can run Snow Leopard.   EMC 2629, and Mac Pro 6,x and later can only 10.7 and later.

The 10.6.3 retail installer will only work on Mac Pro 4,x and earlier.


MacBook with no Air and no Pro on the screen as of 11/30/2011 can all run Snow Leopard with at least 1 GB of RAM.


MacBook Air 4,x and later can't run Snow Leopard, while 3,x and earlier with at least 1 GB of RAM can run Snow Leopard.


iMac 12,1 i3 (EMC 2496 on foot, MC978LL/A) can't run Snow Leopard, while the 12,x i5 and i7 can run Snow Leopard, and the iMac 1,1 through 11,x can run Snow Leopard with at least 1 GB of RAM.  iMac 13,1 and later can't run Snow Leopard natively.


Lastly, here the Macs that are compatible with 10.6.3 retail avialable from the Apple Store based on Model Identifier:


iMac 11,1 and older

Mac Mini 3,x and older

MacBook 6,1 and older

MacBook Pro 5,x and older

MacPro 4,x and older

MacBook Air 2,x and older


Macs that fall between those criteria must use the 10.6 installer that shipped with them to install 10.6.



* The release names Early and Late can be gotten by plugging the serial number of the machine in