Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Mounting smb shares after upgrade to Catalina not working

I have a NAS storage device connected to my router on my internal network which is protected by a username & password. Prior to the upgrade to Catalina my 2016 15" Macbook Pro had no issues connecting to these shares using smb://routername/share. After the upgrade to catalina I can no longer connect to the network shares. It keeps asking me for my username & password, and no matter what I enter the dialog box keeps coming back. When I try on the command line using "mount_smbfs //username:password@routername/share mountpoint" I keep getting the error message "mount_smbfs: server rejected the connection: Authentication error". If I go into the router and remove the credentials from the shares, then the mount works fine. I know the credentials are correct (I reset them in the router).


I've also re-enabled NetBIOS as described in this article (https://medium.com/@gobinathm/how-to-access-smb-printer-shares-in-macos-catalina-10-15-17ea91d2c10b) but that did not help.

MacBook

Posted on Oct 8, 2019 6:12 AM

Reply
Question marked as Helpful

Oct 8, 2019 7:43 AM in response to edeandrea In response to edeandrea

@eandrea - I tested changing the protocol setting, and as expected, when I set it to 1 I no longer could 'see' the other SMB share. When I removed it, the share re-appeared. However, on both settings I still couldn't access the NAS share.


I have a sneaking suspicion that there is some issue with SMB version 1.0 access. And I would bet your NAS server uses SMB 1.0 as well.

Oct 8, 2019 7:43 AM

There’s more to the conversation

Read all replies

Oct 8, 2019 6:44 AM in response to edeandrea In response to edeandrea

I too have the same issue. I also have a Windows 10 PC with SMB sharing enabled on my home network. I can access the Windows 10 SMB shares from my Mac, but not the router's NAS share. I do know from experience with the Windows 10 PC accessing the NAS share, that SMB version 1.0 access has to be enabled from the client in order to work with my NAS share, which I think uses plain-text passwords, which is not enabled by default in the /etc/nsmb.conf file. I've enabled this (minauth=none), but I still can't access the NAS SMB share. Is there another setting somewhere I'm missing?

Oct 8, 2019 6:44 AM

Reply Helpful

Oct 8, 2019 7:30 AM in response to edeandrea In response to edeandrea

smb_neg has been obsolete since Sierra. It is replaced by protocol_vers_map, which according to the man pages defaults to 7, which supports versions 1/2/3. I could try setting this to 1, for version 1 only. I would then expect my access to the Windows 10 PC shares to fail. I'll test this.

Oct 8, 2019 7:30 AM

Reply Helpful
Question marked as Helpful

Oct 8, 2019 7:43 AM in response to edeandrea In response to edeandrea

@eandrea - I tested changing the protocol setting, and as expected, when I set it to 1 I no longer could 'see' the other SMB share. When I removed it, the share re-appeared. However, on both settings I still couldn't access the NAS share.


I have a sneaking suspicion that there is some issue with SMB version 1.0 access. And I would bet your NAS server uses SMB 1.0 as well.

Oct 8, 2019 7:43 AM

Reply Helpful (1)

Oct 8, 2019 8:01 AM in response to ksaro1 In response to ksaro1

Thank you for the confirmation @ksaro1. I confirmed that my NAS server does use SMB 1.0 via the smbutil statshares -a utility (I turned off authentication on my share and connected it):


==================================================================================================
SHARE                         ATTRIBUTE TYPE                VALUE
==================================================================================================
backup                        
                              SERVER_NAME                   REMOVED
                              USER_ID                       REMOVED
                              SMB_NEGOTIATE                 SMBV_NEG_SMB1_ENABLED
                              SMB_NEGOTIATE                 SMBV_NEG_SMB2_ENABLED
                              SMB_NEGOTIATE                 SMBV_NEG_SMB3_ENABLED
                              SMB_VERSION                   SMB_1
                              SMB_SHARE_TYPE                UNKNOWN
                              UNIX_SUPPORT                  TRUE
                              LARGE_FILE_SUPPORTED          TRUE



Oct 8, 2019 8:01 AM

Reply Helpful

Oct 10, 2019 12:26 PM in response to Buffloo In response to Buffloo

enable it in your NAS, I'm using an old WDSHARESPACE and it's in NAS network setting, what's your NAS model?

In compare to smb1 and CIFS, I feel my READ/WRITE speed is better now also.

I know, it's temporal solution till Apple solve the problem.

after enabling AFP in NAS. you can access it via finder:


afp://username@<NAS ip address>/sharefoldername

Oct 10, 2019 12:26 PM

Reply Helpful (2)

Oct 10, 2019 12:53 PM in response to rezamercury In response to rezamercury

In my case i just have an external USB drive that is attached to my router, so I have no control over the protocol being used. Shouldn't this be an issue with Catalina? If I turn off the authentication settings then it can connect. It only fails when I turn the authentication back on.

Oct 10, 2019 12:53 PM

Reply Helpful
User profile for user: edeandrea

Question: Mounting smb shares after upgrade to Catalina not working