Previous 1 2 3 4 5 6 Next 193 Replies Latest reply: Dec 19, 2013 2:12 PM by Mike S HT Go to original post Branched to a new discussion.
  • katsbits Level 1 (0 points)

    Finding this to be a constant problem that only gets fixed temporarily doing the "uninstall iTunes" thing. It always seems to return after a short while, seemingly after syncing back and forth rather than just one or the other as the primary sync device. Only thing that stops the sometimes 90% CPU use is to shut down AppleMobileDeviceService.exe from Task Manager.

    (Win XP Pro SP3)

  • armyofnine Level 1 (0 points)

    I'm having the same problem: Windows 7 64-bit with recently updated iTunes and Quicktime.  Now I can't sync and the CPU usage is pegged at 100%.  Glad to know it's Apple Software and not a more sinister problem, but disappointed that this a problem with Apple Software, too. :-(


    Trying the uninstall-reinstall fix.

  • gchin Level 1 (20 points)

    I also updated iTunes and Quicktime and still had the AppleMobileDeviceService.exe high cpu problem.


    I started iTunes and tried to sync my ipod touch. That got stuck doing backup(Step 1). After reading several other forums, recommended checking the backup folder.


    When I checked the backup folder in : documents and settings/username/application data/apple computer/mobilesync/backup/0147a3e...


    I saw in the newest folder under the backup folder, the newest item was related to Quicktime.


    So I decided to remove Quicktime from my computer.


    After doing that, AppleMobileDeviceService.exe cpu dropped to zero.


    Now I am downloaded Quicktime from Apple to install from scratch.


    After finishing the install, AppleMobileDeviceService.exe is high again.


    Then after watching a short video in iTunes, AppleMobileDeviceService.exe cpu dropped to zero.


    Anyone else?

  • MLefever Level 1 (0 points)

    I also have extremely high, 95-100, cpu usage coming from the AppleMobileDeviceService.exe.  I've tried uninstalling and reinstalling, still have the issue.  It has dropped to zero a few times but I'm really not sure why, though it does appear to have been after using iTunes.


    This is really frustrating me, any ideas?

  • andyfromchesbch Level 1 (0 points)

    I am also having these same problems with AppleMobileDeviceService.exe hogging up one processor and iTunes on the other.  I've tried a bunch of things documented here but with the same results......

  • SidCaesar Level 1 (0 points)


    Post a fix asap!!!

    AppleMobileDeviceService started hogging 50% of my CPU.

    I thought I would update my Iphone before disabling AppleMobileDeviceService

    Right now after an hour, both Itunes and AppleMobileDeviceService  are hogging 100% of CPU with no end in sight.

    This is ridiculuous.

    I will have to get rid of my iphone and ipad and move to better products, if Apple cannot make their products Windows compatible.

  • gchin Level 1 (20 points)

    Also see a simpler solution that solved the AppleMobileDeviceService.exe high cpu problem for me at:


    iTunes for windows - App Store's blank page - final solution





  • donfromhinton Level 1 (0 points)

    Wrestled this one for months...finally tripped over Article HTI925 Removing and Reinstalling iTunes, Quicktime, and other software components for Windows XP.


    Bottome line, I had to uninstall the components in a specific order (iTunes, then QuickTime, then Apple Software Update, then Apple Mobile Device Support, then Bonjour, then Apple Application Support.  I also cleaned the registry and other junk files, rebooted then rein-stalled the latest iTunes WITHOUT launching it after install.  Another reboot, launch it and now it's GREAT! 


    Also, I have VISTA.


    I think some module update caused a conflict...Bonjour was crashin too, the Service took excessive CPU even when iTunes wasn't launched, etc.  Hope this helps someone else, even tho I am too dumb to even find the correct link to the post I used to fix this.  Would like to give that guy credit - he nailed it!

  • tsonjapple Level 1 (0 points)

    I reinstalled 3 times and it solves the problem for several days or weeks but it comes back. This time I have gone through the reinstall procedure and I have stopped the auto updates. I'll let a few updates pass me by then just do a full reinstall every couple of months. Maybe this will work.


    Hey Apple, This is pathetic! Please fix this now!!!

  • donfromhinton Level 1 (0 points)

    Try this thread...the uninstall seems to need to be exact...



    Good luck, and I agree -- Apple -- what the heck?!  Maybe they don't want it to be too easy if u r not on a Mac...

  • saucecoda Level 1 (0 points)

    I've had all the above dramas on WinXP SP3 and have tried most of the suggested "fixes", to no avail.

    The only way to sort this out is to kill the AMDS Service from Task Manager.

    If you rarely use iTunes, then either disable the AMDS Service via the use of MSCONFIG, or set it to Manual (as opposed to Auto) start.

    If you need to use iTunes frequently, then kill the service immediately after boot up. When you need to use iTunes then start the AMDS Service before launching iTunes or connecting your Apple device. Then kill it again when you've finished.


    What's the old saying "An Apple a day wastes your time away"!

  • Scouser_stc Level 1 (0 points)

    Yes, this is what I do, keep it set to manual. Scotty the Windows Watchdog makes that process fairly easy:



    FYI, I downloaded a new version of iTunes the other day... of course it reset AMDS to run automatically, so everything came to a crawl again. I'm getting to the point of not synching my iPhone (with MS Excahnge, all my contacts/email synch aurotomctically over the air - thanks Microsoft!).


    When is Apple going to fix this? Is anyone from Apple reading this? How about an "official" post on what you're doing about it - or, going to do, & when?


  • Mike S HT Level 1 (5 points)

    Same problem here -- AMDS hogs 12% of the CPU after my iPhone sync is finished.  I noticed b/c my laptop fan runs at a higher setting when AMDS is hogging.


    Uninstalling/re-installing all Apple sw didn't help me.


    The easiest workaround I can think of is simple, though annoying:


    --If you don't have Microsoft's Process Explorer, get it.  If you have Windows, you should have PE.


    --Run PE w/ Admin privileges (right click and choose Run as Admin is one way).


    --Sort by the Process column and locate AppleMobileDevicerService.exe (not ...Helper.exe).


    --Right click and choose Suspend when you're done syncing.


    --Close PE.  When you're ready to sync next time (assuming that you haven't rebooted), open PE and choose Resume.  [On my system, the hogging only happens after a sync.]

  • saucecoda Level 1 (0 points)

    A Message to Apple Senior Management:


    You must realise that this problem with your AMDS service is causing serious disruption to maybe 10 million users of iTunes for Windows. You'll know the exact number of such users.

    The vast majority of users will have no idea what is causing their PCs to run like dogs; nor will they know that is this AMDS problem that causes their other programs to misbehave (I can quote specific examples:e.g. Nero CD cutting fails and ruins a CD because its processes can't respond fast enough).


    I predict that when this issue hits the mainstream IT and business media, Apple's brand and reputation will take a significant hammering.


    It's no good publicly ignoring this major issue; hoping it will be fixed with a "quiet" upgrade (the MS way of doing things). Take the initiative, be proactive and inform ALL users about the issue and tell them the steps you're taking to fix and thoroughly test the solution.

    If you do this before the problem hits "Big Media" you can actually play it to your advantage; your PR people will know how.


    If you continue to try to sweep this one under the carpet there's a very good chance it will come back to bite you badly.

  • MLefever Level 1 (0 points)

    I agree completely!


    I forget who gave the advice to completely remove all apple software (iTunes, Quicktime, Bonjour, Safari, etc) then reload, but that is exactly what I did and my PC is running as fast as it ever has, thank you!

Previous 1 2 3 4 5 6 Next