Announcement: Announcing the newest addition to Apple Support Communities, Apple Arcade!

If you have a question or knowledge to share with the community, we want to hear from you.

Announcement: Get Ready for macOS Catalina

Experience dedicated apps for music, TV, and podcasts, plus smart new features like Sidecar. Learn how to get ready >

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: No Wake-on-LAN possible since updating to ML

Hi everybody,


since updating from OS X 10.7 to 10.8 (clean install), Wake-on-LAN does not work anymore. Setup: Mac mini (Early 2011) connected to Time Capsule (2nd gen) via devolo dLAN. Mac mini goes to sleep after 30 minutes and eventually disappears from the network. Sending Wake-On-LAN packets or using Back To My Mac fail, it simply won't wake up.


Wake-on-LAN worked smoothly under 10.7 after some problems. Any ideas?


Thanks and regards


Steffen

Mac mini, OS X Mountain Lion

Posted on

Reply

Jul 31, 2012 1:07 AM in response to SteffenKaiser In response to SteffenKaiser

If you haven't done so already, check System Preferences > Energy Saver to be sure the Wake for Ethernet Network Access is selected under the Power Adapter profile. 10.8 reset my preferences on installation. Also note that Wake on Lan is not available when on battery power only. I don't recall if this was the case or not on Lion.

Jul 31, 2012 1:07 AM

Reply Helpful

Jul 31, 2012 1:19 AM in response to Alfred DeRose In response to Alfred DeRose

Thanks Alfred. The system prefs are alright and, of course, set to "Wake for Ethernet Network Access" is enabled. Furthermore, several programs and tasks are running in the backgound (Cubby, LogMeIn, hourly Time Capsule backup), but none of them brings the Mac back from sleep. Basically, the Bonjour Sleep Proxy should maintain the network connection to the sleeping Mac, but it's not working anymore. Even a direct afp connection to the sleeping Mac mini from within the local network fails. After it went to sleep, it disappears from the network.

Jul 31, 2012 1:19 AM

Reply Helpful

Jul 31, 2012 1:55 AM in response to Alfred DeRose In response to Alfred DeRose

Yes, wired. It's a wired Ethernet-over-Power Line connection, see www.devolo.com for technical details. WiFi is turned off. Anyway, wired and WiFi use the same static IP address within the LAN, it's alway 10.0.1.2, the standard host for NAT port forwarding. The network setup has always been this way and never caused problems. It has been running smoothly for almost 18 months now, using LogMeIn, Plex, jDownloader, EyeTV and other stuff for remote access via iPhone, iPad or web interfaces. Glitches started after upgrading to ML.


I just had the idea that the DHCP lease time configured in the Time Capsule might be the source of the problem. It was set to three hours, which explains why the Mac mini (10.0.1.2) eventually disappears from the list of network devices after it went to sleep: IIRC the Bonjour Sleep Proxy discards the IP reservation as soon as the lease time has elapsed, making the corresponding network device unreachable. Well, I cannot remember I changed anything in the network setting of the Time Capsule, but increased DHCP lease time to 60 days now. As soon as I get home, I will push the Mac mini's power button to re-register it's IP in the LAN and check if the new DHCP lease time solves the Wake-on-LAN issue.


I wonder why I did not run into that problem with Snow Leopard or Lion. Maybe they really changed something under the hood with regards to the Power Nap feature. For now, it's just guessing, so any further ideas are warmly welcome.

Jul 31, 2012 1:55 AM

Reply Helpful

Jul 31, 2012 2:04 AM in response to SteffenKaiser In response to SteffenKaiser

I sometimes have a problem with my Mini losing WiFi connection but haven't care enough to to investigate since I rarely need to connect remotely. DHCP might be the issue as you suggested so I'll look into that myself.


Might be worth trying a direct line into your router just to see if the pwer line connection is somehow contributing to the problem. i doubt it, but you never know.

Jul 31, 2012 2:04 AM

Reply Helpful

Jul 31, 2012 2:26 AM in response to Alfred DeRose In response to Alfred DeRose

You're absolutely right, one should rule out every possible cause for error. I will try a direct connection if the DHCP lease time does not solve the problem, but I doubt that the dLAN adapters have anything to do with the issue. Network traffic is running perfectly well.

Jul 31, 2012 2:26 AM

Reply Helpful

Jul 31, 2012 8:35 AM in response to SteffenKaiser In response to SteffenKaiser

Ok, I did not expect that, but it really seems to be connected to the dLAN adapters. They go to sleep as well, a few minutes after the mini did. That's why the connection breaks. I never had that behaviour with SL and Lion, but it seems to be the way it should have worked from the beginning.


I tried a direct connection between mini and Time Capsule and it worked perfectly well, at least a few minutes after putting the mini to sleep. I did not try a longer period of time as I have no possibilty to connect the mini directly to the router. My workaround will be disabling sleep mode until I find a solution.

Jul 31, 2012 8:35 AM

Reply Helpful

Jul 31, 2012 1:59 PM in response to SteffenKaiser In response to SteffenKaiser

I'm on a Mac mini connected to an Airport Extreme and experiencing the same issue with wake for internet access not working. It worked perfectly before, and now it does not.


My Macbook Pro appears to be working just fine with the same setup.

Jul 31, 2012 1:59 PM

Reply Helpful

Jul 31, 2012 9:48 PM in response to SteffenKaiser In response to SteffenKaiser

I am having this same problem. Once I upgrade I couldn't figure out why all my ports were giving me time out errors. I have services running on my mac that I access over the internet. After thinking about it, I narrowed it down to the sleep. Before ML my computer would wake up and I could connect fine. Now it is sleeping and will not wake up. I will have to change it to never also......


Guess the "power nap" changed something.

Jul 31, 2012 9:48 PM

Reply Helpful
User profile for user: SteffenKaiser

Question: No Wake-on-LAN possible since updating to ML