Previous 1 15 16 17 18 19 20 Next 294 Replies Latest reply: Sep 15, 2015 10:30 AM by rogercrocha Go to original post Branched to a new discussion.
  • SarahCat Level 1 (5 points)

    This is exactly what I determined a few weeks ago and I agree with artisticforge that the answer must come from the currently mute Apple and that never letting the Mac sleep is not the best.


    I never had the problem prior to using my new i7 Mini with Mountain Lion.


    Fixed IPs, even if they work around the problem, are not a good solution for a lot of us because they are not available to us.


    Apple Support - Major FAIL!

  • MackDougS Level 1 (5 points)

    The only solution I've found is as follows:

    Both my iphone and iPad are paired to my imac via Bluetooth.

    I keep the Bluetooth off. If I need to wake on LAN I just turn on my

    Bluetooth on my device and my imac wakes up. I shut off Bluetooth

    And use the home sharing.

    I'm not a programmer but it seems to me it should be an easy fix.

    Just use the same code that searches for BLuetooth have it look for home share.

  • SarahCat Level 1 (5 points)

    Bluetooth unfortunately has very limited range, i.e., not all over my home, so that is not a solution to me. That said, having multiple network connections in order to wake a host computer is really not worth it to me. I'm burning the watt-hours and never letting my poor Mac Minigo to sleep.


    I'm staging a sleep deprivation, much like a hunger strike until Apple fixes this.


    I'd buy my Mini a latte if there were Starbucks for Mac.

  • lexvo Level 1 (70 points)

    You are right that setting static IP adresses is not the final solution. I should have said "I may have found something that works FOR ME, for my particular setup" :)


    So far the solution for me is setting static IP adresses for my iMac, Airport Extreme and ATV3 AND disabling ipv6 on my iMac. Whether this is logical or not, it seems to be working and that's most important for me. For the first time in 7 months everything works as it should. :)


    There are numerous posssible solutions for this problem and I've tried a lot of them. I will keep an eye on it for a week to see if this solution lasts. I have tried too many solutions which failed after a few days.


    Before I couldn't have my iMac wireless wake on LAN when I put it to sleep manually. That is working now. And my ATV finds my iTunes library. So I feel I'm making steps in the right direction.

  • SarahCat Level 1 (5 points)

    Understood lexvo. I'm going with setting my Mac Mini to 'never sleep' until Apple fixes the wake on LAN problem. Not a good solution but I need to have reliable remote access and this same computer runs Indigo for home control. Curiously, Indigo running in an active OSX session will not wake the Mac when it attempts to execute a timed event, either. This was not the case with a much older Mac Mini running Snow Leopard or Lion.


    It appears that the only sure bet to wake my new Mac Mini running Mountain Lion is a local keyboard press or the power button. This my indicate a much bigger problem than just wake on LAN.

  • David Munch Level 1 (5 points)

    Just adding my voice here - My router has a static IP, and then it distibutes IP's internally by DHCP. WOL does not work for my Mini.

  • scooterb696 Level 1 (0 points)

    You need to edit the plist file for WOL to work fully on Mountain Lion as per below


    sudo vi /Library/Preferences/SystemConfiguration/


    look for the <string></string> line


    you are going to insert darkwake=8 in between the two string tags, navigate to there and press i and type in darkwake=8 so it now looks like below




    press escape

    and type :wq


    Reboot your mac and it will work


    Message was edited by: scooterb696

  • bjw Level 4 (1,325 points)

    A couple things:


    I checked the file scooter just mentioned on my iMac.  I don't have anything between the string tags.  But I'm not saying that his tip won't help by any means.


    I've been following this thread for a long long time.  My 2011 iMac has been through iterations of working and not working with regard to WOL.


    Currently it's working.  I've tried so many of the suggestions on this thread it would be impossible for me to pin down what fixed it for me.   My gut is that it was a clean install of Mountain Lion and applying the Combo Update for 10.8.3.


    I'm on 10.8.3 and have no intention of updating unless there's a VERY compelling reason.  


    I can wake up my iMac with Terminal applications and VNC apps.  I have an Aiport Extreme.


    One more thing:  I've noticed this thread has shifted somewhat to Mac Mini as the problem - maybe iMac isn't the problem so much anymore? 

  • scooterb696 Level 1 (0 points)

    I don't think this has anything to do with the hardware platform but to do with the OS version being run


    I have a 2009 Mac Pro with 10.8.4 with all latest updates and until I did my tip above WOL would not work


    Now it works every single time

  • artisticforge Level 1 (5 points)



    I have to look at the source code to know in my own mind why setting to darkwake=8 would appear to fix the problem.


    I have only the one mac mini running mountain lion the other 8 macs are running snow leopard.

    the mac-mini right now is not allowed to sleep, sleep deprivation. it works so I have time to research why this suggested fix works.

  • SarahCat Level 1 (5 points)

    Artisticforge apparently has joined my Mac Mini Sleep Deprivation strike. I, too would like know why this code hack works before I just blithely make a change like this to my Mac

  • lexvo Level 1 (70 points)

    Alas, the solution I described a few posts above quit working. This morning wireless WOL didn't work anymore.

    So I can note this one also as a solution that stops working after a few days.

  • GusBricker Level 1 (0 points)

    Ok, (joining in the research here) this is what I have found thus far, from perusing this file:


    The DarkWake parameter accepts the following flags (or logical additions of flags):


    // gDarkWakeFlags

    enum {

        kDarkWakeFlagHIDTickleEarly      = 0x01, // hid tickle before gfx suppression

        kDarkWakeFlagHIDTickleLate       = 0x02, // hid tickle after gfx suppression

        kDarkWakeFlagHIDTickleNone       = 0x03, // hid tickle is not posted

        kDarkWakeFlagHIDTickleMask       = 0x03,

        kDarkWakeFlagIgnoreDiskIOInDark  = 0x04, // ignore disk idle in DW

        kDarkWakeFlagIgnoreDiskIOAlways  = 0x08, // always ignore disk idle

        kDarkWakeFlagIgnoreDiskIOMask    = 0x0C,

        kDarkWakeFlagAlarmIsDark         = 0x0100


    It would appear that these flags pertain to circumstances under which a mac would be permitted to wake. Although a quick glance would indicate that wake on LAN does not seem to be one of them. The flags for DarkWake are apparently all for regulating sleep/wake from disk and HID.



  • GusBricker Level 1 (0 points)

    Also, check out the research done by this guy:


    Heaps of good ideas explored in there!

  • lexvo Level 1 (70 points)

    Thank you for sharing this! Very interesting read!