Skip navigation

No Wake-on-LAN possible since updating to ML

92061 Views 281 Replies Latest reply: Apr 11, 2014 5:32 AM by Abraham Zabih RSS Branched to a new discussion.
  • scooterb696 Calculating status...
    Currently Being Moderated
    Jul 25, 2013 2:29 AM (in response to SteffenKaiser)

    I know the solution that worked for me will probably not work for everyone and to be honest I don't have an explanation of why it has worked.

     

    I am on a wired LAN connection and not using WiFi and since making the change everything works as it should.

    I WOL from my Billion 7800N router which has this built in, so all I do is http to my router and click the button to issue the WOL and my mac springs to life. I know everyones setup is different.

  • SarahCat Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 25, 2013 11:50 AM (in response to scooterb696)

    It's amazing how much work has gone into researching this problem and as far as I can tell, none of it done by Apple, who actually has the fiduciary responsiblity for the problem; it's an Apple problem. Lots of work, novel setups, novel solutions which mitigate the problem for a brief period of time, Wake on LAN is a particular problem for me because it's not just a failure of wake on LAN, it's shown up as a failure of wake on an active application that has a timer (that would be Indigo, a home control application that has worked as long as the application is running) that only executes a command a few times per day.

     

    Another application, Splashtop Streamer, a remote access server has a setting to tell the computer never to go to sleep, which doesn't seem to work on Mountain Lion. I still had to go into System Preferences and specify in the power management system to tell the system never to sleep (that works, but now my Mac is always fully on and sleep mode is pretty much useless and thus irrelevent).

     

    Since it's Apple hardware, Apple OS, Apple network (with Apple firmware), it's not exactly like having an HP computer running Microsoft Windows and we have HP pointing fingers at Microsoft and vice versa. We have Apple users begging Apple to resolve the problem and point some fingers at themselves. This failure to wake from program control (which includes wake on LAN) is a major problem since it effectively disables the power management for any of us who are not using a Mac merely as an interactive endpoint device.'

     

    APPLE! WAKE UP! APPLE? Oh, it's not waking up...

  • Akadao Calculating status...
    Currently Being Moderated
    Jul 25, 2013 12:07 PM (in response to SarahCat)

    Well done! It is the best remarque I've read about this tip

  • Eric Root Level 6 Level 6 (13,910 points)
    Currently Being Moderated
    Jul 25, 2013 2:32 PM (in response to SarahCat)

    Send Apple feedback. They won't answer, but at least will know there is a problem. If enough people send feedback, it may get the problem solved sooner.


    Feedback

  • ffcphone Calculating status...
    Currently Being Moderated
    Jul 25, 2013 3:15 PM (in response to SarahCat)

    Actually Apple are taking an interest in this. They contacted by email around 8 weeks ago, got me to run some diagnostic tests on my Mac mini, email them various logs and results.

     

    Just because you've seen no evidence yourself that things are going on doesn't mean behind the scenes they are sat on their hands doing notning.

     

    I strongly suspect the OSX team have been pulled out working on Mavericks so wouldn't surprise me if WOL works great in that.

  • SarahCat Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 26, 2013 12:03 AM (in response to ffcphone)

    I'm glad there is some evidence of concern on the Apple side. I've discussed this problem in person at a couple of Apple Stores and via on line feedback and I have not been the recipient of much in the way of response. It's probably just my personality they don't like.

  • lexvo Level 1 Level 1 (60 points)
    Currently Being Moderated
    Jul 26, 2013 2:25 PM (in response to lexvo)

    Well, the darkwake=8 solution is not working for me.

     

    So I guess setting the computer to never sleep (only screen sleep) is the best option for now.

  • mikeSK Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 30, 2013 10:30 AM (in response to SteffenKaiser)

    I have been the same issue and I think I found a solution

    My setup is a Mac Pro connected by Ethernet to AEBS which is in bridge mode to a FiOS router serving DHCP and NAT.

    My solution involved:

    1. installing a small free program from the Mac App Store: Mobile Mouse Server (I had used it on a MacBook Pro connected to the TV). Start it and set to start at login. It is no going to be used. I believe it opens a port that registers with the sleep Proxy server (AEBS, Airport Express, or AppleTV)

    2. Activate networkoversleep: sudo pmset networkoversleep 1

     

    That's it. I tested this with Apple TV and the shared  iTunes library on the Mac Pro came up.

  • StigBull Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 29, 2013 3:23 AM (in response to SteffenKaiser)

    It seems like this is - if not fixed, than at least way, way, way much better in Mavericks.

     

    Can anyone else confirm?

  • bjw Calculating status...
    Currently Being Moderated
    Oct 29, 2013 6:26 AM (in response to StigBull)

    Works for me in Mavericks over wifi.  Not with wired Ethernet.

     

    Mid 2011 iMac. 

     

    I had wired working in 10.8.4 but only after a clean install.

    Current Mavericks install is an upgrade from 10.8.4.

  • vestax32 Calculating status...
    Currently Being Moderated
    Nov 6, 2013 1:35 PM (in response to bjw)

    I have recently swapped my BT (UK service provider) Homehub for a draytek stand alone modem and am using the Time Capsule as a router, not just in bridge mode as it was before. This seems to have solved ALL wake wirellessly problem. I can now see my Imac from apple TV and from the remote app on my iphone.

     

    This leads me to believe that the wake for network access function stopped working because Apple programmed the Mountain Lion update to only accept wake commands from other apple hardware (time capsule) and not from service provider wireless boxes such as the BT homehub I have been using. This would obvioulsy explain why it worked before the updat and not after.

     

    So I think the key is that you MUST have Apple hardware acting as the actual router (not just in bridge mode) and have a stand alone modem or have your service providers box set to modem only.

     

    If this is the case it would have been nice for Apple to have just told us this is what is going on!!!

  • StigBull Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 6, 2013 11:49 PM (in response to vestax32)

    I don't think it's because of non-Apple hardware, that's not my experience.

     

    I have exclusively used Apple equipment; MacMini's and Time Capsule at home, and Retina MacBook Pro at work.

    I have also used a command line utility I found which sends a wake 'magic packet'.

     

    2 out of 10 times the Mini did really wake on Lion and Mountain Lion, but with Mavericks it has so far worked every single time I try. Seems to work with or without the magick packet.

     

    For the record, the Mini has always been both wired and wi-fi connected to the same Time Capsule (so it can communicate with the printer and iPad/iPhone over wi-fi).

  • vestax32 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2013 12:21 AM (in response to StigBull)

    I have checked again this morning and its still working fine after a whole night of sleep.

     

    Stigbull, yes but what are you using as your modem/router?

  • StigBull Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 7, 2013 12:35 AM (in response to vestax32)

    It's a Thomson cable modem.

     

    I also set up port forwarding on the Time Capsule so it forwarded UDP ports 7 and 9 (the magic packet ports) to the Mini, but I have no idea if it had any effect, since the Mini woke so occasionally and randomly.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.