1 3 4 5 6 7 Previous Next 131 Replies Latest reply: Oct 11, 2013 7:29 AM by Maroquio Go to original post
  • 60. Re: Magic Mouse not "right clicking" after 10.7.5
    Dfhughes Level 1 Level 1 (0 points)

    Thanks Barthmr, its partially working for me.

     

    I no longer see the mouse diagram and the programmable button options but it is working with what I had tried to program before removing the AppleHIDMouse.kext to the trash.

     

    Dave

  • 61. Re: Magic Mouse not "right clicking" after 10.7.5
    BartHmr Level 1 Level 1 (0 points)

    You're welcome!

     

    If you ever need to make changes to your mouse settings, just restore the .kext file.

    The mouse settings will then display Mighty Mouse's features.

    I have verified that the changes you make will be used if you remove the file again.

     

    Bart

  • 62. Re: Magic Mouse not "right clicking" after 10.7.5
    TheSmokeMonster Level 4 Level 4 (3,240 points)

    http://support.apple.com/kb/HT1379

     

    Did we try resetting the PRAM?

     

    Contents of PRAM on earlier Macs

    Some earlier Macs store these settings in PRAM:

    • Status of AppleTalk
    • Serial Port Configuration and Port definition
    • Alarm clock setting
    • Application font
    • Serial printer location
    • Autokey rate
    • Autokey delay
    • Speaker volume
    • Attention (beep) sound
    • Double-click time
    • Caret blink time (insertion point rate)
    • Mouse scaling (mouse speed)
    • Startup disk
    • Menu blink count
    • Monitor depth
    • 32-bit addressing
    • Virtual memory
    • RAM disk
    • Disk cache
  • 63. Re: Magic Mouse not "right clicking" after 10.7.5
    Dfhughes Level 1 Level 1 (0 points)

    Smoke,

     

    When I contacted Apple support that is one of the first steps they had me try. It did not restore the mouse operation. They had me remove a couple of plist files as well that did not help either.

     

    Bart's solution is working but as he says program the mouse buttons to what you desire before removing the AppleHIDMouse.kext

     

    Maybe this solution will point Apple to the source of the problem?

     

    Dave

  • 64. Re: Magic Mouse not "right clicking" after 10.7.5
    marcusreese Level 1 Level 1 (5 points)

    I had the same problem after doing a clean install of 10.7.5. I fixed it by making a copy of the Apple HIDMouse.kext file and then taking out the Apple HIDMouse.kext file, restarting, drag the file back in and Authenicate, restart and that fixed it. I can right click the mouse again.

  • 65. Re: Magic Mouse not "right clicking" after 10.7.5
    Dfhughes Level 1 Level 1 (0 points)

    That's great Marcus but I am a bit confused.

     

    Why did you have to copy the Apple HIDMouse.kext file and which one did you take out or both?

    By taking out do you mean delete one and then drag the copy back in?

     

    Thanks,

     

    Dave

  • 66. Re: Magic Mouse not "right clicking" after 10.7.5
    Philip Keller Level 1 Level 1 (0 points)

    Unfortunately, Marcus' procedure (as I understood it) did not work for me. As Bart said, when I copied AppleHIDMouse.kext back to /System/Library/Extensions/, the control panel was restored, but the right-click disappeared again.

     

    Incidentally, I was unable to re-install the extension simply by dragging it into the Extensions folder; I got the following message on the console:

       com.apple.kextcache: AppleHIDMouse.kext is not authentic; omitting.

    I had to re-install the extension with a Terminal command, as follows:

       cp -R Desktop/AppleHIDMouse.kext/ /System/Library/Extensions/AppleHIDMouse.kext

     

    -- Philip

  • 67. Re: Magic Mouse not "right clicking" after 10.7.5
    marcusreese Level 1 Level 1 (5 points)

    Sorry I wasn't very clear. When I went to drag out the Apple HIDMouse.kext file from the System/Library/Exensions folder to the desktop, the file copied instead of being moved. I then deleted the original file and kept the one that copied to the desktop. I restarted and dragged the file from the desktop back into the System/Library/Extensions folder. It asked me to Authenicate with my user password, I typed in my password and the file copied into the Extension folder. I then restarted and my mouse's right click worked again. I only have one user account on my Mac and it's set to Admin.

  • 68. Re: Magic Mouse not "right clicking" after 10.7.5
    Dfhughes Level 1 Level 1 (0 points)

    Hello Marcus,

     

    Thanks for the clarification, I followed your steps exactly and was asked for the authentication as well. When I restarted the computer the right click was indeed working! Upon further investigation however I found the mouse icon and programmable options missing from the mouse preferance pane. Do you have the same?

     

    thanks again,

     

    Dave

  • 69. Re: Magic Mouse not "right clicking" after 10.7.5
    Philip Keller Level 1 Level 1 (0 points)

    Dave, Marcus,

     

    I'll betcha a nickel that if you look in your console and search for "AppleHIDMouse", you'll find the "AppleHIDMouse.kext is not authentic" message I mentioned above. I didn't investigate, but I imagine "not authentic" means "wrong owner / access rights". (A small, but important, mistake in my reply above: the terminal command was "sudo cp..." instead of "cp...").

     

    -- Phil

  • 70. Re: Magic Mouse not "right clicking" after 10.7.5
    Dfhughes Level 1 Level 1 (0 points)

    You are no doubt correct Phil, that is why the mouse is still working after authenticating the file, it is not being used by the system and that is why I still don't see the mouse control panel and the right click is still working.

     

    I didn't need to use the terminal command to restore the AppleHIDMouse.kext file, I have over the last couple of tries put it back from the trash which the system accepted and restored it from my time machine backup.

     

    Thanks BartHmr, Marcus and Phil for your assistance with this problem.

     

    Dave

  • 71. Re: Magic Mouse not "right clicking" after 10.7.5
    marcusreese Level 1 Level 1 (5 points)

    I just tried it on a different computer, moving the AppleHIDMouse.kext file out, restarting, moving it back in, Authenicate, restart again. I went to the mouse prefs and the mouse settings are still missing. The right click works but you can't change any of the mouse settings like tracking speed, double click speed. When I first checked the mouse extension, after the second restart, the extension was missing the system user rights. I ran DiskUtil repairpermissions which fixed the rights to that file but mouse system prefs is still missing the picture of the mouse and the setting you can change. When I get a chance I'll try Philip's terminal command.

  • 72. Re: Magic Mouse not "right clicking" after 10.7.5
    rchealey Level 1 Level 1 (5 points)

    Spurred on by some of the above attempts, I have finally fixed this by doing the following. I hope it works for others. You do need to get a copy of the kernel extension from a working mac however.

     

    (1) Take a copy of AppleHIDMouse.kext from another mac running Mountain Lion 10.8.2 (in my case). I imagine that this could alternatively be another Mac running Lion 10.7.5 but have not tested this.

     

    (2) Drag and drop copy this to /System/Library/Extensions/

    (You'll need to authenticate at this point to allow finder to do the copy.)

     

    (3) Open up a terminal window and change directory to /System/Library/Extensions/ using cd /System/Library/Extensions/

     

    (4)  Change the permissions and owner of AppleHIDMouse.kext via these terminal commands

    sudo chmod -R AppleHIDMouse.kext

    sudo chown -R root:wheel AppleHIDMouse.kext

    (I acknowledge help from http://osxdaily.com/2012/01/12/how-to-manually-install-kernel-extensions-in-mac- os-x/ I did not need to remove the kernel extension caches spoken of in the above article)

     

    (5) Reboot.

    The Apple Wireless mouse then right-clicks and the correct system preferences graphic appears for the mouse.

     

     

  • 73. Re: Magic Mouse not "right clicking" after 10.7.5
    t.kuerrev Level 1 Level 1 (70 points)

    Hi, rchealey,

    thanks for your efforts and reporting what you did. It sounds very good! The final solution? :-)

    I have a question concerning step 3: In the terminal I have to put in: cd /System/Library/Extensions/   ...?

    or what is the exact command? Does it mean, the folder is renamed to something else? What happens in this step exactly?

     

    I would appreciate if you could give me some extra private tuition.

    Thanks,

    Thomas

  • 74. Re: Magic Mouse not "right clicking" after 10.7.5
    rchealey Level 1 Level 1 (5 points)

    For step (3), in the terminal window type

     

    cd /System/Library/Extensions

     

    We are not renaming the folder. This command simply changes the working directory to the Extensions folder where the Kernel Extension lives so that when the chmod and chown commands are done, they will take effect on the AppleHIDMouse.kext that lives in the Extensions folder.

1 3 4 5 6 7 Previous Next